Calibre install errors chown: cannot access /home/calibre

    • OMV 1.0

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Calibre install errors chown: cannot access /home/calibre

      Newbie here, thought that I would try openmediavault on a amd 6 core cpu with 8gb ram 4 x 4tb raid 5, 2 x 3TB mirror, 1TB root, new to Linux so I have installed omv without errors, setup 2raids, omv-extras.org with the plex plug (works great), use Putty to control with http site, trying to install calibre but having an issues and not sure if it is something that I have done or what. This is the error message when installing the plugin

      2015-03-11 08:11:18 (4.19 MB/s) - `/tmp/calibre64.txz' saved [59868288/59868288]

      Extracting...
      update-rc.d: using dependency based boot sequencing
      insserv: warning: current start runlevel(s) (empty) of script `calibre' overrides LSB defaults (2 3 4 5).
      insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `calibre' overrides LSB defaults (0 1 6).
      insserv: warning: current start runlevel(s) (empty) of script `calibre' overrides LSB defaults (2 3 4 5).
      insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `calibre' overrides LSB defaults (0 1 6).
      insserv: warning: current start runlevel(s) (empty) of script `calibre' overrides LSB defaults (2 3 4 5).
      insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `calibre' overrides LSB defaults (0 1 6).
      chown: cannot access `/home/calibre': No such file or directory
      dpkg: error processing openmediavault-calibre (--configure):
      subprocess installed post-installation script returned error exit status 1
      Processing triggers for openmediavault ...
      Updating locale files ...
      Updating file permissions ...
      Purging internal cache ...
      Restarting engine daemon ...
      Errors were encountered while processing:
      openmediavault-calibre

      The calibre plugin appears but
      Error #2002:
      exception 'OMVException' with message 'Invalid method parameter: '' does not match '/^[a-f0-9]{8}-[a-f0-9]{4}-[a-f0-9]{4}-[a-f0-9]{4}-[a-f0-9]{12}$/i'' in /usr/share/php/openmediavault/rpcservice.inc:187
      Stack trace:
      #0 /usr/share/openmediavault/engined/rpc/sharemgmt.inc(1203): OMVRpcServiceAbstract->validateMethodParams(Array, '{\n\t\t\t "type":"...')
      #1 [internal function]: OMVRpcServiceShareMgmt->getPath(Array, Array)
      #2 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      #3 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('getPath', Array, Array)
      #4 /usr/share/openmediavault/engined/rpc/calibre.inc(285): OMVRpc::exec('ShareMgmt', 'getPath', Array, Array)
      #5 [internal function]: OMVRpcServiceCalibre->doImport(Array, Array)
      #6 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      #7 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('doImport', Array, Array)
      #8 /usr/sbin/omv-engined(500): OMVRpc::exec('Calibre', 'doImport', Array, Array, 1)
      #9 {main}

      Looks like a permissions issue for /home/? Tried to uninstall and reinstall but no luck. Have been doing a lot of reading on various calibre forums and sites but nothing has helped . appreciate any help.
      AMD-FX-6100 six core processor
      12gb ddr3 ram
      12TB
    • /home/calibre should be created right away with the correct permissions using the useradd function. Not sure how this would fail unless the calibre user already existed in the database. It also doesn't use that folder once you have enable the plugin.

      I would do the following as root:

      mkdir /home/calibre
      chown -R calibre:users /home/calibre
      apt-get -f install

      The invalid parameter is nothing to worry about. It happens occasionally because no shared folder is setup. Haven't had a chance to fix that.
      omv 4.0.11 arrakis | 64 bit | 4.13 backports kernel | omvextrasorg 4.1.0
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • Hey thank you for your help here, I followed the above without errors, it updated the local files, and file permissions purged internal cache, restarted engine daemon then it created index of packages, index openmedia plugins . checked the plugin on gui entered folder locations and still have



      Invalid method parameter: '' does not match '/^[a-f0-9]{8}-[a-f0-9]{4}-[a-f0-9]{4}-[a-f0-9]{4}-[a-f0-9]{12}$/i'

      Error #2002:
      exception 'OMVException' with message 'Invalid method parameter: '' does not match '/^[a-f0-9]{8}-[a-f0-9]{4}-[a-f0-9]{4}-[a-f0-9]{4}-[a-f0-9]{12}$/i'' in /usr/share/php/openmediavault/rpcservice.inc:187
      Stack trace:
      #0 /usr/share/openmediavault/engined/rpc/sharemgmt.inc(1203): OMVRpcServiceAbstract->validateMethodParams(Array, '{\n\t\t\t "type":"...')
      #1 [internal function]: OMVRpcServiceShareMgmt->getPath(Array, Array)
      #2 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      #3 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('getPath', Array, Array)
      #4 /usr/share/openmediavault/engined/rpc/calibre.inc(285): OMVRpc::exec('ShareMgmt', 'getPath', Array, Array)
      #5 [internal function]: OMVRpcServiceCalibre->doImport(Array, Array)
      #6 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      #7 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('doImport', Array, Array)
      #8 /usr/sbin/omv-engined(500): OMVRpc::exec('Calibre', 'doImport', Array, Array, 1)
      #9 {main}

      Sorry , not sure if I require to reboot or something else. Lots to learn. thank you for your patients.
      AMD-FX-6100 six core processor
      12gb ddr3 ram
      12TB
    • Yes that is the error message after inserting the settings that include , enable, data directory,user, password, shared folder, then I click import, the error message comes up, clicked on ok, then a box comes up says importing, stop is greyed out but close there, nothing happens. Should I try to uninstall?
      AMD-FX-6100 six core processor
      12gb ddr3 ram
      12TB