Deutsch: OMV von außen erreichbar machen

    • OMV 1.0
    • Deutsch: OMV von außen erreichbar machen

      Guten Tag liebe Forengemeinde,

      meinen NAS Eigenbau unter OMV möchte ich nun nach außen hin öffnen um die WebGUI, einen Teamspeak 3 Server und einen Minecraft Server von außen erreichbar zu machen. Dann soll auch OqnCloud hinzu kommen.

      Momentaner Stand:
      OMV ist eingerichtet mit Nutzern, NAS, Calm-AV...

      Ein Account auf selfhost.de ist angelegt.

      In meinem Speedport W 921 V ist die DynDNS eingerichtet, ihre Funktion wurde getestet.

      Ich habe versucht, den Port 80 weiter zu leiten, allerdings ist mir weder der Unterschied zwischen Port-Umleitung, Port-Weiterleitung und Dynamischer Portfreischaltung ganz klar, auch habe ich keine Ahnung ob ich TCp oder UDP weiter leiten muss.
      Nächstes Problem ist der Test... um von außen auf die WebGUI zu kommen müsste ich (name).selfhost.eu:80 oder (gerätename).(name).selfhost.eu:80 eingeben oder etwas völlig anderes?

      Dann müsste ich den SSH Dienst zum Laufen bekommen um von meinem PC aus auf die Kommandozeile zugreifen zu können.

      Dies wären erst einmal die Grundlagen, danach bräuchte ich Hilfe beim Konfigurieren von TS3 (schon installiert), Minecraft und OwnCloud (beide noch nicht in Angriff genommen.

      I also speak english, but german support from your community would be great!

      Vielen Dank im Vorraus
      Cronyk
    • Cronyk wrote:

      OMV möchte ich nun nach außen hin öffnen um die WebGUI


      Wieso brauchst du Zugriff auf die WebGUI von außen? Jeder der Zugriff auf die GUI erhält kann alle deine Festplatten löschen, oder schlimmeres.

      Cronyk wrote:

      Ich habe versucht, den Port 80 weiter zu leiten,


      Ganz schlechte Idee. Port 80 ist eine Klartext Übertragung. Jeder der will kann dein Passwort mitlesen. Aktiviere mindestens SSL über Port 443, oder nutze noch besser OpenVPN oder OpenVPNAS.

      Cronyk wrote:

      Nächstes Problem ist der Test... um von außen auf die WebGUI zu kommen müsste ich (name).selfhost.eu:80 oder (gerätename).(name).selfhost.eu:80 eingeben oder etwas völlig anderes?


      Wenn du im Router Port 80 auf Port 80 deines NAS weiterleitest, solltest du bei Zugriff auf deinen selfhost dns adresse, Zugriff auf deine WebGUI bekommen. Aber wie oben schon gesagt, keine gute Idee.

      Cronyk wrote:

      Dann müsste ich den SSH Dienst zum Laufen bekommen um von meinem PC aus auf die Kommandozeile zugreifen zu können.


      Ja dann schalte doch SSH in der WebGUI wieder an. ;)

      Cronyk wrote:

      danach bräuchte ich Hilfe beim Konfigurieren von TS3 (schon installiert)


      Und unhöflich zu sein, wir sind nicht das Teamspeak support forum :P Und soviel gibts da ja jetzt auch nicht was man groß konfigurieren muss.

      Cronyk wrote:

      Minecraft


      Auch hier das gleiche, auch nicht soviel was man einrichten braucht...

      Cronyk wrote:

      OwnCloud


      @tekkb hilft dir da bestimmt gerne weiter.

      Gruß
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • Ok, schlechte Idee, verstehe ich :)

      Es geht nicht um den Teamspeak Support, der Server läuft. Aber das Problem ist, dass ich jetzt die drei benötigten Ports
      UDP: 9987
      TCP: 10011
      TCP: 30033
      An meinem Speedport weiter geleitet habe. Und nun nicht weiß, wie die schlussendliche Adresse aussieht die ich dann im Clienten eingeben muss. Welchen Port wähle ich an?

      Dann gibt es noch Freischaltungen in der Firewall von OMV, muss ich die auch machen?

      SSH habe ich aktiviert, bei Port 3333 eingestellt. Dann den Port 3333 unter TCP Umleitungen im Speedport freigegeben und in die Adresszeile (name).selfhost.eu:3333 eingegeben. Seiten-Ladefehler. Wo ist der Fehler?
    • Cronyk wrote:

      Welchen Port wähle ich an?


      Da es der standardport ist, musst du beim connecten den Port nichtmal angeben.

      Cronyk wrote:

      Wo ist der Fehler?


      Dass du via HTTP auf den SSH Port zugreifst? Benutze PuTTY dafür.

      Gruß
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • Cronyk wrote:

      PuTTY sagt Network error: Network caused connection abort.
      Das heißt, dass zumindest Port und Hostname richtig waren, oder? Schwarzes Fenster geht auf.


      Das heißt blos dass er den Hostname auflösen kann.

      Cronyk wrote:

      Von TS habe ich alle Ports auf dieser Seite im Router und in der OMV Firewall mit passenden Protokollen Freigegeben:
      teamspeak.de/support/antworten…/Allgemeines%2Fa%2F1.html
      (name).selfhost.eu funktioniert nicht als Adresse


      Schick mir mal bitte via Konversation / Privater Nachricht deine IP und deine selfhost addresse, dann kann ich mir das näher ansehen.

      Gruß
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • Jetzt endlich steht das gesamte System UND....

      Ein Rechner kann nicht zugreifen.
      Im Explorer unter Netzwerk wird das NAS nicht angezeigt, muss ja auch nicht.

      Wenn ich bei Windows 7 Rechner 1 jetzt Rechtsklick -> Netzlaufwerk verbinden klicke und dann
      \\Locale IP (192.1xx.x.xxx)\Freigabenname
      eingebe hat er es. Der andere Windows 7 Rechner spuckt nur eine Fehlermeldung aus das das Netzlaufwerk nicht gefunden wurde.
      Gebe ich 192.1xx.x.xxx allerdings im Firefox ein erscheint die WebGUI, Verbindung ist also da.
      Weiß nicht weiter...
    • Cronyk wrote:

      Der andere Windows 7 Rechner spuckt nur eine Fehlermeldung aus das das Netzlaufwerk nicht gefunden wurde.


      Machs mal ohne Netzlaufwerk. Einfach im Explorer \\hostname eintippen und los gehts.

      Gruß
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • Windows Firewall? Mal ausschalten
      Heimnetzgruppe gleich? Datei und ... Freigabe aktiv?

      Gruß
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • Folgendes Update, wie es aussieht brauche ich euch noch ein letztes Mal:

      System ist aufgerüstet mit einer Intel Dual-Core CPU und nun insgesamt 8 GB RAM. Neuem Mainboard und 2 2TB Festplatten die im RAID laufen als Mirror. Alle Rechner im Haus können zugreifen. Minecraft und Teamspeak Server Laufen, alle Rechte und Benutzer funktionieren.
      Nur kann man von außen weder Minecraft noch Teamspeak erreichen. Die Portfreischaltungen sind alle noch aktiv und kontrolliert, DynDNS funktioniert noch, der Account steht und der Router ist auch noch eingerichtet. Habe ja nur die Hardware vom Server verändert also RAM, Motherboard, CPU und eine Festplatte. Die Systemfestplatte blieb unberührt*.

      Woran kann es liegen? Von "intern" kann ich auf MC und TS zugreifen. Von extern bekomme ich einfach einen Verbindungsfehler auf die DynDNS Domain.

      *
      Edit:
      Stimmt so gar nicht, ich habe Updates über den Assistenten gemacht.
    • Cronyk wrote:

      Nur kann man von außen weder Minecraft noch Teamspeak erreichen.


      Und die interne IP ist auch immer noch die gleiche wie vorher?

      Gruß
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • War sie nicht, sie hat sich von 192.168.1.165 zu 192.168.1.139 geändert. Da ich mir dachte, dass das Problem daran liegt habe ich sie aber in der WebGUI wieder auf die erste Nummer zurückgestellt. DIe Netzlaufwerke haben sich daraufhin auch automatisch wieder verbunden, das war dann allerdings auch schon alles.
    • Dann überprüf doch mal ob die Portweiterleitungen im Router noch so sind, wie sie gedacht waren.

      Gruß
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • Funktioniert es denn mit der WAN IP?

      Gruß
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • Auf was meinst du leitet DynDNS weiter? Eben auf deine WAN IP. Probier also mal ob der Zugriff mit dieser funktioniert.

      wieistmeineip.de

      Gruß
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • Die GUI hat keine moeglichkeit das anzuzeigen. Wie auch, sie kann ja gar nicht feststellen ob die Portfreigaben auch alle eingestellt sind.

      Gruss
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.