Cannot connect in FTP

    • OMV 1.0
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Cannot connect in FTP

      Hi all,

      I need some help to configure the ftp on my OpenMediaVault.

      I join my configuration :


      WHen I attent logging with Filezilla :



      Status: Connecting to XXX.XXX.XXX.XXX:21...

      Status: Connection established, waiting for welcome message...

      Status: Insecure server, it does not support FTP over TLS.

      Command: USER JC

      Response: 331 Password required for JC

      Command: PASS **********

      Response: 530 Login incorrect.

      Error: Critical error: Could not connect to server

      And if i connect with user 'Admin'



      Status: Connecting to XXX.XXX.XXX.XXX:21...

      Status: Connection established, waiting for welcome message...

      Status: Insecure server, it does not support FTP over TLS.

      Status: Connected

      Status: Retrieving directory listing...

      Status: Directory listing of "/" successful

      The Directory "/" is empty .

      I don't understand what it's the problem.

      Could you help me please?
    • I think too.
      I reset all privilèges but I can't connect.



      Status: Connecting to 192.168.0.101:21...

      Status: Connection established, waiting for welcome message...

      Status: Insecure server, it does not support FTP over TLS.

      Command: USER JC

      Response: 331 Password required for JC

      Command: PASS **********

      Response: 530 Login incorrect.

      Error: Critical error: Could not connect to server



      530 Login incorrect => Why? It's a problem with one group? I'm giving to him all groups?
      I have the same error with "root"

      But i can connect with "admin" but I can see only "/" but it's empty folder.

      I need change some ".conf" ?


    • What client are you using? You're trying to connect inside lan or from wan?
      Every user can login but only those indicated in privileges will see the shares (admin for example is not available in privileges, but he can login)
      To reset privileges is not to reset permissions. Can you clarify if you resseted permissions with the utility?
      Can you post here this command :
      cat /etc/proftpd/proftpd.conf
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server
    • Sorry, I use "Reset Permissions" with the utility.

      Source Code

      1. cat /etc/proftpd/proftp.conf :
      2. Include /etc/proftpd/modules.conf
      3. LoadModule mod_vroot.c
      4. UseIPv6 on
      5. ServerName "omv"
      6. ServerType standalone
      7. DeferWelcome on
      8. MultilineRFC2228 on
      9. DefaultServer on
      10. ShowSymlinks on
      11. DisplayChdir .message true
      12. ListOptions "-l"
      13. MaxInstances 30
      14. DenyFilter \*.*/
      15. AuthPAMConfig proftpd
      16. User proftpd
      17. Group nogroup
      18. Umask 000 000
      19. UseFtpUsers off
      20. PersistentPasswd off
      21. DefaultRoot /srv/ftp
      22. TimesGMT off
      23. AllowOverwrite on
      24. AuthOrder mod_auth_pam.c* mod_auth_unix.c
      25. DefaultTransferMode ascii
      26. #SystemLog /var/log/proftpd/proftpd.log
      27. <IfModule mod_facl.c>
      28. FACLEngine on
      29. </IfModule>
      30. <IfModule mod_quotatab.c>
      31. QuotaEngine off
      32. </IfModule>
      33. <IfModule mod_ratio.c>
      34. Ratios off
      35. </IfModule>
      36. <IfModule mod_delay.c>
      37. DelayEngine on
      38. </IfModule>
      39. <IfModule mod_ctrls.c>
      40. ControlsEngine on
      41. ControlsMaxClients 2
      42. ControlsLog /var/log/proftpd/controls.log
      43. ControlsInterval 5
      44. ControlsSocket /var/run/proftpd/proftpd.sock
      45. </IfModule>
      46. <IfModule mod_ctrls_admin.c>
      47. AdminControlsEngine off
      48. </IfModule>
      49. <IfModule mod_vroot.c>
      50. VRootEngine on
      51. VRootLog /var/log/proftpd/vroot.log
      52. </IfModule>
      53. Port 21
      54. TransferLog NONE
      55. RequireValidShell off
      56. IdentLookups off
      57. UseReverseDNS off
      58. TimeoutIdle 1200
      59. TimeoutNoTransfer 600
      60. TimeoutStalled 600
      61. AllowRetrieveRestart on
      62. AllowStoreRestart on
      63. DeleteAbortedStores off
      64. MaxClients 5
      65. MaxConnectionsPerHost 2
      66. MaxLoginAttempts 5
      67. <Directory />
      68. HideFiles (welcome.msg)
      69. </Directory>
      70. <IfModule mod_vroot.c>
      71. VRootAlias "/media/dc04934f-2933-4248-a7a4-a1eb807d60d3/videos" "videos"
      72. </IfModule>
      73. <Directory /videos>
      74. <Limit ALL>
      75. AllowUser OR JC
      76. AllowGroup OR Famille,Ami,ftp
      77. DenyAll
      78. </Limit>
      79. <Limit READ DIRS>
      80. AllowUser OR JC
      81. AllowGroup OR Famille,Ami,ftp
      82. DenyAll
      83. </Limit>
      84. </Directory>
      85. <IfModule mod_vroot.c>
      86. VRootAlias "/media/dc04934f-2933-4248-a7a4-a1eb807d60d3/videos/séries" "videos-series"
      87. </IfModule>
      88. <Directory /videos-series>
      89. <Limit ALL>
      90. AllowUser OR JC
      91. AllowGroup OR Famille,Ami,ftp
      92. DenyAll
      93. </Limit>
      94. <Limit READ DIRS>
      95. AllowUser OR JC
      96. AllowGroup OR Famille,Ami,ftp
      97. DenyAll
      98. </Limit>
      99. </Directory>
      100. <IfModule mod_ban.c>
      101. BanEngine on
      102. BanControlsACLs all allow user root
      103. BanLog /var/log/proftpd/ban.log
      104. BanMessage Host %a has been banned
      105. BanOnEvent MaxLoginAttempts 5/00:10:00 00:30:00
      106. BanTable /var/run/proftpd/ban.tab
      107. </ifModule>
      108. DisplayLogin /srv/ftp/welcome.msg
      109. <IfModule mod_wrap.c>
      110. TCPAccessFiles /etc/hosts.allow /etc/hosts.deny
      111. TCPAccessSyslogLevels info warn
      112. TCPServiceName ftpd
      113. </ifModule>
      Display All

      I try plain ftp, I try secure ftp only when plain ftp are running good ;)

      The post was edited 1 time, last by WastlJ ().

    • Are you having Filezilla prompt you for credentials??? or did you try to save them? There are some changes in the new version of Filezilla.

      Edit/Settings/Interface

      then on the right "behavior"

      take check off "Do not save passwords"

      You need to do this if you save your passwords.

      I use the site manager and it would not work correctly til I did this.

      The post was edited 1 time, last by tekkb ().

    • I use a HDD, I read somewhere it's dangerous to use usb to system.
      I use an old 80Go HDD.

      I can force reinstall of this plugin by apt-get insctruction?

      I put my setting page in English and without scrollbar.



      I use the filezilla interface. I save my options in the application.
      I try with prompt but I can't connect to.
    • It may work with admin some weird way because you might be logged into the web gui.


      I don't suspect corruption now or issue with your system drive. I didn't notice the scrollbar. But read what I said about Filezilla.

      Well you cannot save your credentials now in Filezilla til you do what I said above.

      Can you give me bigger picture of shared folder privileges?

      The post was edited 2 times, last by tekkb ().