USB printer no longer recognized

    • OMV 1.0
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • USB printer no longer recognized

      Hello Forum

      I am new to this Forum, and I am also kind of new to the Linux environment. I've been using OMV for roughly a month now, and after trying different Home NAS solutions, I find OMV to be the easiest to use.

      I am running OMV in an old HP dc7800 usdt thin client. The computer has a single SATA port, therefore I installed the OS in a USB SSD to leave space for a big HDD to use as storage. Connected to the system is also a HP Laserjet 1020. I struggled a little to make the printer work, but in the end the only issue was that I needed to download the corresponding drivers (mea culpa, newbie here) . For that, I just used:

      Source Code

      1. getweb 1020


      And after that I could add the printer directly in the CUPS interface (localhost:631). I used the printer for a couple of days. I mapped the printer in my laptop, and it worked flawlessly. At the third day I turned off my OMV PC and uplugged the printer from it. I needed the USB cable from the printer for something else. Next day, I reconnected the printer to the OMV PC and restarted it. And there started the problems!

      Now, I am not able to add the printer in CUPS. It is not even recognized nor visible. If I go to the OMV interface and check the printing plug in, the printer is recognized as unknown. So, after doing some research, I tried to see if the printer was actually being recognized by Debian. If I open a console and type lsusb, the printer is recognized. I can see that the printer is plugged to one of the usb ports (Bus 1, Device 005: HP Laserjet 1020); but when I run lpinfo -v the printer is also recognized, but it appears as /unknown/printer.

      I've tried connecting the printer to different usb ports. I also tried restarting cups, resetting it to its default values and even re installing it. None of them seemed to work. The printer does work, already tested it again connected directly to my laptop.

      I found in some forums suggesting to blacklist lsusb, but I don't really see how can that help (or perhaps I do not really understand how that works). I tend to think that the issue came because I unplugged the printer and then plugged it again (maybe in a different usb port).

      Any insights or suggestions are highly appreciated! In any case, amazing software :thumbsup:
      Custom mini-ITX build
      Coolcube Mini, Intel Desktop Board DQ77KB, Intel Celeron G1610T, 4 GB DDR3 Ram, 30 GB Sandisk SSDnow 200 (OS), 1 TB Samsung M8 HN-M101MBB

      Dell Optiplex 960 sff (deprecated) - link


      Dell Optiplex FX160 (repurposed) - link

      "If you can't find it in Google, it simply doesn't exist!" - The Internetz

    • So, it seems like I figured it out. For some reason, the driver included in the OMV installation (foo2zjs) stopped working or got outdated. I well may be that one of the OMV updates broke the driver. Hard to tell.

      In any case, I followed the instructions in foo2zjs webpage and installed the driver manually. In order to install it, I had to run first the following commands:

      Source Code

      1. apt-get remove make

      Source Code

      1. apt-get install make

      Source Code

      1. apt-get install build-essential


      The first two lines will re install make. For some reason, it was not working properly in my PC. The last one will prevent an error saying cc not installed when compiling the driver.

      Then, go to the foo2zhs webpage and follow the instructions to download, compile and install the driver for your printer (in my case, the Laserjet 1020). When the driver is installed and you have restarted CUPS, go to localhost:631 and add the printer directly in te CUPS interface. I tried to do it also from the OMV printing plug in and it also worked.

      Hope that my findings can help someone else with this problem.
      Custom mini-ITX build
      Coolcube Mini, Intel Desktop Board DQ77KB, Intel Celeron G1610T, 4 GB DDR3 Ram, 30 GB Sandisk SSDnow 200 (OS), 1 TB Samsung M8 HN-M101MBB

      Dell Optiplex 960 sff (deprecated) - link


      Dell Optiplex FX160 (repurposed) - link

      "If you can't find it in Google, it simply doesn't exist!" - The Internetz