Zoneminder not rendering when authentication is enabled

    • OMV 1.0

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Zoneminder not rendering when authentication is enabled

      Hi all, this is my first post :)

      I have zoneminder installed (the one compiled to use nginx) and it is working beautifully when no authentication is required to access zoneminder.

      I am having a problem however when I try to enable a username and password. For some reason the video is not showing up when it is enabled. After looking at the logs I can see that the sockets either are not being created or the sockets that are created cannot be connected to. Sample err from log below

      socket_sendto( /tmp/zm/zms-> 259629s.sock ) failed: No such file or directory

      Looking at an Ubuntu thread here, two methods seemingly fixed the issue

      Source Code

      1. 1) Keep the default zone apache.conf without the ScriptAlias.
      2. 2) Stop both zoneminder and apache2
      3. sudo service apache2 stop
      4. sudo service zoneminder stop
      5. 2) Remove any stale sockets from /tmp/zm (default location):
      6. sudo rm -vf /tmp/zm/*.*
      7. 3) sudo a2enmod cgi
      8. 4) Start zoneminder
      9. sudo service zoneminder start
      10. 5) Start apache2
      11. sudo service apache2 start
      Display All

      and

      Set the correct timezone in etc/php5/apache2/php.ini. This fixed the time issue, unauthenticated user issue and the socket issue.

      Since I am not using apache but nginx I am at a lost. Would someone with a little more experience be able to point me in the right direction?