virtualbox problems

    • OMV 1.0
    • virtualbox problems

      hi there

      when i installed virtualbox i get nothing but errors. As soon i click on virtual i get this error
      Error #64:exception 'Exception' with message 'Could not connect to host (127.0.0.1:18083/)' in /usr/share/phpvirtualbox/lib/vboxconnector.php:210

      i've run build-essentials and vboxdrv setup, they fail with error too and point me to this log /var/log/vbox-install.log

      Makefile:183: *** Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR=<directory> and run Make again. Stop.
      Makefile:183: *** Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR=<directory> and run Make again. Stop.
      make KBUILD_VERBOSE=1 SUBDIRS=/tmp/vbox.0 SRCROOT=/tmp/vbox.0 CONFIG_MODULE_SIG= -C /lib/modules/3.16.0-0.bpo.4-amd64/build modules
      make[1]: Entering directory `/usr/src/linux-headers-3.16.0-0.bpo.4-amd64'
      make -C /usr/src/linux-headers-3.16.0-0.bpo.4-amd64 \
      KBUILD_SRC=/usr/src/linux-headers-3.16.0-0.bpo.4-common \
      KBUILD_EXTMOD="/tmp/vbox.0" -f /usr/src/linux-headers-3.16.0-0.bpo.4-common/Makefile \
      modules
      test -e include/generated/autoconf.h -a -e include/config/auto.conf || ( \
      echo >&2; \
      echo >&2 " ERROR: Kernel configuration is invalid."; \
      echo >&2 " include/generated/autoconf.h or include/config/auto.conf are missing.";\
      echo >&2 " Run 'make oldconfig && make prepare' on kernel src to fix it."; \
      echo >&2 ; \
      /bin/false)
      mkdir -p /tmp/vbox.0/.tm



      Can anyone please help???


      Andy
    • You need the kernel-headers installed. How did you install the backports kernel? There is a button to install the kernel headers in omv-extras.
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Hi ryecoaaron again,

      sorry that failed too earlier:
      Install build-essential.
      Reading package lists...
      Building dependency tree...
      Reading state information...
      build-essential is already the newest version.
      0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
      Recompile VirtualBox module.
      Stopping VirtualBox kernel modules ...done.
      Recompiling VirtualBox kernel modules ...failed!
      (Look at /var/log/vbox-install.log to find out what went wrong)
      Load VirtualBox module.
      Starting VirtualBox kernel modules ...failed!
      (modprobe vboxdrv failed. Please use 'dmesg' to find out why)
      Restart vboxweb-service
      Starting VirtualBox web service ...fail!
    • What is the output of:

      apt-get -t wheezy-backports --yes --force-yes --fix-missing install linux-headers-3.16.0-0.bpo.4-amd64 firmware-linux firmware-linux-free
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • hi

      that worked fine, everything unpacked and installed fine.When i clicked on phpvirtualbox and entered username password i got htis:

      Exception Object
      (
      [message:protected] => Could not connect to host (127.0.0.1:18083/)
      [string:Exception:private] =>
      [code:protected] => 64
      [file:protected] => /usr/share/phpvirtualbox/lib/ajax.php
      [line:protected] => 128
      [trace:Exception:private] => Array
      (
      )

      [previous:Exception:private] =>
      )
    • Source Code

      1. apt-get purge openmediavault-virtualbox virtualbox
      2. reboot
      3. rm -f /etc/default/openmediavault-virtualbox /etc/default/virtualbox
      4. userdel vbox
      5. groupdel vboxusers
      6. ​reboot


      Then reinstall the plugin
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Thanks, got this after reinstalling;

      useradd: group 'vboxusers' does not exist
      dpkg: error processing openmediavault-virtualbox (--configure):
      subprocess installed post-installation script returned error exit status 6
      Processing triggers for openmediavault ...
      Restarting engine daemon ...
      Errors were encountered while processing:
      openmediavault-virtualbox

      Cannot click on close, its stuck now.