Issue with Sabnzbd

    • OMV 1.0
    • Resolved
    • Issue with Sabnzbd

      Hi everyone,

      I have been using OMV for about 8 months now and love the simplicity. Up until the last week when the new version of Debian was released I have had hundreds of updates showing in my update manager. The majority will not upgrade and will hang giving me this message.

      Source Code

      1. Reading package lists...
      2. Building dependency tree...


      The only way out would be to refresh the screen.

      I have just noticed that my installed and once fully functional version of Sabnzbd is no longer running. I get this error when I try to visit it via a web browser:

      Source Code

      1. 500 Internal Server Error
      2. The server encountered an unexpected condition which prevented it from fulfilling the request.
      3. Traceback (most recent call last):
      4. File "/opt/SABnzbd/cherrypy/_cprequest.py", line 618, in respond
      5. cherrypy.response.body = self.handler()
      6. File "/opt/SABnzbd/cherrypy/_cpdispatch.py", line 25, in __call__
      7. return self.callable(*self.args, **self.kwargs)
      8. File "/opt/SABnzbd/sabnzbd/interface.py", line 299, in index
      9. filter=FILTER, searchList=[info], compilerSettings=DIRECTIVES)
      10. File "/usr/lib/python2.7/dist-packages/Cheetah/Template.py", line 1259, in __init__
      11. File "/usr/lib/python2.7/dist-packages/Cheetah/Template.py", line 1553, in _compile
      12. File "/usr/lib/python2.7/dist-packages/Cheetah/Template.py", line 788, in compile
      13. File "_opt_SABnzbd_interfaces_Plush_templates_main_tmpl.py", line 21, in <module>
      14. ImportError: No module named DummyTransaction
      Display All


      When I look for the listing of Sabnzbd under installed plugins, under plugins branch (OMV GUI) it's no longer listed. I tried to reinstall it from the Plugins menu and when I click to install it I get this message and the screen

      Source Code

      1. Reading package lists...
      2. Building dependency tree...
      hangs again.

      I'm not too familiar with code and I can use SSH a bit, but I'm at a loss as to how to get my Sabnzbd to work again. Is it related to having all these phantom updates listed in my update manager that won't install? If so, how can I fix it?

      Thanks in advance!

      *** EDIT ***

      I tried running this SSH code to see what errors showed up

      Source Code

      1. apt-get install openmediavault-sabnzbd


      And this is what happened:

      Source Code

      1. /bin$ apt-get install openmediavault-sabnzbd
      2. Reading package lists...
      3. Building dependency tree...
      4. Reading state information...
      5. Some packages could not be installed. This may mean that you have
      6. requested an impossible situation or if you are using the unstable
      7. distribution that some required packages have not yet been created
      8. or been moved out of Incoming.
      9. The following information may help to resolve the situation:
      10. The following packages have unmet dependencies:
      11. openmediavault-sabnzbd : Depends: git but it is not going to be installed
      12. Depends: python-configobj but it is not going to be installed
      13. Depends: par2 but it is not going to be installed
      14. E: Unable to correct problems, you have held broken packages.
      Display All


      It looks like there's an issue with my python install. Any idea how I can fix it?

      The post was edited 3 times, last by JSKershaw ().

    • Okay, so this is what I'm thinking went wrong. The only problem now is trying to figure out how to fix it. With the issue of all these old updates showing in my update manager I may have installed one of the old updates which screwed up my python install.
      Is there a way to manually remove all instances of python and sabnzbd from my omv so I can reinstall them fresh?
      Any help you guys can provide will be greatly appreciated.
    • Okay I seem to have cleared the main problem. I was able to install Sabznbd, but now when I try to initiate the plugin I get this error.

      Source Code

      1. ​Error #4000:
      2. exception 'OMVException' with message 'Failed to execute command 'omv-mkconf sabnzbd getsettings': Warning: unrecognized option '-n'
      3. Segmentation fault' in /usr/share/openmediavault/engined/rpc/sabnzbd.inc:71
      4. Stack trace:
      5. #0 [internal function]: OMVRpcServiceSabnzbd->getSettings(NULL, Array)
      6. #1 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      7. #2 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('getSettings', NULL, Array)
      8. #3 /usr/sbin/omv-engined(500): OMVRpc::exec('Sabnzbd', 'getSettings', NULL, Array, 1)
      9. #4 {main}


      Any idea how I can fix this? I tried uninstalling the Sabnzbd plugin and reinstalled it and I still get this error.
    • If you run omv-mkconf sabnzbd getsettings from the command line (ssh) does it report the same error?

      What do you get if you run omv-showkey sabnzbd?


      Source Code

      1. <sabnzbd>
      2. <enable>1</enable>
      3. <showtab>0</showtab>
      4. <newinstance>0</newinstance>
      5. <newinstenable>0</newinstenable>
      6. <ppass>0</ppass>
      7. <ssl>0</ssl>
      8. <update>0</update>
      9. <port>8080</port>
      10. </sabnzbd>
      [IMG:http://widgets.trakt.tv/users/1f5d0f5ed67f98ed9d06d9849b42dd0e/watched/banner@1x.jpg]
      What I am watching/watched on my Popcorn Hour media player
      omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
      MySQL (Percona) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS
    • I made a real mess of things. I got my openmediavault somewhat working. Then I clicked on an install package that was in the update manager and it did something to my OMV. Now the GUI and remote ssh isn't working. Only thing that's working is my samba. So right now I'm in the process in backing up my most important information and files.

      The only thing I can possibly do is start fresh and once I get OMV setup the way I want it I will use clonezilla to make an image of the system disk so this doesn't happen again.