Error during upgrade

    • Resolved
    • OMV 1.0
    • Error during upgrade

      Hey guys,

      I'm having issues upgrading over webgui/update manager.
      Error reads as follows and appears when I try to open the changelog:

      Source Code

      1. ​Failed to execute command 'export LANG=C; apt-get --yes --force-yes --download-only --reinstall install 'libcurl3-gnutls' 2>&1': Reading package lists... E: The value 'stable' is invalid for APT::Default-Release as such a release is not available in the sources
      2. Error #4000:
      3. exception 'OMVException' with message 'Failed to execute command 'export LANG=C; apt-get --yes --force-yes --download-only --reinstall install 'libcurl3-gnutls' 2>&1': Reading package lists...
      4. E: The value 'stable' is invalid for APT::Default-Release as such a release is not available in the sources' in /usr/share/openmediavault/engined/rpc/apt.inc:392
      5. Stack trace:
      6. #0 [internal function]: OMVRpcServiceApt->getChangeLog(Array, Array)
      7. #1 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      8. #2 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('getChangeLog', Array, Array)
      9. #3 /usr/sbin/omv-engined(500): OMVRpc::exec('Apt', 'getChangeLog', Array, Array, 1)
      10. #4 {main}
      Display All


      When I try to "upgrade" a window pops up showing "Installing Updates ..." and "please wait".
      Apart from that, nothing happens ...

      Any thoughts ? ?(
    • Hi

      I'm having a similar problem with the webui hanging during package upgrade process. But I'm also getting this running an apt-get update:

      Traceback (most recent call last):
      File "/usr/sbin/omv-mkaptidx", line 55, in <module>
      cache = apt.cache.Cache()
      File "/usr/lib/python3/dist-packages/apt/cache.py", line 102, in __init__
      self.open(progress)
      File "/usr/lib/python3/dist-packages/apt/cache.py", line 145, in open
      self._cache = apt_pkg.Cache(progress)
      SystemError: E:The value 'stable' is invalid for APT::Default-Release as such a release is not available in the sources
      Reading package lists... Done
      W: GPG error: plex.r.worldssl.net lucid Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 43525C28E533491A