webgui not loading after restart

    • OMV 1.0
    • webgui not loading after restart

      Sorry if I missed a thread with the answer. Yesterday, I had one of my shares become inaccessible, so I rebooted. After reboot the share was available but the webgui was not. OMV is running, I can ssh but no webgui. Today, the same share become inaccessible again. Then I realized I had the owncloud directory on that share, so I remove owncloud thinking that would fix the issue. It seems to have resolved the inaccessible drive but not the webgui. Needs some help.

      It works!This is the default web page for this server.

      The web server software is running but no content has been added, yet.
    • "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • I performed:

      omv-mkconf nginx
      omv-mkconf php5fpm
      service apache2 stop
      service php5-fpm restart
      update-rc.d -f apache2 remove
      service nginx restart

      Result: No Webgui

      Then: omv-firstaid

      Result: Wegui back

      However, one of my shares is inaccessible. I tried to disable OwnCloud and received Error #4000 below.

      Error #4000:
      exception 'OMVException' with message 'Failed to execute command 'omv-mkconf owncloud 2>&1': mkdir: cannot create directory `/media/7bc999b6-78de-48a9-81be-1925529fa53a/Data/BackupWin': File exists' in /usr/share/openmediavault/engined/module/owncloud.inc:60
      Stack trace:
      #0 /usr/share/openmediavault/engined/rpc/config.inc(180): OMVModuleOwnCloud->applyConfig()
      #1 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
      #2 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      #3 /usr/share/php/openmediavault/rpcservice.inc(158): OMVRpcServiceAbstract->callMethod('applyChanges', Array, Array)
      #4 /usr/share/openmediavault/engined/rpc/config.inc(224): OMVRpcServiceAbstract->callMethodBg('applyChanges', Array, Array)
      #5 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)
      #6 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      #7 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('applyChangesBg', Array, Array)
      #8 /usr/sbin/omv-engined(500): OMVRpc::exec('Config', 'applyChangesBg', Array, Array, 1)
      #9 {main}

      Performed:

      omv-mkconf nginx
      omv-mkconf php5fpm
      service apache2 stop
      service php5-fpm restart
      update-rc.d -f apache2 remove
      service nginx restart

      a second time, no luck.

      thoughts?
    • nuckjr40 wrote:

      exception 'OMVException' with message 'Failed to execute command 'omv-mkconf owncloud 2>&1': mkdir: cannot create directory `/media/7bc999b6-78de-48a9-81be-1925529fa53a/Data/BackupWin': File exists'


      No idea why it would try to create a folder that already exists. @votdev maybe?

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • I also don't know why mkdir fails because every command is executed with option -p. See linux.die.net/man/1/mkdir

      -p, --parents
      no error if existing, make parent directories as needed
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • Update: Webgui is loading and I can login. I can access all shares except the share that owncloud uses as the data directory. Unfortunately, that is my backup drive as well. If I try to modify the ACL for that share, I receive the follow errors:

      Error #4000:
      exception 'OMVException' with message 'Failed to execute command 'export LANG=C; getfacl --no-effective --access -- '/media/7bc999b6-78de-48a9-81be-1925529fa53a/Data/Backup/' 2>&1': getfacl: /media/7bc999b6-78de-48a9-81be-1925529fa53a/Data/Backup/: Input/output error' in /usr/share/openmediavault/engined/rpc/sharemgmt.inc:883
      Stack trace:
      #0 [internal function]: OMVRpcServiceShareMgmt->getFileACL(Array, Array)
      #1 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      #2 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('getFileACL', Array, Array)
      #3 /usr/sbin/omv-engined(500): OMVRpc::exec('ShareMgmt', 'getFileACL', Array, Array, 1)
      #4 {main}

      DirectoryIterator::__construct(/media/7bc999b6-78de-48a9-81be-1925529fa53a/Data/Backup/): failed to open dir: Input/output error

      I have tried to clear the ACLs on that directory with no success.

      I feel like I need to clean up all the owncloud configurations via ssh but not sure how.