Is it possible to upgrade from 0.5.60 (saudakar) to 2.x ?

    • OMV 0.5
    • Update

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Is it possible to upgrade from 0.5.60 (saudakar) to 2.x ?

      Hi,

      i'm actually very behind in the updates and the system feels a bit unstable at time (nothing major). Also i'm still running XBMC as a media player so it would probably be good to upgrade to Kodi.
      I'm running 0.5.60 on a HP Proliant N40L.
      So i was wondering if there was a way to upgrade to the latest version directly?
      Or if i should consider a complete reinstallation of OMV ? but in that case, is there a way to make sure that i don't lose any data on the data disks?
      (OMV is installed on its own hardrive)

      Many Thanks.
      Best Regards,
      bhim25
    • I would recommend you make a backup of your data to a USB drive or some other media before moving forward.

      I think you would be better off with a new installation. Try removing your drives with the data on them while you are doing to the new installation. After it is complete put your drives back in and see if they are visible to OMV. Mount your data drives and you should be back in business.

      Some tips on things to look for in your current installation
      Are you using raid?
      what filesystem? ext4?

      Hope that helps :)
      ShadowZero -- OMV Fan since 0.3
    • Hi Shadowzero,

      thanks for your reply !

      I am using Raid 5 (4 physical disks) with an ext4 filesystem. I'm hoping that's a plus?
      I thought the new installation might be the way forward but i'm being a bit cautious as in case i miss to backup some important configuration files...
      Will the mounting of drives not be automatic by OMV ?

      this definitely helps :)

      thanks again !
    • Hiho!

      I would not even try it. Because... It is (normally) not a big deal to do a new installation.

      New installation means:

      - make screenshots of some important settings
      - make screenshots of used shares
      - unmount your raid
      - unplug your data-disc
      - install 2.0
      - plugin data-discs
      - mount your data-discs
      - mount your raid (AFAIK, but I'm not an expert to RAID, it will be seen by OMV)
      - recreate your shares

      If you like me, and you got only some shares and some users, it's easy.

      Remember: If you try to do an upgrade and somethings goes wrong - you just wasted time.
    • Ok, so i've installed 1.19 (krazilec) from scratch in the end.
      One thing which is weird is that the IP address doesn't appear when booting. I've tried reinstalling twice and i still have the same problem. The workaround is to do an ifconfig. I don't know if anyone has had the same issue? Maybe i'm doing something wrong but i don't understand as i can see the DHCP step being successful and it can download the debian packages during the installation and i can access it after having found the actual IP address.

      I'll hold off for 2.0.x when it is really official.

      Another thing that was strange is on the Update manager page. There is quite a lot of them. Should i update them all? I tried to but it didn't work. Maybe too many in one go?
      I've also installed the OMV-extras.org plugin and i was expecting to see options to install sickbeard, couchpotato, etc... But i don't. Have I missed something or a repository ?

      I have found this on the forum for Kodi : Kodi (formerly XBMC) for OMV Is that correct ?

      Thanks again everyone for all the help.
    • Update...

      I found out what the problem was, when trying to upload the omv extras repository via the Web UI, it didn't work.
      So i reverted to do it manually (omv-extras.org/simple/index.ph…install-omv-extras-plugin) and that's when i saw that the apt-transport-https was missing. So i installed it and eventually after a few refresh/clean/reload, everything appeared in the Web UI and i was able to install everything.
      it used to work straight away in previous version so i don't know if it's my installation that is wrong or if the new version is not a "auto-refreshing / auto-updating" as before?

      I'm still struggling with compiling Kodi at the moment. I have posted my question in the relevant thread but can give an update here once i found out what's wrong.

      Hope this helps others...
    • Final update...

      Here's what i did to get KODI working...

      GCC installation (needed for the NVIDIA driver) (I have an NVIDIA graphic card in my HP Microserver so can output directly to a TV via HDMI)
      apt-get install build-essential gcc g++ make binutils linux-headers-`uname -r`

      then for KODI :
      omv-update
      apt-get install python-software-properties pkg-config
      apt-get install software-properties-common
      apt-get install freeglut3 freeglut3-dev libdrm-dev doxygen swig git-core

      apt-get install automake autopoint bison build-essential ccache cmake curl cvs default-jre fp-compiler gawk gdc gettext gperf libasound2-dev libass-dev libavcodec-dev libavfilter-dev libavformat-dev libavutil-dev libbluetooth-dev libbluray-dev libbluray1 libboost-dev libboost-thread-dev libbz2-dev libcap-dev libcdio-dev libcec-dev libcec1 libcrystalhd-dev libcrystalhd3 libcurl3 libcurl4-gnutls-dev libcwiid-dev libcwiid1 libdbus-1-dev libenca-dev libflac-dev libfontconfig-dev libfreetype6-dev libfribidi-dev libglew-dev libiso9660-dev libjasper-dev libjpeg-dev libltdl-dev liblzo2-dev libmad0-dev libmicrohttpd-dev libmodplug-dev libmp3lame-dev libmpeg2-4-dev libmpeg3-dev libmysqlclient-dev libnfs-dev libogg-dev libpcre3-dev libplist-dev libpng-dev libpostproc-dev libpulse-dev libsamplerate-dev libsdl-dev libsdl-gfx1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libshairport-dev libsmbclient-dev libsqlite3-dev libssh-dev libssl-dev libswscale-dev libtiff-dev libtinyxml-dev libtool libudev-dev libusb-dev libva-dev libva-egl1 libva-tpi1 libvdpau-dev libvorbisenc2 libxml2-dev libxmu-dev libxrandr-dev libxrender-dev libxslt1-dev libxt-dev libyajl-dev mesa-utils nasm pmount python-dev python-imaging python-sqlite unzip yasm zip zlib1g-dev


      cd $HOME/kodi
      git clone -b Helix git://github.com/xbmc/xbmc.git
      cd xbmc
      ./bootstrap
      apt-get remove libtag1-dev
      make -C lib/taglib
      make -C lib/taglib install
      ./configure
      make
      make install

      apt-get install xorg

      NVIDIA DRIVER (download from nvidia website (use wget)):
      sh ./NVIDIA-Linux-x86_64-346.72.run

      CREATE a conf file for Xorg for the display:
      nvidia-xconfig
      cp XF86Config xorg.conf

      Launch Kodi
      xinit /usr/bin/kodi-standalone -- -nocursor :0

      Hope this helps :)