How can I replace a disk (aufs pool and snapraid)?

    • OMV 1.0
    • How can I replace a disk (aufs pool and snapraid)?


      my plan is to swap the disk against a bigger one, add it to the aufs pool and then copy the files from the old disk.

      After testing a bit on my own, I'm still not able to unmount/swap a disk to replace it with a bigger one. The disks are pooled with aufs and snapraid does the parity stuff. I've stopped all plugin and services (e.g. smb) and deleted the snapraid configuration but under filesystem the unmount button is still grayed out. Or is it necessary to delete all shared folders too so no referencing is on the disk anymore? I don't know what to do next.

      I'm grateful for any help or advice.
    • I haven't tried this (would test in a vm first). I wouldn't think you should have to disable anything.

      - remove drive from snapraid
      - shutdown server
      - remove drive
      - start server
      - add drive to snapraid keeping the name the same as removed drive
      - remove missing from aufs
      - expand aufs to include new drive
      omv 4.1.17 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13 plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!