Install of PlexMediaServer Plugin

    • OMV 1.0
    • Thanks for the response Tekkb! Alas:

      root@OMVServer:/media/5d3465f2-52fa-477b-a915-deb30d0942c9# chown -R plex:plex plexmediaserver
      root@OMVServer:/media/5d3465f2-52fa-477b-a915-deb30d0942c9# /etc/init.d/plexmediaserver start
      Starting Plex Media Server: done
      root@OMVServer:/media/5d3465f2-52fa-477b-a915-deb30d0942c9# /etc/init.d/plexmediaserver status
      It seems that Plex Media Server isn't running (no process found).
      root@OMVServer:/media/5d3465f2-52fa-477b-a915-deb30d0942c9# /etc/init.d/plexmediaserver start
      Starting Plex Media Server: done
      root@OMVServer:/media/5d3465f2-52fa-477b-a915-deb30d0942c9# /etc/init.d/plexmediaserver status
      It seems that Plex Media Server isn't running (no process found).
    • I got feeling you shared the root of your data drive. There should not be and s in the perms of the plexmediaserver folder. And the chmod of the plexmediaserver folder should be 0755.

      Read this... Especially the 1st part about how not to make a media share:

      How to make a good Media share for Emby and PlexMediaServer

      Uninstall the plex plugin.
      Then you need to undo all the samba shares/shared folders on this data drive and start again following this guide.
    • Thank you tekkb, now I do have a something to ask you concerning your above response. I originally followed this guide (en.jose-crispim.pt/artigos/arm…penmediavault.html#p2_3_5) to setup OMV, including all my users, folders, permissions, and shares. This is a little bit different from the guide you recommend, since it does involve ACLs. I've attached pics of all the shared folders which are located on the volume "/media/5d3465f2-52fa-477b-a915-deb30d0942c9" (which i've named MyPersonalArchiv) which i intend to have my plexmediaserver folder in. Correct me if i'm wrong, but are all my shared folders not shared from the root on volume MyPersonalArchiv?

      Now, I will next attempt to follow your specified guide "How to make a good Media share for Emby and PlexMediaServer" step by step and see if it makes a difference.
      Images
      • Capture.JPG

        32.29 kB, 528×225, viewed 223 times
      • Capture1.JPG

        28.53 kB, 506×234, viewed 238 times
      • Capture3.JPG

        26.38 kB, 505×231, viewed 210 times
      • Capture4.JPG

        28.38 kB, 500×228, viewed 219 times
      • Capture5.JPG

        28.11 kB, 504×236, viewed 215 times
      • Capture6.JPG

        28.54 kB, 502×236, viewed 222 times
      • Capture7.JPG

        28.94 kB, 500×235, viewed 217 times
    • I would not follow his guide. Follow my Guide to create the media share and the install Plex plugin. It should be simple.

      I looked at your pictures above. You have a music and pictures shares. You do not need to do this. Both of those can go in the Media Share.

      After you install plexmediaserver do a stat of the plexmediaserver folder.. If you see 2755 and an "s" it is wrong and you did not delete the share that was at the root of the data drive.
    • Okay, so i followed your "How to make a good Media share for Emby and PlexMediaServer" guide to the letter and voila it works! I'm able to access the plex webgui and the PlexMediaServer service is running as it should be. Now, I did use another hard drive in my OMVServer which had never had any shared files in it at all to do this (it is my Snapraid parity drive) since the disk i wanted to use originally "MyPersonalArchiv" (and would like to ultimately use) already has 1.8TB of info and I didnt want to mess around with it yet. I did "stat plexmediaserver" and "id plex" in the volume and i got this:

      root@OMVServer:/media/dfd512fa-d0c6-4ed7-93dd-221fa9002ddb# stat plexmediaserver
      File: `plexmediaserver'Size: 4096 Blocks: 8 IO Block: 4096 directory
      Device: 811h/2065d Inode: 164888577 Links: 3
      Access: (0755/drwxr-xr-x) Uid: ( 112/ plex) Gid: ( 116/ plex)
      Access: 2015-11-16 15:25:10.395672820 -0500
      Modify: 2015-11-16 15:23:37.729489988 -0500
      Change: 2015-11-16 15:25:10.715680358 -0500
      Birth: -
      root@OMVServer:/media/dfd512fa-d0c6-4ed7-93dd-221fa9002ddb# id plex
      uid=112(plex) gid=116(plex) groups=116(plex)

      So permissions are good right?

      Ok, so ideally i do not want my "media" folder in my parity drive, I'd like it to be on the drive where I want to keep my media in. So, tekkb what should i do? Should i delete EVERY single shared folder in MyPersonalArchiv and start completely clean with just a single "media" shared folder (with music, pictures. etc folders inside)? If this is the volume where i want my plexmediaserver folder in, is it okay to create other shared folders that plex will not use in that volume like "documents" etc. (as long as i follow your guide)?

      Also, I'd like to head off as many potential headaches as I can so i did the following check. I've got 7 separate disks in my OMVserver. In terminal, i did a "stat" on each of them. For access, on 6 out of 7 i get "Access: (0755/drwxr-xr-x) Uid: ( 0/ root) Gid: ( 0/ root)". However on "5d3465f2-52fa-477b-a915-deb30d0942c9" (MyPersonalArchiv) i get "Access: (2770/drwxrws---) Uid: ( 1000/ ahmad) Gid: ( 100/ users)". Is this a problem?

      I'd like to cover as many bases as I can before I start essentially redoing my OMVserver because we're talking about TB of info that i cannot lose ?(
    • Looks good... permissions look good.

      I see the media share as a special share just for media (movies, tv, music, pictures, other related).

      I would not create folder in the media share that you want more security on or not related.
      Important documents (maybe called Documents) and Backups are special shared folders for other purposes and you should create an individual share just for that purpose, Virtualbox would be another example.

      On the shared folders, then shared via samba, you should be using privileges to give rights to them. After you created a shared folder give at least your user read/write privileges so you can add data to the folder. Later you can add other users if needed.

      It is OK to have all kinds of shared folders on a given data drive as long as you don't share the root of the drive. Sharing the root of the drive can destroy chown (ownership) or chmod of folders/files below the root of the drive.... my daughter messages me

      C-ya

      The post was edited 2 times, last by tekkb ().

    • tekkb wrote:

      Looks good... permissions look good.

      I see the media share as a special share just for media (movies, tv, music, pictures, other related).

      I would not create folder in the media share that you want more security on or not related.
      Important documents…


      Okay, so I understand for "media share" just put in folders that Plex would use. But its still okay to put in other shared folders like "Documents" or "Backups" on the same level as "media share" as long as I follow your guide, right? But should i still delete all my current existing shares on MyPersonalArchiv, just to be sure?

      Now before i do that, should i be worried that disk "5d3465f2-52fa-477b-a915-deb30d0942c9" (MyPersonalArchiv) where i want plexmediaserver folder to be in, has these permissions "Access: (2770/drwxrws---) Uid: ( 1000/ ahmad) Gid: ( 100/ users)" instead of all the other disks that show "Access: (0755/drwxr-xr-x) Uid: ( 0/ root) Gid: ( 0/ root)"?

      Tekkbb, you can respond when you can, you've been a great help already!
    • ermac wrote:

      But its still okay to put in other shared folders like "Documents" or "Backups" on the same level as "media share"


      It is OK to have other shared folders at same level on the data drives. But you may want them to be a little different than the media share. Like you might not want users to have access, or others. So they drop down might be different depending on what you want.

      I try to write more later.

      The post was edited 1 time, last by tekkb ().

    • No problems tekkb, i'm currently copying the contents of MyPersonalArchiv to another drive i made space in, going to take awhile since its +1.8TB.

      I experimented putting the "media share" folder on another disk in OMVserver that had pre-existing shares and then putting the plexmediaserver folder on that disk, and it ran perfectly! Then again, that disk volume had proper permissions set and I'm positive i never setup a root share on that disk since i added it much later then when i first started experimenting with OMV and my original disk. So clearly the problem is with "5d3465f2-52fa-477b-a915-deb30d0942c9".

      I took a look at another thread you contributed too "Plex media server refuses to start OMV 2.0" on the forums that dealt with messed up permissons for a volume at the root level. It looks like i have a very similar problem to user tinh_x7 regarding a share at the root level that was setup a long time ago that messed up permissions for that volume. So, for example i got "root users" for my aquota.group and aquota.user files. I did "chown root:root /media/5d3465f2-52fa-477b-a915-deb30d0942c9" then "chmod g-s /media/5d3465f2-52fa-477b-a915-deb30d0942c9" so now when i do "stat 5d3465f2-52fa-477b-a915-deb30d0942c9" i get the following:

      root@OMVServer:/media# stat 5d3465f2-52fa-477b-a915-deb30d0942c9
      File: `5d3465f2-52fa-477b-a915-deb30d0942c9'
      Size: 4096 Blocks: 8 IO Block: 4096 directory
      Device: 821h/2081d Inode: 2 Links: 10
      Access: (0755/drwxr-xr-x) Uid: ( 0/ root) Gid: ( 0/ root)
      Access: 2015-11-16 18:38:24.223784770 -0500
      Modify: 2015-11-16 18:38:23.447766404 -0500
      Change: 2015-11-16 18:38:23.447766404 -0500

      The Access: section now matches all the other drives in my OMVserver.

      I "cd 5d3465f2-52fa-477b-a915-deb30d0942c9" and do "ls -la" and get this:

      root@OMVServer:/media/5d3465f2-52fa-477b-a915-deb30d0942c9# ls -la
      total 132
      drwxr-xr-x+ 10 root root 4096 Nov 16 18:38 .
      drwxr-xr-x 12 root root 4096 Apr 29 2015 ..
      -rw-------+ 1 root users 8192 Nov 16 18:18 aquota.group
      -rw-------+ 1 root users 7168 Nov 16 18:18 aquota.user
      drwxrws---+ 4 root users 4096 Nov 15 17:07 Development
      drwxrws---+ 15 www-data www-data 4096 Nov 14 13:34 Documents
      drwxrwx---+ 2 root root 16384 Jan 11 2015 lost+found
      drwxrws---+ 9 root users 4096 Jan 12 2015 Mental Expansion Files
      drwxrws---+ 9 ahmad users 36864 Jul 6 00:01 Music
      drwxrws---+ 115 ahmad users 12288 Feb 14 2015 My Comics
      drwxrws---+ 17 ahmad users 4096 May 27 23:17 Pictures
      drwxrws---+ 20 ahmad users 4096 Nov 15 22:03 Software Stuff

      I haven't reinstalled plexmediaserver yet. As you can see, things are a bit messed up in the permissions, no?
    • ermac wrote:

      5d3465f2-52fa-477b-a915-deb30d0942c9" (MyPersonalArchiv) where i want plexmediaserver folder to be in, has these permissions "Access: (2770/drwxrws---) Uid: ( 1000/ ahmad) Gid: ( 100/ users)


      When you created a shared folder in the web gui it normally has setgid 2, the first digit in chmod, and this is OK if it is the folder and not at the root. When you create shared folder never use just "/" for the path, a forward slash. Make sure you have have the name of the folder in the path to when you create it. An easy way to check if you accidentally created a share at the root if to:
      cd /media/5d3465f2-52fa-477b-a915-deb30d0942c9
      mkdir test

      Then stat the folder:
      stat test

      If you a 2 in the first digit and an s in the chmod values and chown is root:users it had acquired these values because the root of the drive was shared. When the root of the drive is shared with setgid as 2 all subfolders/files will get same group recursively.

      The post was edited 2 times, last by tekkb ().

    • Hello,



      im very new in this omv/plex world.

      I dont know whether I am in the right threat.
      pleace excuse and link to the right part of the forum.

      so thats my problem:

      I installed omv on raspberry pi 3.

      plexmedia addon is installed too.

      My sony BDP-S5500 shows the connected Mediaserver in its smart-Menu. everything works ...

      ALso PLexMedia WebSurface shows every contents I load up in the Folders....

      But in my s5500 I only can find Musik and Videos. It works with MP3, Wave, mkv and mp4.
      But didnt find any jpg or bitmap.

      Can any body help me? I thought that I can stream all media files not only music and movies.
      Images
      • omv version.PNG

        22.92 kB, 645×270, viewed 58 times

      The post was edited 1 time, last by robbsche: more infos ().