Problem mit Plex Media Server

    • OMV 1.0
    • Problem mit Plex Media Server

      Hallo alle,

      ich habe im Forum bisher nichts gefunden, dass mir weitergeholfen hätte.
      Kurz folgendes zu meinem Problem:
      Ich habe über die Web-Oberfläche von OMV das Plugin Plex installiert, aktiviert und über den Web-Client Button die Plex Web-Page geöffnet.
      Nach der Anmeldung läuft das auch soweit, ABER es kommt die Meldung "Sie haben für diesen Server keine Zugriffsberechtigung.".
      Hier kurz ein paar Infos, die in gelesenen Foren immer wieder abgefragt wurden.
      Hat jemand eine Idee zu diesem Problem?
      Sind weitere Infos notwendig?

      Source Code

      1. root@Homeserver:~# /etc/init.d/plexmediaserver status
      2. Plex Media Server process running.


      Source Code

      1. root@Homeserver:~# id plex
      2. uid=112(plex) gid=116(plex) Gruppen=116(plex)


      Source Code

      1. root@Homeserver:~# dpkg -l | grep openmediavault
      2. ii openmediavault 1.19 all Open network attached storage solution
      3. ii openmediavault-autoshutdown 1.0.8 all OpenMediaVault AutoShutdown Plugin
      4. ii openmediavault-backup 1.0.11 all backup plugin for OpenMediaVault.
      5. ii openmediavault-clamav 1.3 all OpenMediaVault ClamAV plugin
      6. ii openmediavault-keyring 0.3 all GnuPG archive keys of the OpenMediaVault archive
      7. ii openmediavault-links 1.5 all OpenMediaVault links plugin
      8. ii openmediavault-minidlna 1.0.11 all OpenMediaVault miniDLNA (DLNA server) plugin
      9. ii openmediavault-omvextrasorg 1.28 all OMV-Extras.org Package Repositories for OpenMediaVault
      10. ii openmediavault-plexmediaserver 1.0.12 all OpenMediaVault Plex Media Server plugin
      11. ii openmediavault-rsnapshot 1.0.11 all OpenMediaVault rsnapshot backup plugin.
      12. ii openmediavault-unionfilesystems 1.8 all Union filesystems plugin for OpenMediaVault.
      Display All


      Viele Grüße und im voraus Danke!
    • yes i did the Port Forwarding .... also i tried this command:

      Source Code

      1. ssh ip.address.of.server -L 8888:localhost:32400

      Edit:
      Here the output of the command

      Source Code

      1. bind: Address already in use
      2. channel_setup_fwd_listener: cannot listen to port: 8888
      3. Could not request local forwarding.


      Still no connection with the server with the web app


      The post was edited 2 times, last by Pascal ().

    • ssh ip.address.of.server -L 8888:localhost:32400

      Why would you tunnel local port 8888 to 32400? This is wrong and not necessary.

      If you are remote and no client use this:

      Source Code

      1. https://plex.tv/


      Otherwise use a client.

      If you want to access the server for settings use ssl. You have to be signed in with your plex account in the server settings at Settings/Server/General for remote access. Forward port 32400, which should be done already, to your OMV from your router and access like so:

      Source Code

      1. https://wanipofyourlan:32400/web/index.html


      But I don't recommend accessing the Plex server UI from the net. Better to just use the plex.tv or client. Only change server settings when you are on your LAN, or you could do via OpenVPN connection. Once server settings are setup you don't need to play with these often.

      See picture for Plex Web UI via OpenVPN session... You have to sign in because the VPN connection is on another subnet. You can in the web server settings of the Plex Web server allow another network without login though. But I don't recommend it.

      No need to mess with SSH tunnel & port forwarding. You have been reading plex forums to much. :)
      Images
      • plex web ui via openvpn.jpg

        54.18 kB, 1,001×524, viewed 471 times

      The post was edited 11 times, last by tekkb ().

    • Hey Tekkb,

      thanks for all!
      I don´t know why, but today, i came home, and everything´s working fine ^^

      But your right, i realy read a lot the last days :D
      I have one last question. The picture you have posted, is a screenshot from omv isn´t it?
      There is shown the plex web page, is that normal or only possible with openvpn?
      In my explorer only a blank page is shown.
    • Screenshot looks fine. Did you refresh the page? If that didn't work, did you clear the browser cache?
      omv 4.1.12 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!