openmediavault

The open network attached storage solution

News

  • New

    I have two external usb drives on a RPI running OMV. On a recent startup, only 1 of two drives (sdb) showed up after OMV started. I found the cause of the problem and restarted omv. I can see both drives under the storage, disks option. The array hasnt started a rebuild as I would have expected.

    When I look at the array status in ovm gui, it only shows sdb1, not sda1. Given the situation, wasnt sure how to readd the drive to the raid 1 array.
    Would appreciate any suggestions.

    Ron
  • New

    Just getting into folder permissions and I have a few questions so far.
    When adding a shared folder I have to set its basic permissions of owner/group/others. That is clear. Right after creating the folder I can go to ACL extra options. Do these options correspond to what I've setup when adding the folder? So I could for example change the folder group here from users to lets say 'mediaUsers' and give all of them the permission they should have? Am I correct?

    I furtheremore noticed that I somehow cant access a folder via SMB share what I have read/write privileges for. As soon as I grant myself execution privileges, I can. Could anyone explain that behavior?

    Thanks! :)



    EDIT:

    So for what do U guys actually use the privileges Button? I read many of you are using only that, but that means that you must grant everyone all privileges on system permission level don't you? Wouldn't it be way more secure to grant only the privileges needed for every user/group on system level?

    Example1:…
  • New

    Hi,
    Having used proxmox (at work) and OMV (at home) for a while, I would like to add a virtualized Linux box in my OMV NAS. For specific reason, I cannot use Docker. So, initially, I thought to keep OMV as the main OS and to add LXC/LXD into it, so as to add one or two containers (I won't need more). Thus, OMV would be the one responsible for all data backups, including of the containers.

    But I also saw that a few (many?) here are using proxmox as raw OS, and OMV as a container in it...

    For those who have choosen either way:
    - Are there big advantages or drawback of chosing either way (OMV as a container, or OMV as plain-vanilly OS) ?
    - If you run OMV as a container in LXC/LXD or in proxmox, what is your backup strategy? Is Proxmox in charge of the backups, or OMV, or a mix of both?
    - If you run OMV as a container in LXC/LXD or in proxmox, how do you install it (notably for partitioning) and what is your OMV system disk?

    Thanks for your ideas and times!
    Regards

Unread Threads

Topic Replies Last Reply

Backing up USB Installation

43

crashtest

Unclear network behaviour

14

spaxton

OMV Problem with startup.

10

IamBartjuuh

How to re-add a drive that didnt show when omv first started up

1

cabrio_leo

Folder permissions, ACL, again

7

HannesJo

Recent Activities

  • crashtest -

    Replied to the thread OMV 4.x Backing up USB Installation.

    Post
    When in prep for breaking of your RAID1 set; I'd suggest running at least a short test and checking the SMART stat's of the drive you'll be using to house a *single copy* of your data. These items are under Storage, SMART, in the Devices and Scheduled
  • spaxton -

    Replied to the thread OMV 4.x Unclear network behaviour.

    Post
    Quote from crashtest: “Let us know how it went with NetworkManager and info in the link, one way or the other. It's a configuration issue that must be looked at, so your results will be of interest. ” Yes, sure. I will post the results here as soon…
  • IamBartjuuh -

    Replied to the thread OMV 5.x (beta) OMV Problem with startup..

    Post
    Okay whut I looked at everything and in this: bit.ly/2kmTZBS picture you can see that it boots into /dev/sdf1 and if I do exit in debian build-in shell (which i will boot in btw idk why) it says this: bit.ly/2kdQaP8 ALERT! /dev/sdf1 does not exists.…
  • IamBartjuuh -

    Replied to the thread OMV 5.x (beta) OMV Problem with startup..

    Post
    Quote from KM0201: “Quote from IamBartjuuh: “Quote from KM0201: “Man.. it's been forever since I've seen an IDE port...lol. Nostalgic. Did you actually manage to get installed, and this is happening on the install, or are you getting that while…
  • IamBartjuuh -

    Replied to the thread OMV 5.x (beta) OMV Problem with startup..

    Post
    Quote from macom: “Boot your server in the same configuration as you installed it. I.E if the data drives were not connected during installation, boot without data drive. That should work. Then execute update-grub Shutdown, connect data drives,…
  • cabrio_leo -

    Replied to the thread OMV 4.x How to re-add a drive that didnt show when omv first started up.

    Post
    USB RAID is no longer supported via the OMV 4 user interface - and not recommended (too many problems, for RPI´s often regarding the power supply of the connected disks). Therefore you will have to do the job by CLI.
  • rnutter -

    Posted the thread OMV 4.x How to re-add a drive that didnt show when omv first started up.

    Thread
    I have two external usb drives on a RPI running OMV. On a recent startup, only 1 of two drives (sdb) showed up after OMV started. I found the cause of the problem and restarted omv. I can see both drives under the storage, disks option. The array…
  • shockwave -

    Replied to the thread OMV 4.x Backing up USB Installation.

    Post
    Quote from macom: “ the setting is called -icds It is used to enable/disable checking the size of the target drive before starting the clone process. Worked always for me, but others had issue with it. ” Thank you. This worked for me. I was able to…
  • HannesJo -

    Replied to the thread OMV 4.x Folder permissions, ACL, again.

    Post
    Okay I think i get your point. I found it just a bit confusing because since you have to be aware of correct system permissions, anyway.. I was wondering why one should not do everything with that. Security might not be an issue. It just feels a bit like…
  • macom -

    Replied to the thread OMV 4.x Update No gui (error 500) after update.

    Post
    ?(