The open network attached storage solution


  • New

    first time Linux and OMV user here.
    just installed OMV 5.0.5 and the web interface viewed from a remote computer gets a 502 Bad Gateway nginx until you logon as root at the NAS console. then you can log off root, or stay logged on, it doesn't matter, the web interface works until reboot. then you have to logon as root at the NAS console again to get access.

    if you reboot from the remote web interface, the NAS reboots and the web page says loading... loading... loading... (it has lost connection) and when you refresh the page you get kicked because your auth has expired.

    I needed to use the NAS as a headless unit. can't login every time to allow me to work remotely. isn't this a configurational issue?

    one thing that was different during install, was that the NAS doesn't have access to the internet so it couldn't download a few gigabytes of data from a Debian server, so it said you can continue but your installation will be lacking. I hope that didn't have anything to do with it…
  • New

    Hi All,
    I've been running OMV 5 for a few weeks, serving up content to my media player, configured with a Static IP address, but when I check System > Network > Interfaces in the Web Console, nothing is displayed.
    I get the same thing after clearing the cache and even tried a different browser.

    I tried running omv-firstaid and re-applied the network settings, but when I was finished, it gave me the following error:

    Configuring network interface. Please wait ...
    ERROR: __init__() got an unexpected keyword argument 'http_status_code'

    After the above error in the command line, the Web console said that there was a config change that needed to be applied, but when I tried that, I also got an error (I didnt note it unfortunately) and I ultimately reverted the changes.

    I read somewhere that it may be safer to use DHCP and set up the router to assign the same address, but I wanted to get some input here first in case there may be other issues at play.

    I want to set up Docker, but want…
  • New

    Hello everyone , it's my first error since 2 years and i dont understand
    I have this error

    Source Code

    1. Error #0:
    2. OMV\Exception: Failed to read file '/var/cache/openmediavault/cache.omv\controlpanel\login_js.json' (size=0). in /usr/share/php/openmediavault/json/
    3. Stack trace:
    4. #0 /usr/share/php/openmediavault/json/ OMV\Json\File->getContents()
    5. #1 /usr/share/php/openmediavault/controlpanel/ OMV\Json\File->read()
    6. #2 /var/www/openmediavault/index.php(46): OMV\ControlPanel\ControlPanelAbstract->render()
    7. #3 {main}
    i use sudo omv-firstaid -> clear web control panel cache
    console : Clearing the web control panel cache. Please wait ...
    ctrl+r -> control panel show login + password
    if i submit my login + password…

Unread Threads

Topic Replies Last Reply

No network interface displayed in System > Network > interfaces



web interface 502 Bad Gateway until after logging in as root on console.



web interface 502 Bad Gateway until after logging in as root on console.



Trying to install Pihole



Help for SMB



Recent Activities