openmediavault

The open network attached storage solution

News

  • New

    I had a set of four old 4TB drives sitting around, so I bought a few enclosures and a hub so I could build an OMV NAS from a Pi 4 for experimentation. I can see all four drives in the Disks page, and was able to wipe all 4, and in the File Systems page I was able to format them all as EXT4. After formatting though only one drive at a time will show up in the File Systems page. If I mount it, it will show me another disk as unmounted. When I try to mount that one it refreshes and shows me the disk I had originally mounted as mounted.

    I suspect that the issue is the enclosure (amazon.com/gp/product/B01JNLCC7U/), because it shows all four drives as having the same serial number. Can anyone confirm?
  • New

    Hallo,
    nachdem ich mich jetzt seit Wochen mit der Einrichtung eines NAS Systems auf einem Raspberry PI4 beschäftigt habe und das System nun lief, sind mir nun mehrer GB an Daten nach einem Reboot verloren gegangen.
    Das System läuft auf einem Rspberry PI4 mit 4GB Arbeitsspeicher.
    Vers. 4.1.31-1
    Dateisystem ext4
    Kann leider nur noch gelöscht werden und lässt sich nicht mehr einbinden. ?(

    Beim Reboot wurde folgendes ausgegeben:
    Timed out waiting for device dev-ttyS2.device
    Dependency failed for Serial Getty on ttyS2
    Timed out waiting for device dev-disk-by\x2dlabel-NAS1.device
    Debendency failed for File System Check on /dev/disk/by-label/Nas1
    Debendeny failed for /srv/dev-disk-by-label-NAS1

    Ich hoffe es gibt eine Möglichkeit, die Daten wiederherzustellen.
    Bei der Festplatte handelt es sich um eine relativ neue Seagate Baracuda 6TB.

    Eventuell hat jemand eine Idee, wie ich hier vorgehen könnte um das Dateisytem wieder einbinden könnte.

    Viele Grüße Oliver Brückner ;(
  • New

    I'm a few days busy with setting up my Pine64 NASCase with a ROCKPro 64 4GB SBC together with a 3TB WD Red HDD for a few days now, but I got the error "communication failure" everytime I want to create a filesystem under [Storage - File Systems]

    I see there are a few topics in the past regarding this (javascript 60 seconds?) error, but it seems it's still not solved!?

    Earlier topic(s):
    communication failure

    From this tracker: :
    github.com/openmediavault/openmediavault/issues/78

    I debugged the system, see the logging in the txt attachment

    Source Code

    1. monit stop omv-engined
    2. omv-engined -d -f
    Meanwile the GUI showed this:

    Source Code

    1. Creating the file system, please wait ...
    2. ===== Wipe signatures from device =====
    3. ===== Create partition =====
    4. Creating new GPT entries.
  • New

    hi,

    mostly done, the main nas moved to OMV5

    letsencrypt container to proxy nextcloud, omv and other stuff ist setup works fine so far.

    now i try to reconfigure the OMV Android APP and can't get it working with local Address and port 8080 (is set in OMV webUI) it can get the API but dosn't show anything. with my domain/omv the APP can't even get the API.

    anyone an idea? APP Developer @ forum? still working on? ;)

    thx
    drddy

Unread Threads

Topic Replies Last Reply

2nd IP for tvheadend and avm DVB-C

5

geaves

Lost all drives

31

geaves

OMV5, Portainer, MariaDB, Nextcloud, Let's encrypt - how do I make it work?

6

igonixio

Dateisystem nach Reboot fehlend

1

cabrio_leo

Can't Mount More than One Drive

0

Recent Activities

  • geaves -

    Replied to the thread OMV 5.x (beta) 2nd IP for tvheadend and avm DVB-C.

    Post
    Quote from draddy: “what i have to do more to use 2 ip's in the same network with one container? ” Pass...how long is a piece of string :) but I know a man who might @Morlan
  • geaves -

    Replied to the thread Lost all drives.

    Post
    Quote from LarryM04: “I did notice that as the system came back up it ran an fsck on the raid and corrected errors. ” Sometimes a reboot just resolves what appears to be the obvious. Quote from LarryM04: “Now that its back can you give me a…
  • igonixio -

    Replied to the thread OMV 5.x (beta) OMV5, Portainer, MariaDB, Nextcloud, Let's encrypt - how do I make it work?.

    Post
    - portainer > Stacks > Add Stack - Name: nextcloud, this code Source Code (93 lines)- change domain on line 62 and 66. You can use a subdomain like sub.domain.tld or domain.tld. Password on line 25. - "Deploy the stack" - Go to your domain and hope it…
  • LarryM04 -

    Replied to the thread Lost all drives.

    Post
    Oh, I do see that the B drive dropped out. Is there something I can do not as drastic as "Wipe" and re-add?
  • LarryM04 -

    Replied to the thread Lost all drives.

    Post
    root@helios4:~# cat /proc/mdstat Personalities : [raid10] md0 : active raid10 sdc[6] sdd[5] sda[7] 15627790336 blocks super 1.2 512K chunks 2 near-copies [4/3] [U_UU] bitmap: 10/117 pages [40KB], 65536KB chunk unused devices: <none> THE FILES ARE…
  • igonixio -

    Replied to the thread OMV 5.x (beta) OMV5, Portainer, MariaDB, Nextcloud, Let's encrypt - how do I make it work?.

    Post
    Third: nextcloud - on console create a database for nextcloud Source Code (8 lines) - copy this to /home/<your_user>/traefik/nextcloud_conf_files/nginx.conf (Hidden Content) Source Code (168 lines)
  • cabrio_leo -

    Replied to the thread OMV 4.x Dateisystem nach Reboot fehlend.

    Post
    Hallo Oliver, du versorgst die Baracuda aber schon separat mit Strom und nicht über den RPI4, oder? Power-Probleme sind eine der häufigsten Ursachen von Problemen mit RPIs. Hast du eine Gelegenheit, die HDD an einen anderen Linux-Computer…
  • draddy -

    Replied to the thread OMV 5.x (beta) 2nd IP for tvheadend and avm DVB-C.

    Post
    hi, excact this how-to i used to configure. after rebuild the conatainer i can use the macvlan network, container start, use IP from macvlan all ok- but i can't get a second ip address. what i have to do more to use 2 ip's in the same network with one…
  • igonixio -

    Replied to the thread OMV 5.x (beta) OMV5, Portainer, MariaDB, Nextcloud, Let's encrypt - how do I make it work?.

    Post
    Hello, i use follow setup: Portainer > MariaDB > Nextcloud > traefik HowTo: Basics: - My home network has IP 192.168.178.1, Server on 192.168.178.191 - Need a DynDNS Service and a own Domain. I use selfhost.de with my domain and FRITZ!Box. - Needs a…
  • geaves -

    Replied to the thread Lost all drives.

    Post
    Ok that's why, reboot the machine and check cat /proc/mdstat if it shows the same as your post 20 active (auto-read-only) then run the --readwrite command. If it's the same as the above it will need to be assembled again :(