openmediavault

The open network attached storage solution

News

  • New

    502 Bad Gateway nginx

    updated from version 3 to version 4
    web interface has stopped working


    Source Code

    1. root@storage:~# dpkg -l | grep openm
    2. ii openmediavault 4.1.27-1 all openmediavault - The open network attached storage solution
    3. ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive
    4. ii openmediavault-nut 4.0.13-1 all OpenMediaVault Network UPS Tools (NUT) plugin

    Source Code

    1. omv-firstaid
    2. ERROR: Failed to connect /var/lib/openmediavault/engined.sock: [Errno 2] No such file or directory
  • New

    Hi Guys,

    I had Raspbian buster lite and was able to install OMV5 beta following techno dad video.

    But i wanted to try the stable OMV 4 version instead of beta.

    So, i downloaded the OMV_4_Raspberry_Pi_2_3_3Plus_4.img.xz and flashed it as it is via Etcher to my sdcard.

    I just connected the power source and Ethernet cable (same setup as OMV5) but i am getting only Redlight.

    I left it for more than 1 hour but still nothing. Is there any way to find out if something is going on or any other procedure to install OMV 4 in Pi3B.

    Cheers!!!!
  • New

    I am trying to repair OMV Array and I assume I have to remove a malfunctioning device from the RAID 5 Array in OMV before pulling the malfunctioning 2 TB HDD from the server. The problem is, I can't get OMV to load as it sees a dirty file system and is stuck on repair before raising the network(i.e., "A start job is running for LSB: Raise network interfaces."). I see in logs "kicking non-fresh sda from array!" and "raid level 5 active with 4 of 5 devices algorithm 2". I am also seeing references to 0xe frozen (I assume this is the malfunctioning drive) . I also see fsck failed with error code 4.

    I am attaching some screen captures.

    Questions:

    1. Is a reinstall of OMV required? ?(

    2. Can I just pull the malfunctioning drive and replace and assume the errors will resolve so I can add the new drive to the array and rebuild? ?(

    Hoping someone can help? I backed up the array before I lost access to the server. I just wish to avoid rebuilding it if I can.


    Fotafm…

Unread Threads

Topic Replies Last Reply

502 Bad Gateway nginx

1

Constantine

502 Bad Gateway Web gui

46

Constantine

Windows 10: HDDs starts (spin up) always on start of windows (explorer closed)

4

Andreas 27

openmediavault 4.1.27 stable lots of errors?

6

Adoby

Issue with PLEX Docker

10

gderf

Recent Activities

  • Constantine -

    Replied to the thread OMV 4.x 502 Bad Gateway nginx.

    Post
    Source Code (3 lines)
  • Constantine -

    Posted the thread OMV 4.x 502 Bad Gateway nginx.

    Thread
    502 Bad Gateway nginx updated from version 3 to version 4 web interface has stopped working Source Code (4 lines)Source Code (2 lines)
  • Constantine -

    Replied to the thread OMV 4.x Resolved Upgrade 3.x -> 4.x 502 Bad Gateway Web gui.

    Post
    Quote from maciekelga: “Hi, today I have same problem with 502 Bad Gateway ngix, I can connect via Putty. I tried tu update omv but nothing changed. I`m using version 4. Can You help me? ” i have this problem how you fix it???
  • @cabrio_leo many thanks. Since I do not need the network drives all the time, I use now 'net use ....'. Works perfectly. Best Andreas
  • Adoby -

    Replied to the thread openmediavault 4.1.27 stable lots of errors?.

    Post
    Since it seems you are the only one having problems, it is likely that the problem is with you or with your gear.
  • gderf -

    Replied to the thread OMV 5.x (beta) Issue with PLEX Docker.

    Post
    After making the change to /etc/fstab did you remount all drives or reboot the machine? Plex downloads the codecs when needed, so if there is a network problem, this will fail. I always ask this question, so don't take it personally. I see you used…
  • Nefertiti -

    Liked crashtest’s post in the thread OMV 4.x Samba password never works..

    Like (Post)
    OK, so I'm guessing you believe it's a Windows thing as well, with one particular client. Have you tried this particular -> How-To. Specifically, the section titled: Domain Connected Windows 10 Clients / Servers I'd go as high as possible, 5 should
  • Nefertiti -

    Replied to the thread OMV 4.x Samba password never works..

    Post
    Yes for now it is working.
  • nonamer66 -

    Replied to the thread OMV 5.x (beta) Issue with PLEX Docker.

    Post
    Quote from gderf: “You are confused about folder permissions and a drive being mounted executable. You have a Path in container /config. This points to the Host/volume /srv/dev-disk-by-label-StorageOne/appdata/plex. The DRIVE that has the mount point…
  • raven.warsong -

    Replied to the thread openmediavault 4.1.27 stable lots of errors?.

    Post
    I dont know I have installed liniux distros a lot and never had any problem i mean apt update and apt install or setting a static ip adress should not brake any thing