Search Results

Search results 1-20 of 25.

  • Syncthing Refused to Connect

    threehappypenguins - - Docker

    Post

    I'm following the Techno Dad tutorial exactly, have the exact same settings in my docker (which include the same PUID & PGID as verified with PuTTY), and I can't connect to the server on port 8384. I have two different Odroid HC2's with OMV installed, and I'm having the same problem on both of them. The tutorial has me install the syncthing/syncthing container. I also tried the linuxserver/syncthing container, and am having the same issue. Where do I start in trying to get this problem resolved?…

  • Quote from lunchbox651: “Cache fixed that issue but my files still wont appear. I can see storage usage now but files still dont show. Here's what I have set: ” I'm having the same issue as you, but with my USB hard drive. Even if I SSH in, the files are not there. I tried ls -a and the folder is total blank. And yet it shows that the drive is nearly filled up (I did a backup over night). Any fix?

  • @GeorgeP so you can successfully have access to your Nextcloud Sharedfolder and if you drag and drop a file into it (using Windows), that the new files show up in the NextCloud interface?! I was told that this couldn't happen, and that I had to manually rescan for it to show up in the web interface. Unless I'm misunderstanding something?

  • I have NextCloud successfully installed on OMV, including remote access. If I transfer a 2 GB folder using my Windows filesystem (Samba), I can get speeds up to 90 mb/s, so it transfers very quickly. However, if I use the web interface to upload something, or the NextCloud desktop app to download something (download so it can sync), it's ridiculously slow. Example: the desktop app says I have anywhere from 6-8 hours left to download 2 GB. Is there some kind of configuration that I don't know abo…

  • Success!!! I was very close... so I Googled about 502 Bad Gateway with regards to getting Nextcloud on OMV working remotely, and I came across this thread, which then brought me to this thread. After reading about checking to see if the network and proper dockers were joined, I thought, "But I already did that under the Networks tab in docker." But I decided to check anyway. I saw that the nextcloud docker was joined to my-net (the network I created), but letsencrypt was not! So I joined letsenc…

  • I think I may have made some progress. I read this thread, and after changing the line proxy_max_temp_file_size 2048m to proxy_max_temp_file_size 1024m in the nextcloud.subdomain.conf file and restarting the letsencrypt container, I noticed that ports 80 & 443 were still open! However, when I tried to access myserver.domain.org, I got "502 Bad Gateway". If I completely delete the line proxy_max_temp_file_size 1024m (or 2048m which is default), ports 80 & 443 are still open, but I still get "502 …

  • I am following this this tutorial to try and get NextCloud working remotely, but I am getting a "refuse to connect" error when trying to access Nextcloud through my domain. During setup of everything, I get an error (another post) when I tried to add --network my-net to Extra arguments both in the nextcloud and letsencrypt containers. For the letsencrypt container, however, I am successfully able to add --cap-add=NET_ADMIN to Extra arguments. From my previous thread I created, I am pretty sure t…

  • Quote from cj2tech: “Quote from cj2tech: “I had this issue too. The issue is that techno dad video is out of date. In both videos he is missing permissions. For lets-encrypt and for nextcloud. To fix it I had to stop the dockers delete and remake the config folders and then enter all the permissions based off of what they said on docker hub (See links below). Lets-encrypt = hub.docker.com/r/linuxserver/letsencrypt/ Nextcloud = hub.docker.com/r/linuxserver/nextcloud/ ” For Lets Encrypt you need t…

  • Update: I stopped the Letsencrypt service, deleted the container, deleted the Letsencrypt folder, and started over with Letsencrypt. It probably didn't work because I had initially created Letsencrypt without --cap-add=NET_ADMIN in the arguments, figuring that I would have to find a GUI way of adding Fail2ban. But then I decided to modify the Letsencrypt container and try adding --cap-add=NET_ADMIN to the Extra arguments, and it worked. But it was probably my modifying the container that screwed…

  • @Morlan,I did go ahead and went to the tab "Networks" clicked on "my-net" and chose the Nextcloud container and pressed okay (left everything else blank). Then I noticed that when clicking "Run Image" and adding all the info for Letsencrypt, that the tutorial is having me add --network -my-net again in Extra Arguments. Not a problem with repeating the process and adding Letsencrypt to my-net with the GUI like I did with Nextcloud. I just simply left --cap-add=NET_ADMIN by itself in Extra Argumen…

  • So I have a question about this thread. Morlan wrote: "You can try joining the containers in the network settings of the docker gui. I wasn't sure what this meant, so in the Docker GUI, I went to the tab "Networks" clicked on "my-net" and chose the Nextcloud container. Is this what I'm supposed to do? If so, do I put my Odroid's IP address in the IP address section? (the IP address I use to log into OMV) I'm just confused about the solutions.

  • I'm trying to follow this tutorial on setting up NextCloud remote access. At about 9:57, when I go to put --network my-net into Extra arguments, I get this error: Source Code (1 line) The details are as follows: Source Code (11 lines)Then I simply have to cancel modifying the container. After this, my nextcloud container completely disappears. I tried docker restart nextcloud, and it says no such container. So then I tried creating the container again, and Nextcloud was working fine and I could …

  • Yes, I have an external drive that I currently back everything up with, that I wrap in tin foil (EMP or solar flare protection), put in a ziplock (water), and place in a fire proof box. I *always* have at least two copies!

  • I'm not really sure what there is to disagree with. Not everyone wants the same type of setup. I have run out of room on my laptop HDD again, and decided to instead purchase an Odroid HC2 in order to transfer (not sync) all my important documents, pictures, videos, etc onto there to be accessed (again, not synced) from any device (phone, other laptops in the house, etc). And I want remote access too (which I'm going to set up next). I also want to set up SymLinks. SymLinks are useful for my kids…

  • This is *exactly* the information I'm looking for!!! Thank you!!! I want to have symlinks, remote access, etc. But as far as I understand, the desktop client is for syncing, which I don't want. My laptop has 1 TB, but I have a massive amount of documents, pictures, videos, etc from over the years, and buying expensive laptop drives every time I run out of room is going to get pricy. So I figured it would be best to have a central server with all my files at home, but access to this server on eac…

  • I had the same issue, until I went to SMB/CIFS > Shares > Nextcloud_data_folder (whatever you named it) > Edit and toggled on Enable permission inheritance. I was able to open the folder from Windows after this point. Even if I toggled it off again, which is weird. But now my issue is that if I create a folder or file in NextCloud, it shows up in my Windows folder. But if I create a folder or file in my Windows folder, it doesn't ever show up in NextCloud. I used Shell in a box to navigate to th…

  • I deleted NextCloud and reinstalled everything, and I got the same issue. Didn't have permission to open the folder on Windows once I logged into NextCloud. I went to Samba settings in OMV, and under Shares, I chose the data folder where I have all my NextCloud stuff, and clicked on Edit. I toggled on Inherit Permissions. Once I did that, I could access the folder from Windows. What's weird, is if I toggle it off again, I can still access. But I still have the same issue where if I create a fold…

  • I have Samba enabled, and at first, I followed these instructions to change the permissions in the smb.conf file so that I could access Nextcloud from Windows. That didn't work. So I poked around more and went to Shared Folders > PHS > ACL and under "Extra Options," changed Owner and Group to www-data. That seemed to solve the issue and now I can both access my files on Windows and the web app for NextCloud. The issue now is that if I make a change on Nextcloud, it shows up in Windows. But if I …

  • I had to resort to deleting the Nexcloud containers and starting all over. I think I know what went wrong. I hit "enter" as I put in an admin and password for first log in to NextCloud, when I was supposed to click on MySQL/MariaDB and enter my other info that I created. It hung for a long time, and I realized I did it wrong and refreshed and did it again. But what I didn't know is that because I did that, by default, under "Data Folder," it says "/data" which is exactly what I noticed when I we…