Dell poweredge 2950 installation problem

    • Dell poweredge 2950 installation problem

      hi all,i am new here,nice to meet you.i been working around openmediavault for a while.I have an omv that is installed on my office desktop,i used it as my small office NAS.Couple days ago,my bro came to my house and he gave me a Dell poweredge 2950 and said he wants me to make a NAS for his school,simply just for sharing files between coworkers.I tried to install omv with my usb thumbdrive the newest version,i got some problem which is preventing me to finish the installation:
      1.The server got 2 Gigabit NICs,whatever i plug my network cable into either one of them,they could not get an ip address from router DHCP.
      2.I forced to assign the static ip address and finished the installation and it looks like worked,i could remotely login by using web interface.i just did not understand why.
      3.After i updated all stuffs,i rebooted the system,the system could not boot,i had to plug my thumbdrive into server and choose boot from my usb thumbdrive and it worked,the system ran again,
      If anyone can give me any idea would be very appreciate,thanks a lot,i am a bit of hasty. :P
    • During the installation process,there is a step where you can set ip address manually.and after the installation let me choose the ftp mirro or something like that,i skipped that step,and installation process told me if i skip that step which let me choose the ftp mirro address close to my position the result of that is i will have a minimum system without any update,and i did it,reboot it.the weird thing is i can not boot the system without my usb is the point lol,,wish you can help me ,thanks very very much.
    • The installer put the grub loader in the USB drive. After you boot the system, remove the USB drive and run grub-install /dev/sda

      then run update-grub

      see if you can boot without the USB key, make sure sda is your OS/boot disk
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10 broadcast channel
      openmediavault discord server

      The post was edited 2 times, last by subzero79 ().

    • Sorry to wake up such a old thread but I just got a Dell 2950 and I am also having problems getting the network card working. I have tried to configure the IP manually but it still will not connect to the internet. IT has two nics and I have tried them both. Any one have any thoughts?

      I was able to manually config the NIC but the nic would not work until after I rebooted so that when I tried to add a repo it failed.

      Can someone please let me know what all I should have in my sources.list? I added a few and got some things going but I think I missed a few.
      NAS Details: New Server Build
    • blindguy wrote:

      It turns out that the broadcom drivers are no longer supplied with debian. So I went and downloaded bnx2 and bnx2x and then copied them to the /firmware folder on the OMV USB stick that I used to install and everything worked fine.

      Oh really? What are the firmware-bnx2 and firmware-bnx2x packages then? :) I have OMV running on a couple of Dells with Broadcom NICs and they work fine.
      omv 5.2.3 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.2.1 plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • If it has been running for a while it might have been installed fine but never removed.

      Here are the Jessie packages:

      Here are notes I found on the internet:

      Important NoteThe driver neccessary for the network cards is the kernel module 'bnx2'. This has been removed with kernel 2.6.23 because of GPL-violations, so you can only use installers/kernels up to 2.6.22 if you need the network cards.
      With kernel 2.6.25 the module has been added again, but without the neccessary firmware. So the network cards would only work with lenny if lenny will use 2.6.25 and with the right firmware.

      The firmware-bnx2 in non-free include the required firmware for the network card to work with the 2.6.26 kernel included in lenny.

      You can also read more at:…netxtreme-ii-bnx2-driver/
      NAS Details: New Server Build
    • I don't know when they dropped these firmwares in wheezy. I never heard that and never had any problems. I routinely installed on test systems. I thought they only dropped them in lenny days. I can guarantee that they are available in wheezy, wheezy-backports, jessie, jessie-backports now. Obviously newer servers may need the newer version from the backports repo and you have to have the non-free flag in your sources.list (added by default by OMV install).
      omv 5.2.3 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.2.1 plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!