["solved"] Firewall Config (MineOS via VirtualBox)

    • OMV 2.x
    • ["solved"] Firewall Config (MineOS via VirtualBox)

      So I got an instance of MineOS running on my OpenMediaVault Server in a VirtualBox VM. Unfortunately the clients can't connect to it:
      - Connecting to the MineOS webinterface (on the instance on the OMV system) works without problems (port 8080)
      - if the VM runs on the desktop, the client is able connect to it (via port 25565, MineOS default server port)
      - on both systems, the VMs network conection type is set to bridged

      my totally uneducated guess is that the firewall that comes with OMV blocks connections on port 25565 (?)

      Anybody could help me out on the config side ?

      I configured the following rule, for TCP and UDP (I removed the first 3 bytes from the ip-addresses)
      dir: INPUT
      Action: Accept
      Source: ...1-...100
      SourcePort: 25565
      Destination: ...11
      DestinationPort: 25565
      Protocoll: TCP (/UDP)
      no extra options

      but the connection is refused if I try to connect to the MineOS (virtual) server or the OMV ip via telnet on mc-server port
    • Unless you created a firewall rule that blocks it, that shouldn't be it. OMV has no firewall by default.
      omv 4.1.22 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • The default firewall policy INPUT, FWD, OUT comes with ACCEPT, in a normal LAN environment all clients should open services in a bridged VM.

      If you're not sure, check with iptables -vnL you should see

      Chain INPUT (policy ACCEPT 12M packets, 6853M bytes) and the rest down also

      If there are any rules you flush the whole filter table with iptables -F
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server
    • Sorry for the late reply, I had a hardware fault on my server (bad power supply) and it took some time till I could get a replacment.
      But to wrap this up quickly:
      After fixing the hardwar problem I decided to reinstall the system and "tada" everything is working fine "ootb", probably messed something up on my first install