I broke Samba somehow

    • OMV 2.x
    • Resolved
    • I broke Samba somehow

      Hi everyone,

      I appear to be in a spot of bother after installing PLEX and attempting to fix it. All my Samba shares are now un-navigable and it's somewhat frustrating!

      Please keep in mind that whilst I've played with Linux in the past, this is my first actual foray into using the operating system... getting into the commandline has been tricky but fun! I can follow instructions quite well at least. I'm not putting up my configs just yet because there's a lot of them and I don't want to create a wall of text if I can help it.

      The trouble starts...
      We have PLEX running on a Windows machine and I decided after things were running smoothly that it was time to move PLEX over to our shiny new OMV setup. I was trying to fix an issue with the PLEX service flat-out refusing to start following a reboot. Right now that's secondary to getting my Samba shares back as my household uses it to host files for our Windows-based PLEX and also as a way of transferring video edits and other large files. Additionally we intend on storing backed up Steam games there for a lan party this weekend (fingers crossed) so that's my deadline. One of the suggested fixes called for manually creating a user called "plex" and another suggested I alter permissions on my media share. Since then I've found that the Samba shares are browsable but I cannot open them.

      We're running our shares out of a Aufs created drive called "Rusthaven" which so far comprises of 4 other drives. We have more available but they aren't in use yet. I'm not actually done configuring the server, but it was at a point where I was happy transferring stuff over from the drives failing in my old QNAP because failing drives are quite sub-optimal. In that I have Couch, lost+found, plexmediaserver (for the database), some custom folders for SAB and then Shares and Test. Shares is the main folder containing our share files. Inside there I have Games, Movies, Documents etc all shared out individually so that we can map them to drives easily. Test is naturally a test folder.

      As for installed plugins I'll give you a quick list. PLEX, as mentioned appears to be the cause of our issues.

      Samba is installed, as is Snapraid which seems to be doing a good job of existing so far. There are other plugins installed and activated, though they don't seem to be related in that they have their own folders on the root drive created by Aufs and it's not shared in any way, shape or form. The list includes SABnzbd, Couch Potato and Sonarr. I also have SSL activated so I can putty in. Very handy.

      Currently I've done the following:
      1. Created a new share folder via Web GUI the same way I did with the initial shares. In the Shared Folders menu I give everyone read/write permission and then when creating the Samba share I ensure that it has guest only access. I leave everything else as default.
      2. Manually edited smb.conf, tried changing security to share and then when that didn't work I added a line for "map to guest = bad user' after changing security back to default user.
      3. Manually changing permissions using WinSCP of the test share folder to 777 to see if that lets me in, as well as changing the owner from plex to root.

      Any assistance on this matter would be greatly appreciated, cheers!
      [ninja edit for readability]
    • Okay I think I found the cause of my issues, I was checking through the other tabs on WebGUI and found the support info one.

      This is up the top of the file, I'm reasonably certain it's not meant to be there as it's not commented out. <sharedfolder>

      <perms>0 = no permission|5 = read and execute|7 = read, write and execute</perms>

      Forum removed all the tabs present in the support info, but that first block is almost centred with the amounts of tabs stuffed in it.
      [Double edit]
      Dangit, I found the direct config.xml file and it appears that it's a template for what they're supposed to look like... Also appears commented out in the config.xml file itself. I am noticing that the mntref (assuming "mount reference"?) is not the mountpoint for Rusthaven itself, which is /media/4c02c547-ade4-44d2-bb26-5ea6fff6e836

      Additional update!

      I got desperate and installed OMV on a spare drive I had, and it appears sharing works! I'm still not sure if this is a Linux permissions issue or a config issue but I still have the old disks if someone wants to pick it apart. For now I'm just regularly backing up the config.xml file and I'm going to experiment as necessary. tekkb appears to have made a guide specifically for sharing PLEX on OMV so I'll start on that first and then move to less problematic things.

      The post was edited 3 times, last by LostCatchphrases ().