[SOLVED]Impossible to create shared folder

    • OMV 2.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • [SOLVED]Impossible to create shared folder

      Hello guy,

      I registered from your nice forum just to ask you some help. First of all, sorry if my English isn't very good and if my sentences are not very explicit, I am a belgian french speaker.

      I installed omv 2.2.1 on my raspberry pi3 to make a personal nas. Everything work, except the USB hard disk drive plugged into my rpbp3. Here is the whole error I meet when I try to create a shared folder in my hdd (after deleting it!). My HDD is 320g, in ext4.

      Source Code

      1. Failed to create the directory '/media/e6c8691b-972e-4a90-ba0c-4acb266c0c1f/300G': mkdir(): Read-only file system
      2. Erreur #6000:
      3. exception 'OMVException' with message 'Failed to create the directory '/media/e6c8691b-972e-4a90-ba0c-4acb266c0c1f/300G': mkdir(): Read-only file system' in /usr/share/openmediavault/engined/rpc/sharemgmt.inc:415
      4. Stack trace:
      5. #0 [internal function]: OMVRpcServiceShareMgmt->set(Array, Array)
      6. #1 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      7. #2 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('set', Array, Array)
      8. #3 /usr/sbin/omv-engined(500): OMVRpc::exec('ShareMgmt', 'set', Array, Array, 1)
      9. #4 {main}


      Other small question, I get used to use terminal (putty), but I don't have the username and the password to make it. Could you tell me what is it?

      Thank you for your help
    • gregours wrote:

      Here is the whole error I meet


      gregours wrote:

      Failed to create the directory '/media/e6c8691b-972e-4a90-ba0c-4acb266c0c1f/300G': mkdir(): Read-only file system


      The filesystem is read only. There could be multiple reasons why your filesystem is remounted as read only. Are you sure the power supply on your RPi is sufficient? Could you supply your syslog (You find it in the Log Section in the Webinterface)?

      gregours wrote:

      Other small question, I get used to use terminal (putty), but I don't have the username and the password to make it. Could you tell me what is it?


      Um, which image did you use to format your sd card with?

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • I finally "fixed" this. I changed the hard disk drive. I can tell you it was not an alim problem, because the 2nd hdd needs more power than the 1st.

      I have some other trouble, low speed on local sharing. I used the command windows+R and I entered \\192.168.X.X, it works. But when I copy or paste something, speed is arount 2mb/s. It's not very much for local sharing, how can I fix it?
    • Do you copy small or big files? How does read speed compare to your write speed?

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • Try the following via command line: Be carefull, keep in mind to replace with the correct UUID!

      Source Code

      1. dd if=/dev/zero of=/media/REPLACEWITHYOURUUID/tempfile bs=1MB count=10240
      2. dd if=/media/REPLACEWITHYOURUUID/tempfile of=/dev/zero
      3. rm /media/REPLACEWITHYOURUUID/tempfile


      Post the output. Depending on the actual speed of your drives, this might take some seconds to minutes.

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • Oh, when you copy it like that to the shell it will run all of the three commands right after each other. You should have some output sometime though, as I said, it could take some time.

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • I come back. I tried on a laptop, and the writing speed is really better. 2mb/s yesterday, and today 11mb/s!

      I have a last problem. On my other computer, windows 10, I can access to the nas, but I cant write anything.
      "you need permission to perform this action"

      And user seem well configured. Writing/reading permission are enabled. I do not understand...
    • gregours wrote:

      Can you (fast) explain, what those command will change?


      I wanted to see the write/read performance. It would've not changed anything.

      gregours wrote:

      and today 11mb/s!


      That sounds about right.

      gregours wrote:

      And user seem well configured. Writing/reading permission are enabled. I do not understand...


      When you created the shared folder, which permission set did you use?

      gregours wrote:

      PS; Silent, I'll kill you!


      Silence, I kill you! :thumbsup:

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • Source Code

      1. root@raspberrypi:~# dd if=/dev/zero of=/media/3db95698-c956-4636-b951-20cb321fd1c9/tempfile bs=1MB count=10240
      2. 10240+0 records in
      3. 10240+0 records out
      4. 10240000000 bytes (10 GB) copied, 308.189 s, 33.2 MB/s
      5. root@raspberrypi:~# dd if=/media/3db95698-c956-4636-b951-20cb321fd1c9/tempfile of=/dev/zero
      6. 20000000+0 records in
      7. 20000000+0 records out
      8. 10240000000 bytes (10 GB) copied, 317.907 s, 32.2 MB/s


      Is that possible to increase speed?

      All created users have reading/writing permission. It works on win8 with one user. But on win10, with mind, it doesn't work.
    • gregours wrote:

      All created users have reading/writing permission.


      I meant the permissions you chose when you created the shared folder, not what you assigned to your users.

      gregours wrote:

      Is that possible to increase speed?


      No. Thats the limit of USB2.0. And via the Network you're limited to 100mbit.

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • [Blocked Image: http://i.imgur.com/eTXGb8X.png]

      That is what I mean.

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • ​stat /media/UUID/sharedfolder

      Post the output of the command above.

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • You copied some weird character, type the command manually - and also replace sharedfolder with the name of your actual shared folder.

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.