Autoshutdown not working

    • OMV 2.x
    • Resolved
    • Autoshutdown not working

      Because nobody reacted the first time I'm hoping for a solution this time.
      Autoshutdown used to work and now it doesn't anymore.

      Output of fakemode tells me "no internet-adress found" and terminates the script in the end. What does this mean and how to solve it?

      Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
      Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
      Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
      Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' X Version: 0.9.9.10'
      Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' Initialize logging to local6'
      Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' /etc/autoshutdown.conf loaded'
      Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' ------------------------------------------------------'
      Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' Checking config'
      Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' LOADPROCNAMES is set to: 'smbd,nfsd,transmission-daemon,mt-daapd,forked-daapd' (default)'
      Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' TEMPPROCNAMES is set to: in.'tftpd' (default)'
      Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' If you want more processes monitored, please have a look at the expert-settings'
      Apr 22 15:26:26 NAS logger: autoshutdown[3014]: WARN: ' HDDIOCHECK is set to false'
      Apr 22 15:26:26 NAS logger: autoshutdown[3014]: WARN: ' Ignoring HDDIO_RATE'
      Apr 22 15:26:26 NAS logger: autoshutdown[3014]: WARN: ' ULDLCHECK is set to false'
      Apr 22 15:26:26 NAS logger: autoshutdown[3014]: WARN: ' Ignoring ULDLRATE'
      Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' SHUTDOWNCOMMAND is set to 'shutdown -h now''
      Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' Your Kernel supports the following modes from pm-utils:'
      Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' Kernel supports SUSPEND (SUSPEND to RAM)'
      Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' Kernel supports HIBERNATE (SUSPEND to DISK)'
      Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' Kernel supports HYBRID-SUSPEND (to DISK & to RAM)'
      Apr 22 15:26:26 NAS logger: autoshutdown[3014]: WARN: ' LOADAVERAGECHECK is set to false'
      Apr 22 15:26:26 NAS logger: autoshutdown[3014]: WARN: ' Ignoring LOADAVERAGE'
      Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' ------------------------------------------------------'
      Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' Reading NICs ,IPs, ...'
      Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' NIC 'bond0' not found, skipping 'bond0''
      Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' NIC 'eth0' found: try to get IP'
      Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' _check_networkconfig(): Run: #1: No internet-Adress found - wait 60 sec for initializing the network'
      Apr 22 15:27:26 NAS logger: autoshutdown[3014]: INFO: ' _check_networkconfig(): Run: #2: No internet-Adress found - wait 60 sec for initializing the network'
      Apr 22 15:28:26 NAS logger: autoshutdown[3014]: INFO: ' _check_networkconfig(): Run: #3: No internet-Adress found - wait 60 sec for initializing the network'
      Apr 22 15:29:26 NAS logger: autoshutdown[3014]: INFO: ' _check_networkconfig(): Run: #4: No internet-Adress found - wait 60 sec for initializing the network'
      Apr 22 15:30:26 NAS logger: autoshutdown[3014]: INFO: ' _check_networkconfig(): Run: #5: No internet-Adress found - wait 60 sec for initializing the network'
      Apr 22 15:31:26 NAS logger: autoshutdown[3014]: WARN: ' No internet-Adress for eth0 found after 5 minutes - The script will not work maybe ...'
      Apr 22 15:31:26 NAS logger: autoshutdown[3014]: INFO: ' 'eth0' has IP: '
      Apr 22 15:31:26 NAS logger: autoshutdown[3014]: WARN: ' Invalid parameter format: Class: nnn.nnn.nnn]'
      Apr 22 15:31:26 NAS logger: autoshutdown[3014]: WARN: ' It is set to '', which is not a correct syntax. Maybe parsing 'ifconfig ' did something wrong'
      Apr 22 15:31:26 NAS logger: autoshutdown[3014]: WARN: ' Please report this Bug and the CLI-output of 'ifconfig''
      Apr 22 15:31:26 NAS logger: autoshutdown[3014]: WARN: ' unsetting NIC[2]: eth0 ...'
      Apr 22 15:31:26 NAS logger: autoshutdown[3014]: WARN: ' Invalid parameter format: SERVERIP [iii]'
      Apr 22 15:31:26 NAS logger: autoshutdown[3014]: WARN: ' It is set to '', which is not a correct syntax. Maybe parsing 'ifconfig' did something wrong'
      Apr 22 15:31:26 NAS logger: autoshutdown[3014]: WARN: ' Please report this Bug and the CLI-output of 'ifconfig''
      Apr 22 15:31:26 NAS logger: autoshutdown[3014]: WARN: ' unsetting NIC[2]: ...'
      Apr 22 15:31:26 NAS logger: autoshutdown[3014]: INFO: ' NIC 'eth1' not found, skipping 'eth1''
      Apr 22 15:31:26 NAS logger: autoshutdown[3014]: WARN: ' No SERVERIP or CLASS found'
      Apr 22 15:31:26 NAS logger: autoshutdown[3014]: WARN: ' exiting ...'
    • First time no one responded? Why didn't you just bump the thread instead of creating a new one?

      The output say to report the output of ifconfig. Can you post that? I am guessing you have a non-standard network configuration.
      omv 5.0.14 usul | 64 bit | 5.0 proxmox kernel | omvextrasorg 5.1.5
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • root@NAS:~# ifconfig
      as0t0 Link encap:Ethernet HWaddr fe:ff:ff:65:1f:00
      UP BROADCAST RUNNING PROMISC MULTICAST MTU:1500 Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:1234 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:200
      RX bytes:0 (0.0 B) TX bytes:180842 (176.6 KiB)

      asbr0 Link encap:Ethernet HWaddr d8:cb:8a:9d:5e:7e
      inet addr:192.168.1.2 Bcast:192.168.1.255 Mask:255.255.255.0
      UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
      RX packets:37095 errors:0 dropped:0 overruns:0 frame:0
      TX packets:83887 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0
      RX bytes:3088707 (2.9 MiB) TX bytes:120812832 (115.2 MiB)

      eth0 Link encap:Ethernet HWaddr d8:cb:8a:9d:5e:7e
      UP BROADCAST RUNNING PROMISC MULTICAST MTU:1500 Metric:1
      RX packets:38212 errors:0 dropped:0 overruns:0 frame:0
      TX packets:83889 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000
      RX bytes:3987869 (3.8 MiB) TX bytes:120812932 (115.2 MiB)
      Interrupt:40 Base address:0xc000

      lo Link encap:Local Loopback
      inet addr:127.0.0.1 Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING MTU:16436 Metric:1
      RX packets:143 errors:0 dropped:0 overruns:0 frame:0
      TX packets:143 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0
      RX bytes:22652 (22.1 KiB) TX bytes:22652 (22.1 KiB)
    • Are you configuring the network settings from the OMV web interface? Did you change something with the network settings that may have caused autoshutdown not to work?
      omv 5.0.14 usul | 64 bit | 5.0 proxmox kernel | omvextrasorg 5.1.5
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Well, the problem is that as0t0 doesn't have an IP. What is the output of: omv-showkey autoshutdown
      omv 5.0.14 usul | 64 bit | 5.0 proxmox kernel | omvextrasorg 5.1.5
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • root@NAS:~# omv-showkey autoshutdown
      <autoshutdown>
      <enable>1</enable>
      <cycles>3</cycles>
      <sleep>30</sleep>
      <range>3..63</range>
      <shutdowncommand>0</shutdowncommand>
      <checkclockactive>0</checkclockactive>
      <uphours-begin>6</uphours-begin>
      <uphours-end>20</uphours-end>
      <nsocketnumbers>21,22,80,139,445,3689,6991,9091,49152</nsocketnumbers>
      <uldlcheck>0</uldlcheck>
      <uldlrate>50</uldlrate>
      <loadaveragecheck>0</loadaveragecheck>
      <loadaverage>40</loadaverage>
      <hddiocheck>0</hddiocheck>
      <hddiorate>401</hddiorate>
      <syslog>1</syslog>
      <verbose>0</verbose>
      <fake>0</fake>
      <extraoptions></extraoptions>
      </autoshutdown>
    • All I can think to try is different network settings including giving as0t0 an ip address.
      omv 5.0.14 usul | 64 bit | 5.0 proxmox kernel | omvextrasorg 5.1.5
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • I don't know if it needs an address or not. I was just suggesting that. I don't use autoshutdown so I'm not sure. I wouldn't assign a second NIC the same IP address as the first. Just make one up.
      omv 5.0.14 usul | 64 bit | 5.0 proxmox kernel | omvextrasorg 5.1.5
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • According to code, FORCE_NIC="eth0" should work IF eth0 has a line starting with inet. In your original ifconfig output, eth0 does not have an IP or inet line. Either fix that or put FORCE_NIC="asbr0"
      omv 5.0.14 usul | 64 bit | 5.0 proxmox kernel | omvextrasorg 5.1.5
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Help me please. I have same problem - plugin not working.
      I need OMV4 power off if 192.168.0.1 not pinging after 5 sec and 3 retries.

      Fake mode activated.
      Ifconfig:

      Source Code

      1. root@nas:~# ifconfig
      2. docker0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
      3. inet 172.17.0.1 netmask 255.255.0.0 broadcast 172.17.255.255
      4. ether 02:42:0e:31:9d:83 txqueuelen 0 (Ethernet)
      5. RX packets 0 bytes 0 (0.0 B)
      6. RX errors 0 dropped 0 overruns 0 frame 0
      7. TX packets 0 bytes 0 (0.0 B)
      8. TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
      9. enx001e06364e81: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
      10. inet 192.168.0.7 netmask 255.255.255.0 broadcast 192.168.0.255
      11. inet6 fe80::5964:2255:210e:d2a8 prefixlen 64 scopeid 0x20<link>
      12. ether 00:1e:06:36:4e:81 txqueuelen 1000 (Ethernet)
      13. RX packets 3394191 bytes 261085383 (248.9 MiB)
      14. RX errors 0 dropped 0 overruns 0 frame 0
      15. TX packets 9322290 bytes 4176661485 (3.8 GiB)
      16. TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
      17. lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
      18. inet 127.0.0.1 netmask 255.0.0.0
      19. inet6 ::1 prefixlen 128 scopeid 0x10<host>
      20. loop txqueuelen 1000 (Local Loopback)
      21. RX packets 28621 bytes 3205866 (3.0 MiB)
      22. RX errors 0 dropped 0 overruns 0 frame 0
      23. TX packets 28621 bytes 3205866 (3.0 MiB)
      24. TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
      Display All
      FORCE_NIC="enx001e06364e81" not helped (192.168.0.7 is a real ip)
      log seems to be useless:

      The post was edited 4 times, last by Nuke ().