Unknown filesystem type 'zfs'

    • OMV 3.x
    • Unknown filesystem type 'zfs'

      Hello everyone. I am new to linux and OMV. I have been learning a little at a time in Linux but it has been slow. In my search for a solid diy NAS system I foud OMV. I have been running this NAS system problem free for about 8 months. Recently I had tried to access my SMB shares via windows and they could not be found. When I signed into OMV webGUI, i saw that it was not mounted. when trying to mount it via webGUI, this is the error that I got:

      Error #6000:exception 'OMVException' with message 'Failed to mount 'f9334705-f9f9-4ba0-bc8c-67b06b276ec2': mount: unknown filesystem type 'xfs'' in /usr/share/openmediavault/engined/rpc/filesystemmgmt.inc:921
      Stack trace:
      #0 [internal function]: OMVRpcServiceFileSystemMgmt->mount(Array, Array)
      #1 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      #2 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('mount', Array, Array)
      #3 /usr/sbin/omv-engined(494): OMVRpc::exec('FileSystemMgmt', 'mount', Array, Array, 1)
      #4 {main}

      I've tried rebooting with no success. I don't know many commands and searching did not resolve anything useful to me. I do have physical access to the machine and can enter commands right at the terminal.

      My system has 4 WD Red drives 3TB each in RAID6. In the RAID Management tab, it shows State: Clean /dev/md0 Capacity 5.46TiB.
      OMV Version is 3.0.2 (Erasmus). I'm not 100% sure if this was automatically updated and I'm unsure of the previous version I used to install this.

      Let me know what other information I can provide and how to go about retrieving it and I will get it posted as soon as I can. Thank you all so much in advance for any help you can provide.

    • Enable ssh and login via putty so you can copy & paste the output of the following commands:

      cat /proc/mdstat
      fdisk -l
      cat /etc/fstab
      omv 4.1.22 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • When I try to enable SSH via WebGUI and I get this error:

      Failed to execute command 'export LANG=C; systemctl stop avahi-daemon 2>&1': Failed to stop avahi-daemon.service: Unit avahi-daemon.service not loaded.
      Error #4000:exception 'OMVException' with message 'Failed to execute command 'export LANG=C; systemctl stop avahi-daemon 2>&1': Failed to stop avahi-daemon.service: Unit avahi-daemon.service not loaded.' in /usr/share/php/openmediavault/systemctl.inc:64Stack trace:#0 /usr/share/php/openmediavault/systemctl.inc(128): OMVSystemCtl->exec('stop')#1 /usr/share/openmediavault/engined/module/zeroconf.inc(56): OMVSystemCtl->stop()#2 /usr/share/openmediavault/engined/rpc/config.inc(164): OMVModuleZeroconf->stopService()#3 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)#4 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)#5 /usr/share/php/openmediavault/rpcservice.inc(158): OMVRpcServiceAbstract->callMethod('applyChanges', Array, Array)#6 /usr/share/openmediavault/engined/rpc/config.inc(224): OMVRpcServiceAbstract->callMethodBg('applyChanges', Array, Array)#7 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)#8 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)#9 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('applyChangesBg', Array, Array)#10 /usr/sbin/omv-engined(494): OMVRpc::exec('Config', 'applyChangesBg', Array, Array, 1)#11 {main}

      So I tried sudo service avahi-daemon start. I get this:

      Failed to start avahi-daemon.service: Unit avahi-daemon.service failed to load: Invalid argument. See system logs and 'systemctl status avahi-daemon.socet' for details.

      I can take high resolution pictures of the screen if that helps with the commands you gave me? Thanks!
    • Since nothing else seems to work and I wasn't getting much help from the interwebs, I tried something to see if it would work and it has. I decided to reinstall OMV on a new USB drive to maintain the existing copy on the original USB drive. Doing so without a network connection I was able to remount the RAID6 partition. All files are intact. Thanks for your help.