Admin Password Rejected

    • Admin Password Rejected

      Hi,

      Been working on a migration from my Ubuntu Server to OMV but all of a sudden I can't login into the webGui. My admin password keeps being rejected and when I try to change the admin password thru omv-firstaid I get the strange feeling that this is not implemented because the other options withing omv-firstaid make a statement "please wait"...anyway It (omv-firstaid) won't work.

      Only thing I was doing was trying to install owncloud. That should not be given this problems right?

      This is really really horrible and hope that there are other possibilities to change the admin password. And furthermore: how can this happen?

      Thanks in advance (and all my data with me).
    • Re: Admin Password Rejected

      Start a Putty root sesstion:

      cd /home

      Source Code

      1. wget http://prdownloads.sourceforge.net/webadmin/webmin_1.620_all.deb

      dpkg --install webmin_1.620_all.deb
      apt-get -f install
      rm webmin_1.620_all.deb

      Then login to webmin at: ipofyouromv.com:10000 (ip or your omv e.g. 192.168.1.125)

      sign in with root and root password
      go to /system /changepasswords in gui
      on right window click on the admin user
      enter new password and click on change
    • Re: Admin Password Rejected

      Thanks!

      Around 9.14PM I had the same idea (have webmin also on the ubuntu server) but slipped immediately my mind when Real scored. Then took the approach what I was doing wrong and forgot about this solution.

      Needing Webmin to get rid of Webmin...how dubious can that be.
    • Re: Admin Password Rejected

      Well, I think it can be an issue that omv-firstaid doesn't work.

      I can make my way around Linux (nowhere near the specialists which I usually work with) but this is basic 'trying to login' which got me thinking I must be doing so wrong. I appreciate your instruction nevertheless.

      I'll look into it tonight straightaway.
    • Re: Admin Password Rejected

      Ok, I'm now getting annoyed.

      I initially could not reset the password but noticed error messages the disk was full (had a 2GB vm) so I made a new install (yeah for virtualization), now 5GB as OS disk and everything installed fine yesterday but now again the account admin is locked out and even resetting the password with webmin doesn't work (although it says it was succesfully).

      When i log in with ssh I see again error messages from mysql the partition is full and there's only 80MB left from the 4.3GB!! I additionally installed plex, subsonic, sabnzbd but that does not take this sort of GB's on my ubuntu server.

      Does anybody have a hint where/what to look for? I will try to remove mysql and see if that helps but any help is very appreciated.
    • Re: Admin Password Rejected

      removing mysql released 55MB but that also crashed the omv-firstaid. Resetting the password is a no go. Luckily the ubuntu server is still going strong but would really like to see what could be the cause.

      My test-omv by the way is still up and running and the major difference is the lack of lvm managed disks. Can this eat up my OS disk?
    • Re: Admin Password Rejected

      Hi,

      Sorry that took a whole 5 minutes to figure out who the guy named "Minus Miller" then is and where his script would be :lol:

      Anyway: Got a new vm, enabled ssh and attached the virtual disks as 1 Volume Group and mounted the Logical Volume. OS Disk is now 4000 out of 4782 available. Now watch some speedskating and see what happens.

      Oh: Not using the jhmiller script voor sabnzbd and rest..
    • Re: Admin Password Rejected

      Ok one day further away and got awaken with a kernel panic: Out of memory for breakfast.

      Because everything went smooth yesterday for several hours and thought it could'nt harm to enable forked-daapd plugin and install Plex. Forked-daapd isn't the problem but from the moment of adding a movie section in Plex my memory kept lowering until 3:30AM my system crashed. FYI: I have around 650 movies so not that big if you read replies from UE users (Unraid Evangelists).

      I rebooted the machine and was able to login (password is still standard) and there is now 700MB os disk space left from the 5GB deployed. For the moment I added the user Plex R/W to the ACL and see what that does but that is not in the tutorial from tekkbebe.

      Keep you posted.
    • Re: Admin Password Rejected

      If you use DLNA from plex you will not have low virtual memory issues. These problems arise from transcoding. So if you are using a plex client this is where you are likely to run into these issues. I'm still trying to sort out some issues running plex on virtual machine. Plex caches when transcoding to the /tmp folder and you can delete anything with plex in the name there. No one has reported the memory issues with a real machine. I've only seen in my vm experience.
    • Re: Admin Password Rejected

      Hi,

      I got a couple of little kids who know their way around the plex clients so I think you're in the right direction. Only thing for now is give you some more info
      - debian kernel is standard (2.36...)
      - vm disk is a SSD
      - vmware 5.1 ESXi

      Is it helpfull for you if I deploy a new vm with new backports kernel or is that lost effort?
    • Re: Admin Password Rejected

      Well, plex was used this morning (thanks to a little boy who was awake way too early according to his parents) and didn't have any negative effect on the vm so things look better now.

      I still want to test if:
      - swapoff works in a new vm and a freshly installed plex (what happens when add movie section)
      - change the initial password and see if that keeps working.

      Last one will try tonight and first one start setting up before moving the virtual disks to the new vm tomorrow night.