Failed to create a file system on a USB drive when installing.

    • Resolved
    • OMV 3.x
    • Failed to create a file system on a USB drive when installing.

      Hi all.

      Finally got around to installing V3 on my HP NL40. (Well the Windows boot drive died so...) I have played with OMV in VM's so I have installed before. Anyway. It is failing to install to a USB stick. I have tried 2 of them (both 8gig) I can install to a hard drive just fine but do not want to lose a slot for just a boot disk.

      So when partitioning I get

      Failed to create a file system.
      The ext4 file system creation in partition #1 of SCSI1 (0,0,0) (sdb) failed <---- this is being typed from memory as the machine is off now.

      Continue/go back, always the same result.

      Like I said it will install to a hard drive.

      Any ideas?

    • Try wiping the stick with dd on a linux machine (boot livecd if you don't have one)
      dd if=/dev/zero of=/dev/sdX bs=512 count=10000 && sync
      substitute the sdX with your usb location

      If that doesn't work, try installing with an OMV image on a usb cd-rom -OR- on a different machine and moving the usb stick back to the N40L -OR- try installing Debian Jessie first and OMV on top of that.
      omv 5.1.0 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.1.5 plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      Try wiping the stick with dd on a linux machine

      I was thinking, I know how to do that on a Windows machine. So as they say a picture is worth a thousand words.
      See attachments.

      In a nut shell... You use Diskpart from the command line.

      1. Open a command prompt in Admin mode
      2. Type "diskpart"
      3. Type "list disk"
      4. Select the correct USB disk (see attachments) the command is "select disk x" with x being the disk number.
      5. Type "list disk" to VERIFY you have selected the correct disk (you will see * by the selected disk)
      6. Type "clean"
      7. Type "exit" to exit out of the diskpart program.

      After that install went perfect.

      Thanks everyone!
      • diskpart1.png

        74.97 kB, 744×497, viewed 1,144 times
      • diskpart2.png

        62.25 kB, 734×414, viewed 888 times
    • Hi,
      I got the same error, while trying to install on a external usb drive with a FAT partition on it.
      I wiped it with partition mini tool under windows (/ just deleted all partitions) and then it worked.
      (Ok, you could also use the cmd or the admistrative tools, but I had the mini tool already installed.)

      Quite strange, that I couldn't find this thread earlier, I just tried everything else, until I found the solution myself.
      The only thread I found was [SOLVED] "Failed to create a file system" which is too old and didn't work.
      Now I wanted to create a new thread with the title "file system creation failed" and the forum recommended me this thread ...
      Maybe you could add this hint into the installer for this error message.

      And as everything else is working now: Big thanks for this distribution ;)
    • Users Online 1

      1 Guest