wlan0 not detected after apt-get upgrade on RPi 3

    • OMV 3.x
    • Resolved
    • Update
    • Wolf2000 wrote:

      See too :
      linuxundich.de/raspberry-pi/dr…aspberry-pi-einzurichten/
      sorry in german
      I didn't need that to get mine to work.
      omv 5.0.14 usul | 64 bit | 5.0 proxmox kernel | omvextrasorg 5.1.4
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Just completed an apt-get update & upgrade. Rebooted and apt-get update does now list the 4 fw packages that i think caused an issue with my wlan0 interface - see below.

      I'm not going to install these right now but could do if it helps with testing/resolving the issue.

      Do you think it could have been a failed/corrupted install that screwed my setup earlier today?

    • jata1 wrote:

      I'm not going to install these right now but could do if it helps with testing/resolving the issue.
      I would install them. I think these packages were added later. I installed them.

      jata1 wrote:

      Do you think it could have been a failed/corrupted install that screwed my setup earlier today?
      No. I think it was bad timing or you didn't click Check to see that all updates were available. Wireless on OMV isn't very well tested either because not many use it.
      omv 5.0.14 usul | 64 bit | 5.0 proxmox kernel | omvextrasorg 5.1.4
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • i just checked to see which repos are enabled in the GUI and noticed that debian backports was not enabled. I checked as i looked at the fw packages and they were all from debian backports. Why are they showing up to install if i don't have back port repo enabled?

      So I enabled the debian backports repo, did an apt clean from the GUI and checked for updates in the update management part of GUI. This came back with an error - but no error message (maybe a timeout)?

      Then i did an apt-get update from the CLI and this came back with an error with the public key - see below.

      Do you think this could be related to the issue I have?

      Should I resolve this error before installing any of the fw packages?

      (thanks for the help and sorry for all the questions)

      W: GPG error: httpredir.debian.org jessie-backports InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 8B48AD6246925553 NO_PUBKEY 7638D0442B90D010
    • jata1 wrote:

      Why are they showing up to install if i don't have back port repo enabled?
      The backports repo is enabled by default starting with OMV 3.0.59.

      jata1 wrote:

      Do you think this could be related to the issue I have?
      Nope.

      jata1 wrote:

      Should I resolve this error before installing any of the fw packages?
      Try updating with omv-update from the command line.

      I am creating a new image right now that should solve the problem.
      omv 5.0.14 usul | 64 bit | 5.0 proxmox kernel | omvextrasorg 5.1.4
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Looks like the backports firmware package doesn't include the RPi3 wifi firmware. The following commands should fix it:

      wget https://github.com/RPi-Distro/firmware-nonfree/raw/master/brcm80211/brcm/brcmfmac43430-sdio.bin
      wget https://github.com/RPi-Distro/firmware-nonfree/raw/master/brcm80211/brcm/brcmfmac43430-sdio.txt
      mv brcmfmac43430-sdio* /lib/firmware/brcm/
      omv 5.0.14 usul | 64 bit | 5.0 proxmox kernel | omvextrasorg 5.1.4
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • @ryecoaaron - thanks a million. changing the driver files for brcmfmac43430 fixed the issue on both my test and production OMV servers. I now have wlan0 back.

      One last thing... How can I fix the the public key signature error that I have when I do apt-get update?

      The error message is

      W: GPG error: httpredir.debian.org jessie-backports InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 8B48AD6246925553
    • jata1 wrote:

      How can I fix the the public key signature error that I have when I do apt-get update?
      apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 8B48AD6246925553
      omv 5.0.14 usul | 64 bit | 5.0 proxmox kernel | omvextrasorg 5.1.4
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 7638D0442B90D010

      I just uploaded a new 3.0.59 image to sourceforge that has no key issues and wireless is working.
      omv 5.0.14 usul | 64 bit | 5.0 proxmox kernel | omvextrasorg 5.1.4
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!