Docker Won't Start

    • OMV 3.x
    • Resolved
    • Docker Won't Start

      I/m running OMV v 3.059 and I had an issue connecting to my Plex docker this AM so I took the opportunity to shutdown and replace my power strip and when I rebooted Docker won't start at all and all settings are cleared from the Docker GUI. The error presented is pasted below. I appreciate if anyone can help!

      Error #0:exception 'OMV\ExecException' with message 'Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; docker images 2>&1' with exit code '1': Cannot connect to the Docker daemon. Is the docker daemon running on this host?' in /usr/share/php/openmediavault/system/process.inc:175Stack trace:#0 /usr/share/openmediavault/engined/rpc/docker.inc(1336): OMV\System\Process->execute(Array)#1 [internal function]: OMVRpcServiceDocker->getDockerRepo(Array, Array)#2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)#3 /usr/share/php/openmediavault/rpc/rpc.inc(84): OMV\Rpc\ServiceAbstract->callMethod('getDockerRepo', Array, Array)#4 /usr/sbin/omv-engined(516): OMV\Rpc\Rpc::call('Docker', 'getDockerRepo', Array, Array, 1)#5 {main}
    • I'm having the same issue. I had docker up and running for a while on a test system, and finally got around to setting up my storage drives and wanted to move the docker home to a shared folder. But ran into this error when trying to change the location. Removed everything, docker plugin, gui, omv-extras, etc. rebooted system, and tried to re-setup but running in to same issues

      Source Code

      1. Error #0:
      2. exception 'OMV\ExecException' with message 'Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl start docker 2>&1' with exit code '1': Job for docker.service failed. See 'systemctl status docker.service' and 'journalctl -xn' for details.' in /usr/share/php/openmediavault/system/process.inc:175
      3. Stack trace:
      4. #0 /usr/share/php/openmediavault/system/systemctl.inc(86): OMV\System\Process->execute(Array, 1)
      5. #1 /usr/share/php/openmediavault/system/systemctl.inc(146): OMV\System\SystemCtl->exec('start', NULL, false)
      6. #2 /usr/share/omvdocker/Utils.php(108): OMV\System\SystemCtl->start()
      7. #3 /usr/share/omvdocker/Utils.php(556): OMVModuleDockerUtil::startDockerService()
      8. #4 /usr/share/openmediavault/engined/rpc/docker.inc(1028): OMVModuleDockerUtil::changeDockerSettings(Array, 42005, '/srv/98eb8de6-4...')
      9. #5 [internal function]: OMVRpcServiceDocker->setSettings(Array, Array)
      10. #6 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)
      11. #7 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('setSettings', Array, Array)
      12. #8 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Docker', 'setSettings', Array, Array, 1)
      13. #9 {main}
      14. OK
      15. Show details
      Display All

      It seems the only way forward from this is to wipe out OMV and start completely over...

      edit: what is even funnier, and kind of ironic, is every time I post to the forums I get an error (but my post will show when I go to to forums).

      Source Code

      1. The server encountered an unresolvable problem, please try again later.
      2. Exception ID: 0b1660bd9d49a960fe47037261b2b1365dc8ff25
      U-NAS NSC-800, Supermicro X10SDV-F-O, Xeon D 1540 (45W), 64GB EEC DDR4, LSI 9211-8i, Samsung XP941 M.2 SSD, ESXi 6.5
    • luxferro wrote:

      I'm having the same issue. I had docker up and running for a while on a test system, and finally got around to setting up my storage drives and wanted to move the docker home to a shared folder. But ran into this error when trying to change the location. Removed everything, docker plugin, gui, omv-extras, etc. rebooted system, and tried to re-setup but running in to same issues

      Source Code

      1. Error #0:
      2. exception 'OMV\ExecException' with message 'Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl start docker 2>&1' with exit code '1': Job for docker.service failed. See 'systemctl status docker.service' and 'journalctl -xn' for details.' in /usr/share/php/openmediavault/system/process.inc:175
      3. Stack trace:
      4. #0 /usr/share/php/openmediavault/system/systemctl.inc(86): OMV\System\Process->execute(Array, 1)
      5. #1 /usr/share/php/openmediavault/system/systemctl.inc(146): OMV\System\SystemCtl->exec('start', NULL, false)
      6. #2 /usr/share/omvdocker/Utils.php(108): OMV\System\SystemCtl->start()
      7. #3 /usr/share/omvdocker/Utils.php(556): OMVModuleDockerUtil::startDockerService()
      8. #4 /usr/share/openmediavault/engined/rpc/docker.inc(1028): OMVModuleDockerUtil::changeDockerSettings(Array, 42005, '/srv/98eb8de6-4...')
      9. #5 [internal function]: OMVRpcServiceDocker->setSettings(Array, Array)
      10. #6 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)
      11. #7 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('setSettings', Array, Array)
      12. #8 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Docker', 'setSettings', Array, Array, 1)
      13. #9 {main}
      14. OK
      15. Show details
      Display All
      It seems the only way forward from this is to wipe out OMV and start completely over...

      edit: what is even funnier, and kind of ironic, is every time I post to the forums I get an error (but my post will show when I go to to forums).

      Source Code

      1. The server encountered an unresolvable problem, please try again later.
      2. Exception ID: 0b1660bd9d49a960fe47037261b2b1365dc8ff25
      ive wiped 4 times and i still get the error with docker
    • I encountered this too. Then I ssh to my OMV and check the docker status. Turned out it wasn't running.

      Source Code

      1. root@fourteenc:~# systemctl status docker
      2. ● docker.service - Docker Application Container Engine
      3. Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: e
      4. Drop-In: /etc/systemd/system/docker.service.d
      5. └─openmediavault.conf
      6. Active: failed (Result: exit-code) since Thu 2018-12-13 19:50:58 +08; 4min 58
      7. Docs: https://docs.docker.com
      8. Main PID: 20186 (code=exited, status=1/FAILURE)
      9. CPU: 0
      10. Dec 13 19:50:56 fourteenc systemd[1]: docker.service: Main process exited, code=
      11. Dec 13 19:50:56 fourteenc systemd[1]: Failed to start Docker Application Contain
      12. Dec 13 19:50:56 fourteenc systemd[1]: docker.service: Unit entered failed state.
      13. Dec 13 19:50:56 fourteenc systemd[1]: docker.service: Failed with result 'exit-c
      14. Dec 13 19:50:58 fourteenc systemd[1]: docker.service: Service hold-off time over
      15. Dec 13 19:50:58 fourteenc systemd[1]: Stopped Docker Application Container Engin
      16. Dec 13 19:50:58 fourteenc systemd[1]: docker.service: Start request repeated too
      17. Dec 13 19:50:58 fourteenc systemd[1]: Failed to start Docker Application Contain
      18. Dec 13 19:50:58 fourteenc systemd[1]: docker.service: Unit entered failed state.
      19. Dec 13 19:50:58 fourteenc systemd[1]: docker.service: Failed with result 'exit-c
      20. lines 1-19/19 (END)...skipping...
      21. ● docker.service - Docker Application Container Engine
      22. Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
      23. Drop-In: /etc/systemd/system/docker.service.d
      24. └─openmediavault.conf
      25. Active: failed (Result: exit-code) since Thu 2018-12-13 19:50:58 +08; 4min 58s ago
      26. Docs: https://docs.docker.com
      27. Main PID: 20186 (code=exited, status=1/FAILURE)
      28. CPU: 0
      29. Dec 13 19:50:56 fourteenc systemd[1]: docker.service: Main process exited, code=exited, status=1/FAILURE
      30. Dec 13 19:50:56 fourteenc systemd[1]: Failed to start Docker Application Container Engine.
      31. Dec 13 19:50:56 fourteenc systemd[1]: docker.service: Unit entered failed state.
      32. Dec 13 19:50:56 fourteenc systemd[1]: docker.service: Failed with result 'exit-code'.
      33. Dec 13 19:50:58 fourteenc systemd[1]: docker.service: Service hold-off time over, scheduling restart.
      34. Dec 13 19:50:58 fourteenc systemd[1]: Stopped Docker Application Container Engine.
      35. Dec 13 19:50:58 fourteenc systemd[1]: docker.service: Start request repeated too quickly.
      36. Dec 13 19:50:58 fourteenc systemd[1]: Failed to start Docker Application Container Engine.
      37. Dec 13 19:50:58 fourteenc systemd[1]: docker.service: Unit entered failed state.
      38. Dec 13 19:50:58 fourteenc systemd[1]: docker.service: Failed with result 'exit-code'.
      Display All

      Then I start the docker and it's working:

      Source Code

      1. root@fourteenc:~# systemctl start docker
      2. root@fourteenc:~# systemctl status docker
      3. ● docker.service - Docker Application Container Engine
      4. Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
      5. Drop-In: /etc/systemd/system/docker.service.d
      6. └─openmediavault.conf
      7. Active: active (running) since Thu 2018-12-13 19:56:09 +08; 811ms ago
      8. Docs: https://docs.docker.com
      9. Main PID: 25795 (dockerd)
      10. Tasks: 10
      11. Memory: 33.5M
      12. CPU: 357ms
      13. CGroup: /system.slice/docker.service
      14. └─25795 /usr/bin/dockerd -H unix:///var/run/docker.sock
      15. Dec 13 19:56:08 fourteenc dockerd[25795]: time="2018-12-13T19:56:08.530623165+08:00" level=warning msg="Your kernel does not support swap memory limit"
      16. Dec 13 19:56:08 fourteenc dockerd[25795]: time="2018-12-13T19:56:08.530700798+08:00" level=warning msg="Your kernel does not support cgroup rt period"
      17. Dec 13 19:56:08 fourteenc dockerd[25795]: time="2018-12-13T19:56:08.530720913+08:00" level=warning msg="Your kernel does not support cgroup rt runtime"
      18. Dec 13 19:56:08 fourteenc dockerd[25795]: time="2018-12-13T19:56:08.531486238+08:00" level=info msg="Loading containers: start."
      19. Dec 13 19:56:08 fourteenc dockerd[25795]: time="2018-12-13T19:56:08.585290784+08:00" level=info msg="Default bridge (docker0) is assigned with an IP address 172.17.0.0/16. Daemon option --bip can be used to set a preferred IP address"
      20. Dec 13 19:56:08 fourteenc dockerd[25795]: time="2018-12-13T19:56:08.808361616+08:00" level=info msg="Loading containers: done."
      21. Dec 13 19:56:09 fourteenc dockerd[25795]: time="2018-12-13T19:56:09.111976793+08:00" level=info msg="Docker daemon" commit=4d60db4 graphdriver(s)=overlay2 version=18.09.0
      22. Dec 13 19:56:09 fourteenc dockerd[25795]: time="2018-12-13T19:56:09.112317816+08:00" level=info msg="Daemon has completed initialization"
      23. Dec 13 19:56:09 fourteenc dockerd[25795]: time="2018-12-13T19:56:09.563268888+08:00" level=info msg="API listen on /var/run/docker.sock"
      24. Dec 13 19:56:09 fourteenc systemd[1]: Started Docker Application Container Engine.
      25. root@fourteenc:~# systemctl enable docker
      Display All
      Hope it helps!