phpVirtualbox console not working - blank

    • OMV 3.x
    • unfortunately not :

      Source Code

      1. root@backup-nas:~# date
      2. Wed 24 May 15:52:13 CEST 2017
      3. root@backup-nas:~# service vboxweb-service status
      4. ● vboxweb-service.service
      5. Loaded: not-found (Reason: No such file or directory)
      6. Active: inactive (dead)
      7. root@backup-nas:~# service vboxweb-service start
      8. Failed to start vboxweb-service.service: Unit vboxweb-service.service failed to load: No such file or directory.
      9. root@backup-nas:~#
    • since Virtualbox is functioning, except for the Console, I guess I'd better leave it alone.

      One quirk that might hold some clue :
      the VM directory is /srv/dev-disk-by-id-md-name-nas-softraid/VM
      The virtual machines are stored in /srv/dev-disk-by-id-md-name-nas-softraid/VM/virtual_machines
      This directory is a symlink to /VM on the OS drive because SSD.

      Could this be causing the issue as per OP ??
    • You can also try this,
      worked for me after fresh install of OMV 4
      Keep in mind that it will remove VNC, but RDP and console is working perfectly after installing this.
      Check Vbox version upfront, newest from OMV Extra repo is Vitualbox 5.2.24:

      Upgrade Ext Pack:

      Source Code

      1. wget https://download.virtualbox.org/virtualbox/5.2.24/Oracle_VM_VirtualBox_Extension_Pack-5.2.24.vbox-extpack
      2. vboxmanage extpack install --replace /root/Oracle_VM_VirtualBox_Extension_Pack-5.2.24.vbox-extpack

      Remove VNC, use RDP instead:

      Source Code

      1. vboxmanage list extpacks
      2. vboxmanage extpack uninstall VNC
      3. vboxmanage extpack cleanup
      Maybe you can skip the update, but I didn`t try ^^