Plex exits immediately after starting service

    • OMV 3.x
    • Plex exits immediately after starting service

      I tried to install the plex plugin and had the web client open then when I tried to update the firewall rules for OMV the client no longer will run and the plex plugin service will not stay running.

      This is the ouput of the systemctl status:

      Source Code

      1. root@SERVER:~# systemctl status plexmediaserver.service
      2. ● plexmediaserver.service - LSB: Plex Media Server
      3. Loaded: loaded (/etc/init.d/plexmediaserver)
      4. Drop-In: /etc/systemd/system/plexmediaserver.service.d
      5. └─db_folder.conf
      6. Active: active (exited) since Mon 2017-08-07 23:30:51 UTC; 1h 46min ago
      7. Process: 19975 ExecStart=/etc/init.d/plexmediaserver start (code=exited, status=0/SUCCESS)
      8. Aug 07 23:30:50 SERVER su[19981]: Successful su for plex by root
      9. Aug 07 23:30:50 SERVER su[19981]: + ??? root:plex
      10. Aug 07 23:30:50 SERVER su[19981]: pam_unix(su:session): session opened for user plex by (uid=0)
      11. Aug 07 23:30:51 SERVER plexmediaserver[19975]: Starting Plex Media Server: done
      12. Aug 07 23:30:51 SERVER systemd[1]: Started LSB: Plex Media Server.
      Display All

      When I try to access the local web client the server refuses connection, even though port 32400 is accepting input (however it is not set in the firewall as output accept).

      I looked at process list and it also does not show plex running either.
      I used this command:

      Source Code

      1. root@SERVER:~# ps -e | grep plex
      2. root@SERVER:~#

      What could be causing the premature exit out of the plugin?