openmediavault-nut_3.2.12 won't install

    • OMV 3.x
    • Resolved
    • openmediavault-nut_3.2.12 won't install

      When I try to install the plugin on OMV 3.0.88 on armhf I get an error in the web interface.

      Debugging it (installing via console) I get:

      Setting up openmediavault-nut (3.2.12) ...
      Updating service units ...
      Restarting services ...
      Action failed -- There is no service by that name
      dpkg: error processing package openmediavault-nut (--configure):
      subprocess installed post-installation script returned error exit status 1
      Processing triggers for openmediavault (3.0.88) ...
      Restarting engine daemon ...
      Errors were encountered while processing:
      E: Sub-process /usr/bin/dpkg returned an error code (1)

      Then I installed nut-monitor that was not installed via apt.

      Dissecting the postins script of the plugin I found the culprit to be
      monit restart collectd

      The service with that name (collectd) is installed but I can not find it in /etc/monit/conf.d/ or /etc/monit/monitrc.d/ (try monit -v restart collectd)

      What should come in there? Are the install scripts for this package incomplete/outdated?
    • I smelled a solution reading this:
      Unable to make NUT plugin work (errors codes inside)

      And it worked!

      Oddly you need an already WORKING (=configured!) UPS to install the plugin and be able to configure your UPS in OMV.

      Installer beware: Your carefully worked out configuration gets overwritten.


      I have a Powerwalker VI 650
      (48 EUR, more than plenty keeping my ODROID HC1 with one 4TB drive powered for about 40+ minutes).
      This thing has a USB-HID interface:

      driver = usbhid-ups
      port = auto
      desc = "PowerWalker VI 650 SE"

      I do not know why, but the (already changed cable) connection is lost every 30 minutes or so.
      To work around this I set up a cron job:

      # every 25 minutes
      5-55/25 * * * * root /sbin/upsdrvctl start > /dev/null

      Then we have these annoying messages broadcasted.

      To work around this I edited upsmon.conf



      The post was edited 3 times, last by DHGE ().