OMV not detecting hard disk ODROID HC1

    • OMV 3.x
    • OMV not detecting hard disk ODROID HC1

      I configured an ODROID HC1 with the OMV image. The HC1 has an integrated SATA port for hard disks. However, the 500GB HDD I'm using wasn't detected by the operating system and therefore, OMV didn't recognize it either. I figured the problem might be related to the disk never being initialized. I used a USB sata dock with my Windows machine and formatted it as ExFAT. However, OMV still doesn't recognize it! Any ideas? I know the disk works because Windows was able to recognize, format, and copy and delete files.
    • @tkaiser Please request such infos via omv-sysinfo if possible, armbianmonitor is not shipped via OMV and is not available on all platforms, so it might confuse users that came across this post while searching for an issue.
      omv-sysinfo can be submitted via email and copied to USB device via omv-firstaid. Additionally it can be collected via the WebUI.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • votdev wrote:

      Unfortunately there's nothing included that could help. @The Machine most probably suffers from undervoltage (this ARM board here wants to be fed with 5V which is not a great idea since some HDD brands stop working when the voltage available to them is below 4.75V which is pretty likely when the PSU does not provide already +5.2V). The output from armbianmonitor could help since this is more or less few years of support experiences with single board computers distilled in two tools (a service called at startup and shutdown sending information to a log file and the armbianmonitor tool sending this with another few information bits to an online pasteboard service).

      At least last 200 dmesg lines and lsusb output would be needed for omv-sysinfo to help with the two problems we face with SBC: powering issues and SD card crappiness.
    • Thank you both (@votdev and @tkaiser) for your replies. I have done as requested. According to the HC1 Introduction video (), the included 5V 4a power supply should work for this purpose. I'm using a Hardkernel power supply. To cover the possibility of power fluctuation (perhaps a bad PSU), I tried a 5V 6A power supply -- still not detecting a HDD.
      The 32GB Micro SD Card is brand new.

      I ran the "sudo armbianmonitor -u" command and you can view the output here

      It's worth noting that I'm not using a standard 2.5" HDD. I'm using a Power Edge 2.5" HDD built for the Dell PowerEdge server series. The HDD is a few MM thicker than normal 2.5" HDD. I wonder if there are other differences. I could try a different HDD for the purpose of finding the cause of the problem.

      Thanks again ;)
    • The Machine wrote:
      According to dmesg and lsusb output the JMS578 USB-to-SATA bridge is not detected which is somewhat strange since it sits on the PCB and IIRC appears on the bus even without a SATA device attached (but my tests were all done with an early developer sample so I dont't know whether that's still true).

      You better open a thread on asking for advice since this is most likely a hardware issue (at least it's not an OMV issue and here no one is able to help). Please prepare this with another disk (ideally an SSD since they work even in undervoltage situations).
    • @tkaiser, I tried it with a standard SATA hard disk and it worked. It must be an issue with the variant hard disk I was using. Perhaps the Dell PowerEdge server Hard Disks require more power. Anyway, I tried it with two standard Hard Disks and both were detected. It seems to be a compatibility issue with the PowerEdge hard disks.
    • The Machine wrote:

      It seems to be a compatibility issue with the PowerEdge hard disks.

      Ah, that rings a bell. Dell doesn't do disks so that's most probably a 'branded' WD Raptor and those need unlike all consumer/laptop 2.5" HDD both 5V and 12V so can't work on the HC1 unless you figure out how to insert 12V on the unpopulated power header (Hardkernel has prepared the PCB already for use with 3.5" disks that need all 5V and 12V but I've no idea whether it's ready on HC1 or not)