Best backup strategy for shared disk data

    • OMV 3.x
    • Best backup strategy for shared disk data


      New and hapy openmedivault user, I have a 1Tb USB disk attached to Raspberry Pi 3 with OMV 3 but I’d like to create a backup copy on a different 1Tb disk.
      What’s the best solution?

      I was thinking of RSync server but, for what I understood, I can sync folder and not the entire disk, moreover I would have to set an interval for syncing.

      Turn the all thing into a RAID system seems, at the moment, out of my ability.

      Thanks for your help.
    • lucamoiana wrote:

      What’s the best solution?
      'Best' solutions either do not exist or aren't realizable...

      One possible solution would be attaching the backup disk to your slow RPi while replacing it with a better SBC and then following this here for example: Rsync two OMV machines but this is just an implementation of a 1:1 sync so it's almost as useless as RAID-1 and of course no backup. But if you take care that both OMV hosts are physically separated then this might be a better approach compared to a setup where two disks are sitting next to each other.

      Alternative approaches exist (use the forum search), eg. 'usb backup' plugin (I personally don't like backup tasks relying on manual/human intervention -- but that's most probably since I deal with data losses for a living ;) )
    • With rsnapshot-plugin you can create snapshots to the second NAS. One step better than RAID1.

      Backup to cloud would be another option. Backblaze B2 is supported by Duplicati for example. There is a plugin for Duplicati.
      Odroid HC2 - armbian - Seagate ST4000DM004 - OMV4.x
      Asrock Q1900DC-ITX - 16GB - 2x Seagate ST3000VN000 - Intenso SSD 120GB - OMV4.x
      :!: Backup - Solutions to common problems - OMV setup videos - OMV4 Documentation - user guide :!:
    • Houston we have a problem ...

      I tried to install usb backup pluign, got an error and, now I'm no longer able to access OMV.

      I tried

      empty browser cache
      sudo reboot

      with no luck.

      I can ssh into raspberry pi and I can see my NAS from OSX

      I know I should start a new thread, but maybe you guys can point me in the right direction ... OMV is getting frustrating