Eth0 lose after reboot

    • Eth0 lose after reboot

      Hello guys,

      After a reboot i lost my eth0.
      My ifconfig is :

      IfConfig wrote:

      lo Link encap:Boucle locale
      inet adr:127.0.0.1 Masque:255.0.0.0
      adr inet6: ::1/128 Scope:Hôte
      UP LOOPBACK RUNNING MTU:65536 Metric:1
      RX paquets:1669 errors:0 dropped:0 overruns:0 frame:0
      TX paquets:1669 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 lg file transmission:1
      RX bytes:626319 (611.6 KiB) TX bytes:626319 (611.6 KiB)

      My interfaces seems correct, after nano /etc/network/:

      interfaces wrote:

      # The loopback network interface
      auto lo
      iface lo inet loopback


      # eth0 network interface
      auto eth0
      allow-hotplug eth0
      iface eth0 inet static
      address 192.168.1.100
      gateway 192.168.1.1
      netmask 255.255.255.0
      dns-nameservers 8.8.8.8 8.8.4.4
      dns-search fr
      pre-down ethtool -s $IFACE wol g
      iface eth0 inet6 manual
      pre-down ip -6 addr flush dev $IFACE

      If I try : sudo dhclient eth0
      A new ip adress is allocated to eth0.
      I fix my ip with :
      - ifconfig eth0 down
      - ifconfig eth0 192.168.1.100 netmask 255.255.255.0 up

      But i lose it after reboot :cursing:

      How can I fix my configuration?

      I already had this problem and I had reinstalled as the guy here.
      No way this time ! X(

      Thx for your help.
    • I have this problem too...

      SPECS:

      OMV 3.0 running inside ESXi 6.5.0
      Pentium G4500
      12GB RAM

      After reboot, no connection at all (no GUI, no ping, no network, nothing, both in STATIC and DHCP).

      - /etc/network/interfaces show eth0 configured correctly;

      - ifconfig don't show eth0;

      - ifconfig eth0 up makes eth0 appear, but without IP (and connection).

      - omv-firstaid run as normal, but don't fix the problem

      ---WORKAROUND---

      - dhclient eth0 bring back eth0 WITH connection, but after reboot, it is gone.

      Havent found a permanent solution, and need help...

      [edit] My permanent solution was scheduling dhclient eth0 at reboot. Not elegant, but enough to wait for a permanent fix.

      [edit2] Fixed typos
    • tkaiser wrote:

      palandri wrote:

      /etc/network/interfaces show eth0 configured correctly
      But HOW does it look like (is there eth0 with 'auto' or 'allow-hotplug'?). Same with dmesg output...

      /etc/network/interfaces

      Source Code

      1. # The loopback network interface
      2. auto lo
      3. iface lo inet loopback
      4. # eth0 network interface
      5. auto eth0
      6. allow-hotplug eth0
      7. iface eth0 inet static
      8. address 192.168.0.5
      9. gateway 192.168.0.1
      10. netmask 255.255.255.0
      11. dns-nameservers 8.8.8.8
      12. iface eth0 inet6 manual
      13. pre-down ip -6 addr flush dev $IFACE
      Display All


      And in dmesg, the only thing that appears after the interface goes up is (nothing appears when releasing the dhcp lease)

      Source Code

      1. [25288.490108] vmxnet3 0000:13:00.0 eth0: intr type 3, mode 0, 3 vectors allocated
      2. [25288.490436] vmxnet3 0000:13:00.0 eth0: NIC Link is Up 10000 Mbps
      If you need something more precise, please ask.


      tkaiser wrote:

      (I really don't understand the 'OMV support situation' but that's a totally different topic)
      I did not understand... Could you please elaborate?
    • tkaiser wrote:

      FOcaL wrote:

      sudo dhclient eth0

      palandri wrote:

      nothing appears when releasing the dhcp lease
      Sorry, I don't get it. You both have static eth0 entries with allow-hotplug in the interfaces file but expect DHCP working?
      In my case, I DON'T expect DHPC to work. It is the only way to work.

      Even if I configure /etc/network/interfaces to use DHCP, it still don't work, only AFTER I run dhclient eth0.

      Just to be clear: Both DHCP and STATIC don't work after reboot (using the corresponding configuration in /etc/network/interfaces)

      ---------------

      I managed to get static IP working by configuring manually after reboot the IP address AND route:

      Source Code

      1. ifconfig eth0 "static-address"
      2. route add default gw "network-gateway"

      Current /etc/network/interfaces file:

      Source Code

      1. # The loopback network interface
      2. auto lo
      3. iface lo inet loopback
      4. iface lo inet6 loopback
      5. # eth0 network interface
      6. auto eth0
      7. iface eth0 inet static
      8. address 192.168.0.5
      9. gateway 192.168.0.1
      10. netmask 255.255.255.0
      11. dns-nameservers 8.8.8.8
      12. iface eth0 inet6 dhcp
      13. pre-up echo 1 > /proc/sys/net/ipv6/conf/$IFACE/accept_ra
      14. pre-up echo 0 > /proc/sys/net/ipv6/conf/$IFACE/disable_ipv6
      Display All
    • palandri wrote:

      Could you please elaborate?
      Sorry, just a small rant not targeted at you. I miss a support tool in OMV that collects more data since supporting remote systems you don't have access to when information is only sparse is always such a waste of time (speaking about another project I contribute to where users are asked to provide output from 'armbianmonitor -u' which will produce stuff like this where almost everything a supporter needs is included).

      I still have not the slightest idea what's going on. At least I would use either auto (with a statically configured address) or allow-hotplug (with DHCP) and if there's some external command needed to kick the interface somewhere then pre-up might help (eg. 'pre-up ifconfig $IFACE up')
    • tkaiser wrote:

      palandri wrote:

      Could you please elaborate?
      Sorry, just a small rant not targeted at you. I miss a support tool in OMV that collects more data since supporting remote systems you don't have access to when information is only sparse is always such a waste of time (speaking about another project I contribute to where users are asked to provide output from 'armbianmonitor -u' which will produce stuff like this where almost everything a supporter needs is included).
      I still have not the slightest idea what's going on. At least I would use either auto (with a statically configured address) or allow-hotplug (with DHCP) and if there's some external command needed to kick the interface somewhere then pre-up might help (eg. 'pre-up ifconfig $IFACE up')
      It's ok, and I agree with you. OMV lacks such support tool.

      At least, everything is working now. Not as supposed, but working indeed.

      Just for the record, the workaround is:

      - If you want OMV to work with DHCP, run dhclient "interface"

      - If you want OMV to work with static IP, run ifconfig "static-address" "interface" && route add default gw "gateway-address"

      The post was edited 1 time, last by palandri ().

    • So the stuff below does not work?

      Source Code

      1. # The loopback network interface
      2. auto lo
      3. iface lo inet loopback
      4. # eth0 network interface
      5. auto eth0
      6. iface eth0 inet static
      7. address 192.168.0.5
      8. gateway 192.168.0.1
      9. netmask 255.255.255.0
      10. dns-nameservers 8.8.8.8
      11. pre-up ifconfig $IFACE up
      12. iface eth0 inet6 manual
      13. pre-down ip -6 addr flush dev $IFACE
      Display All
    • tkaiser wrote:

      So the stuff below does not work?

      Source Code

      1. # The loopback network interface
      2. auto lo
      3. iface lo inet loopback
      4. # eth0 network interface
      5. auto eth0
      6. iface eth0 inet static
      7. address 192.168.0.5
      8. gateway 192.168.0.1
      9. netmask 255.255.255.0
      10. dns-nameservers 8.8.8.8
      11. pre-up ifconfig $IFACE up
      12. iface eth0 inet6 manual
      13. pre-down ip -6 addr flush dev $IFACE
      Display All
      Nope. Looks like OMV ignore completely /etc/network/interfaces
    • palandri wrote:

      Looks like OMV ignore completely /etc/network/interfaces
      OMV writes this file based on what you configure in the web UI (which ends up in an XML file that gets then parsed to write the interfaces file -- write-only behaviour). OMV of course ignores the contents of /etc/network/interfaces since reading this is Debian's job (ifupdown package is responsible for parsing it and the documentation can be found here)

      That being said the vast majority of users has obviously zero problems with this and as also aready said continuing without information (logs) unfortunately is useless. Since vmxnet3 driver suggest you run in a VM I would check network settings there too.