MDADM Error Messages

    • OMV 3.x
    • MDADM Error Messages

      I'm a Linux newbie, lLooking for help on OpenMediaVault install. Instructions recommend disconnecting all data drives, installing to a USB flash drive to boot from (boots completely to RAM), then reconnecting and formatting data drives. It installs perfectly to the flash drive, boots perfectly, no problems. However, ONLY after I reconnect the data drives do I start getting errors, an "MDADM no arrays found in config file or automatically" message. It is apparently related to a RAID system, but this system has never been configured for RAID, doesn't have a RAID set up, nothing like that. I've tried completely removing all existing partitions and reformatting the drives, nothing works, the same error message scrolls repeatedly on the screen. Could use assistance in diagnosing problem, maybe disabling the MDADM system via GRUB boot command? Have seen others online with same issue, but no solutions.
    • Assuming your OMV USB thumbdrive build was done form scratch:

      At times RAID, LVM, GPT, Root Kits and others, may write things to a drive's boot sector that are persistent. These settings may survive reformatting and may refuse attempts to repartition the drive.

      If you're experiencing something like this, try Darik's Boot and Nuke. --> DBAN will erase anything, and the first place it runs is on the boot sector. It will only take a few minutes to clean up the boot sector - there's no need to do a full pass. Afterward, you'll have a clean drive.

      **The only caution is, make sure you run it on the right disk(s).**
    • kaufmanj1973 wrote:

      an "MDADM no arrays found in config file or automatically" message. It is apparently related to a RAID system
      It's exactly the opposite. This message is telling you that there's no RAID involved AT ALL (neither exists a config nor are there RAID structures on your disks -- that's what the message is telling you).

      A different questions is why the message continually appears and this needs some investigation as @Sc0rp already explained.
    • I have never used OMV before. I am getting the mdadm error as well. Below are the steps I have gone through:

      At my work:
      1. I downloaded the 4.1.3 ISO and created a bootable USB flash drive
      2. I went through the installation
      3. Everything went perfect and smooth accept I couldn't get an IP address due to our network rules. I was able to log into OMV.

      At home:
      1. I still couldn't get an IP address so I reinstalled OMV
      2. Everything went perfect again UNTIL OMV tried to boot. All I get is:

      Source Code

      1. [ 0.827255] ERST: Can not request [mem 0xbf49403f-0xbf49603e] for ERST
      2. [ 6.364069] ata4.00: failed to set xfermode (err_mask=0x40)
      3. mdadm: No arrays found in config file or automatically
      4. The line above repeats 15-20 times...
      5. mdadm: error opening /dev/md?*: No such file or directory
      6. Same mdadm error repeats again 15-20 times...
      7. Gave up waiting for root file system device. Common problems:
      8. ...
      9. ALERT! /dev/sdb1 does not exist. Dropping to a shell!
      10. BusyBox v1.22.1 (Debian 1:1.22.0-19+b3) built-in shell (ash)
      11. Enter 'help' for a list of built-in commands.
      12. (initramfs)
      Display All
      I've done memory tests, wiped a reformatted SSD several times, and even rebuilt the bootable flash drive. It just will not boot. Does anyone have any idea what the problem is? Why would it work perfectly the first time and never again?
    • Well, OMV loaded and I have no idea how. Since my last post, I moved my ssd to SSD0 (even though it worked where it was connected before). I also tried several more times by moving the USB stick to every different port there is. Still didn't work. So this morning, I went in to the BIOS and was going to reinstall again. This time I put the USB first and the SSD second, saved and exited. But it decided to boot OMV instead of install.

      I have noticed that when I go into the boot priority, I see UFEI-Sandisk but when I go into the connected hard drives, I see Sandisk. After that, if I go back to the boot priority setting, I see both UFEI-Sandisk and Sandisk.

      So I'm not sure why it's working but it's working. For now at least.