Failed to execute command 'export PATH' when hitting check on Update management tab

    • Failed to execute command 'export PATH' when hitting check on Update management tab

      I am on a clean install OMV 4.14-1 arrakis and whever I try to hit the check button on the Update management tab since the last update I got this error:

      Source Code

      1. Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; apt-get update 2>&1' with exit code '100': Get:1 file:/var/cache/openmediavault/archives InRelease Ign:1
      2. .
      3. .
      4. .
      5. W: The repository 'https://dl.bintray.com/openmediavault-plugin-developers/arrakis-hwraid stretch Release' does not have a Release file.
      6. E: Failed to fetch https://dl.bintray.com/openmediavault-plugin-developers/arrakis-hwraid/dists/stretch/main/binary-amd64/Packages 404 Not Found
      7. E: Some index files failed to download. They have been ignored, or old ones used instead.

      My sources.lst archive looks like:

      Source Code

      1. #debian stretch sources
      2. deb http://ftp.es.debian.org/debian/ stretch main
      3. deb-src http://ftp.es.debian.org/debian/ stretch main
      4. #debian stretch updates
      5. deb http://security.debian.org/ stretch/updates main contrib non-free
      6. deb-src http://security.debian.org/ stretch/updates main contrib non-free
      7. #debian stretch-updates, previously known as 'volatile'
      8. deb http://ftp.es.debian.org/debian/ stretch-updates main contrib non-free
      9. deb-src http://ftp.es.debian.org/debian/ stretch-updates main contrib non-free
      Display All

      I have searched a little and the solution might be adding manually the DNS servers to the ethernet interfaces (either my router's IP or Google DNS 8.8.8.8/8.8.4.4), but if I try to edit the network interface I got this error:

      Source Code

      1. Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl start 'networking' 2>&1' with exit code '1': Job for networking.service failed because the control process exited with error code. See "systemctl status networking.service" and "journalctl -xe" for details

      If I enter "systemctl status networking.service" I get:

      Source Code

      1. dic 03 17:10:50 olmos13nas systemd[1]: networking.service: Main process exited, code=exited, status=1/FAILURE
      2. dic 03 17:10:50 olmos13nas systemd[1]: Failed to start Raise network interfaces.
      3. dic 03 17:10:50 olmos13nas systemd[1]: networking.service: Unit entered failed state.
      4. dic 03 17:10:50 olmos13nas systemd[1]: networking.service: Failed with result 'exit-code'.

      And if I enter "journalctl -xe" I get:

      Source Code

      1. dic 03 17:13:09 olmos13nas collectd[1657]: rrdcached plugin: Failed to connect to RRDCacheD at unix:/var/run/rrdcached.sock: Unable to connect to rrdcached: No such file or directory (status=2)

      Thanks for any sort of help, as always :)
      || omv 4.0.14 | kernel 4.9.0 | omvextrasorg 4.1.0 ||
    • macom wrote:

      Also check if DNS resolving is the problem as you assume

      ping google.com -c4

      Thank you for the help.

      DNS resolve correctly:

      Source Code

      1. PING google.com (216.58.201.142) 56(84) bytes of data.
      2. 64 bytes from mad06s25-in-f142.1e100.net (216.58.201.142): icmp_seq=1 ttl=58 time=2.31 ms
      3. 64 bytes from mad06s25-in-f142.1e100.net (216.58.201.142): icmp_seq=2 ttl=58 time=2.50 ms
      4. 64 bytes from mad06s25-in-f142.1e100.net (216.58.201.142): icmp_seq=3 ttl=58 time=2.35 ms
      5. 64 bytes from mad06s25-in-f142.1e100.net (216.58.201.142): icmp_seq=4 ttl=58 time=2.29 ms
      PD: If I try to check and search for new plugins, it shows the same error as in the Update management tab for the system. I will copy the whole code (it is quite long, I cropped it out in the first post):

      Source Code

      1. Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; apt-get update 2>&1' with exit code '100': Get:1 file:/var/cache/openmediavault/archives InRelease Ign:1 file:/var/cache/openmediavault/archives InRelease Get:2 file:/var/cache/openmediavault/archives Release Ign:2 file:/var/cache/openmediavault/archives Release Get:3 file:/var/cache/openmediavault/archives Packages Ign:3 file:/var/cache/openmediavault/archives Packages Get:4 file:/var/cache/openmediavault/archives Translation-en Ign:4 file:/var/cache/openmediavault/archives Translation-en Get:3 file:/var/cache/openmediavault/archives Packages Ign:3 file:/var/cache/openmediavault/archives Packages Get:4 file:/var/cache/openmediavault/archives Translation-en Ign:4 file:/var/cache/openmediavault/archives Translation-en Get:3 file:/var/cache/openmediavault/archives Packages Ign:3 file:/var/cache/openmediavault/archives Packages Get:4 file:/var/cache/openmediavault/archives Translation-en Ign:4 file:/var/cache/openmediavault/archives Translation-en Get:3 file:/var/cache/openmediavault/archives Packages Ign:3 file:/var/cache/openmediavault/archives Packages Get:4 file:/var/cache/openmediavault/archives Translation-en Ign:4 file:/var/cache/openmediavault/archives Translation-en Get:3 file:/var/cache/openmediavault/archives Packages Ign:3 file:/var/cache/openmediavault/archives Packages Get:4 file:/var/cache/openmediavault/archives Translation-en Ign:4 file:/var/cache/openmediavault/archives Translation-en Get:3 file:/var/cache/openmediavault/archives Packages Get:4 file:/var/cache/openmediavault/archives Translation-en Ign:4 file:/var/cache/openmediavault/archives Translation-en Ign:5 http://hwraid.le-vert.net/debian stretch InRelease Ign:6 http://linux.teamviewer.com/deb stable InRelease Hit:7 http://linux.teamviewer.com/deb stable Release Hit:8 http://hwraid.le-vert.net/debian stretch Release Ign:9 http://ftp.es.debian.org/debian stretch InRelease Hit:10 http://packages.openmediavault.org/public arrakis InRelease Hit:11 http://apt.syncthing.net syncthing InRelease Hit:12 http://ftp.es.debian.org/debian stretch-updates InRelease Get:14 http://security.debian.org stretch/updates InRelease [63.0 kB] Hit:15 https://downloads.plex.tv/repo/deb ./public InRelease Hit:16 http://ftp.es.debian.org/debian stretch Release Hit:17 https://download.docker.com/linux/debian stretch InRelease Hit:13 http://cdn-fastly.deb.debian.org/debian stretch-backports InRelease Hit:19 https://openmediavault.github.io/packages arrakis InRelease Ign:20 https://dl.bintray.com/openmediavault-plugin-developers/arrakis stretch InRelease Ign:21 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-testing stretch InRelease Ign:23 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-plex stretch InRelease Ign:24 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-sync stretch InRelease Ign:25 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-hwraid stretch InRelease Ign:26 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-docker stretch InRelease Ign:27 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-teamviewer stretch InRelease Hit:28 https://dl.bintray.com/openmediavault-plugin-developers/arrakis stretch Release Hit:30 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-testing stretch Release Hit:31 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-plex stretch Release Hit:32 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-sync stretch Release Get:34 http://security.debian.org stretch/updates/main Sources [87.7 kB] Ign:36 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-hwraid stretch Release Hit:39 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-docker stretch Release Get:40 http://security.debian.org stretch/updates/main amd64 Packages [232 kB] Hit:41 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-teamviewer stretch Release Ign:44 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-hwraid stretch/main amd64 Packages Ign:45 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-hwraid stretch/main all Packages Ign:46 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-hwraid stretch/main Translation-en Ign:44 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-hwraid stretch/main amd64 Packages Ign:45 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-hwraid stretch/main all Packages Ign:46 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-hwraid stretch/main Translation-en Ign:44 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-hwraid stretch/main amd64 Packages Ign:45 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-hwraid stretch/main all Packages Ign:46 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-hwraid stretch/main Translation-en Ign:44 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-hwraid stretch/main amd64 Packages Ign:45 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-hwraid stretch/main all Packages Ign:46 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-hwraid stretch/main Translation-en Ign:44 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-hwraid stretch/main amd64 Packages Ign:45 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-hwraid stretch/main all Packages Ign:46 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-hwraid stretch/main Translation-en Err:44 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-hwraid stretch/main amd64 Packages 404 Not Found Ign:45 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-hwraid stretch/main all Packages Ign:46 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-hwraid stretch/main Translation-en Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0x7fd8f36508c8> Traceback (most recent call last): File "/usr/lib/python3.5/weakref.py", line 117, in remove TypeError: 'NoneType' object is not callable Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0x7fd8f36508c8> Traceback (most recent call last): File "/usr/lib/python3.5/weakref.py", line 117, in remove TypeError: 'NoneType' object is not callable Fetched 383 kB in 2s (163 kB/s) Reading package lists... W: The repository 'https://dl.bintray.com/openmediavault-plugin-developers/arrakis-hwraid stretch Release' does not have a Release file. E: Failed to fetch https://dl.bintray.com/openmediavault-plugin-developers/arrakis-hwraid/dists/stretch/main/binary-amd64/Packages 404 Not Found E: Some index files failed to download. They have been ignored, or old ones used instead.
      || omv 4.0.14 | kernel 4.9.0 | omvextrasorg 4.1.0 ||
    • Disable the hwraid repo. It doesn't even exist yet and even if it did, there is no plugin to put in it.
      omv 5.0.10 usul | 64 bit | 5.0 proxmox kernel | omvextrasorg 5.1.1
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      Disable the hwraid repo. It doesn't even exist yet and even if it did, there is no plugin to put in it.

      Nice. It worked like a charm.

      Now the check button works (although I guess there is no updates and then it does not show anything, I udpated 2 days ago).

      For the network part, I guess I should post it in a separate thread? omv-firstaid faisl when configuring the network too, shopwing the same error as in webUI:

      Source Code

      1. ERROR: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl start 'networking' 2>&1' with exit code '1': Job for networking.service failed because the control process exited with error code.
      2. See "systemctl status networking.service" and "journalctl -xe" for details
      || omv 4.0.14 | kernel 4.9.0 | omvextrasorg 4.1.0 ||
    • macom wrote:

      Here someone had the same issue and solved it

      added second NIC and getting an omv error but card works

      Thank you that is exactly my case. However, the flushing did not work. The command was successful, but in the webUI I still cannot save the changes to any NIC.

      I have 2 NICs:
      - Intel i-210 (eth0)
      - Intel i-219 (eth1)

      They both work, as I can access OMV webUI in both IPs (192.168.13.31 and 192.168.13.33), and my router detects both NICs and I can assign them static DHCP addresses.

      Maybe uninstalling the interfaces completely and installing again via omv-firstaid?
      || omv 4.0.14 | kernel 4.9.0 | omvextrasorg 4.1.0 ||
    • macom wrote:

      Sorry, don't know.

      Keep it like it is? If everything is woring.

      Or somebody else has an idea.... :?: :!: :?:

      Yeah, both interfaces are working, but I cannot make any changes to them so the main drawbacks are:

      - I cannot activate wake-on-lan so I have to go physically to power on the NAS when I need it.
      - I cannot do link-aggregation (eth0+eth1) to have a backup in case one of the NICs fail.

      Well, technically I can configure them, but at the moment of saving the changes in the webUI, it shows the errror and it does not take the changes.

      PD: I will repost this second problem with additional info as it has anything to do with the original problem.
      || omv 4.0.14 | kernel 4.9.0 | omvextrasorg 4.1.0 ||

      The post was edited 1 time, last by jfromeo ().

    • Users Online 1

      1 Guest