Pinned Windows 10 Creators failure to locate CIFS/SMB shares

    • Yes, this is correct. Either using the IP address or the host name to access the OMV4 server does not work for Windows 10 Enterprise and for Windows 10 Professional. I'm just getting a pop-up window asking for authorisation, however with the right user name and password supplied, I cannot gain access to the OMV4 server.

      For Windows 10 Professional the workgroup is correctly set as per the quoted HOW-TO in my previous post.
    • I don't want to get at cross purposes, there is a difference between 'seeing' the available shares and accessing them, using File Explorer -> Network then in the address bar highlight network and enter \\ip address of omv (the \\ is important and must be used with the ip address) hit enter will display the shares in the right hand pane. If there are no shares visible then the problem lies with your Windows 10 -> if there are shares visible but you cannot access them then it's a user/permissions problem.

      I have a number a W10 machines and non have had any editing done to the registry or the group policy, the machines are a mix of 64 and 32 bit but they are all W10 Pro.
      Raid is not a backup! Would you go skydiving without a parachute?
    • Let me recap the tests I've done, and the findings obtained:
      • Access to an OMV4 server using SSH terminal prompt and FTP shared folder is working fine with all Windows7, macOS, and Windows 10 operating systems.
      • Access to the same OMV4 server using CMB/CIFS shared folder is working fine with all Windows7 and macOS operating systems, however does not work with the Windows 10 operating system despite having followed all guidelines outlined with the HOW-TO "Connect to OMV SMB shares with Windows 10" post.
      • Accessing a commercial NAS platform with the Windows7, macOS, and Windows 10 operating systems is working fine. No issues at all, it even works with a Windows 10 PC!
      With the same Windows 10 PC, I can access a CMB/CIFS shared drive of the same commercial NAS platform without any problems, however it does not work with a shared drive declared within OMV4.

      With access I mean typing in the File Explorer address bar "\\192.168.0.10\" or "\\omv4server.local\" ,authenticate and see the shared drives of the bespoken server. For a commercial NAS server, it works fine with either addressing method, nothing to be changed there.

      When typing the address of the OMV4 server in File Explorer address bar, I'm getting a pop-up window asking for the credentials, however supplying the correct user and password information, I am always getting "The user name or password is incorrect" - why?

      Thus, either the SMB/CIFS on the OMV4 side needs to be tweaked or on a PC running Windows 10, especially when taking into consideration that SMB 1.0 is banned with the latest Windows 10 update, and who knows what else has been changed on the server &/or client side to patch security holes..
    • Ok I can see from your post you are getting frustrated ignore the 'commercial nas' that doesn't help you and it doesn't help me.

      carriba wrote:

      1. With access I mean typing in the File Explorer address bar "\\192.168.0.10\" or "\\omv4server.local\" ,authenticate and see the shared drives of the bespoken server.
      2. When typing the address of the OMV4 server in File Explorer address bar, I'm getting a pop-up window asking for the credentials, however supplying the correct user and password information, I am always getting "The user name or password is incorrect" - why?
      1. You type in \\192.168.0.10 at this point there is no request for authentication, this simply displays the shares available on the server, my own server below.


      2. This would only happen when trying to open a share as the following image shows, I have set guest access to No just to demonstrate on that particular share;


      Please let's get past the above.
      Raid is not a backup! Would you go skydiving without a parachute?
    • Inspired by the "Stop using SMB1" article, it seems that I have found a solution or workaround to allow accessing again the NAS drive:

      Launch the "Local Security Policy" tool, and under the branch "Security Options" and under the option "Network Security: LAN Manager authentication level" , just change the settings from "Send LM & NTLM - use NTLMv2 session security if negotiated" to "Send NTLMv2 responses only".

      This did work for me and now have access to the OMV NAS storage platforms with SMB 2.0!

      Maybe it's worth to have a look at the OMV server side and explore other parameters...
    • carriba wrote:

      Maybe it's worth to have a look at the OMV server side and explore other parameters..

      In the extra options of an SMB share

      client max protocol =SMB? (where ? is 3 or 2. The list of values can be found ->here.)
      client min protocol = SMB?
      AND

      server max protocol =SMB?
      server min protocol = SMB?

      If applied in the SMB/CIF Setting Tab, extra options
      The above parameters would apply to all shares. (global)
      ________________________________________________________________

      The problems with SMB have never been about Linux on the server side. There's tons of flexibility there. It's always been about Microsoft deciding, without collaboration or notice, on how it's going to be. Adding to that is Microsoft's tendency to send out security updates without warning or thought to the consequences.
    • I have been following this thread and others on the subject. I am new to OMV as I got tired of having to reset my connector between win 10 and Server 2012.
      I first ran this new server with SMB 1.0 switched on in Win 10. Then I read the named threads and starting working away from that scenario. I have followed the workaround and keep getting an error "Win cannot access \\server" "The network path was not found". I run the Diagnose app and then it finds the server and my Shares. I do have a Quick Access link to the \\server (that's how I start the access).
      I am running Win 10 Build 18290, so things may be a little different.
      When I click on a Dir on my server in Explorer (once it has found it), then the "server" appears under Network Section. This occurs every time I re-invoke File Explorer.
      I will try to figure out how to implement flmaxey's server side suggestions.