OMV3/Unionfs/Plex...and Hello

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • OMV3/Unionfs/Plex...and Hello

      Hello OMV Professionals/Enthusiasts,

      TL;DR - I can setup the plex server plug-in on a single drive mount, but not my unionfs three disk array.

      I have been running OMV v2 on an RPi2 for over a year and recently built a full PC server (from parts of various PCs). I am a long time lurker on the forums and grateful for all the knowledge you share so routinely. So far the process has been mostly flawless with some small issues affecting my overall experience. The first issue, changing DHCP reservations, was resolved after realizing I couldn't simply restart the server, but rather, had to hard power off to get a new IP Address (not sure why).

      The second is the subject of my post. My drive array consists of 2 - 2TB drives and 1 - 4TB drive mounted as one volume using unionfs. The separate Archive 8TB drive in my server is currently NTFS and was only used to rsync files from a failed windows server to the array which went smoothly after seeing this post (THANKS!). The array is accessible through SMB/CIFS, Youtube-DL/Downloader, and other plugins without issue so far. When installing Plex following this link, I am unable to get a successful install with the UnionFS array (red dot in services, no web client access). The plexmediaserver folder does show up in the array, but also in /var/lib/plexmediaserver. After trying several different options such as chown for plex user, an ACL change (separate), and a manual SSH install, I have been unsuccessful. Just to be sure, I installed Plex on the single NTFS drive (which I would like to remove), and voila, Plex came up immediately. Ultimately, I can use a different method of joining the drives (or just use them individually), but UnionFS seemed promising with all the other programs/plugins, so I would love for it to work with Plex if at all possible. I am unfamiliar with UnionFS, but have never had a major issue with Plex on OMV or Windows (my old server). Thanks for your time.