No luck with Bios time settings

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • No luck with Bios time settings

      So I wanted to set my OMV computer to boot at 10 am. It is set to shut down at 2 am. So it will be off between those hours.

      Time in bios is set to right time with boot time set to 10 am.
      Time in OMV is set by NTP Server (time.google.com) and I have the right Time Zone selected.

      The problems i am having is that the computer boots up at 3 am instead of 10 am. It shuts down at the right time. Im assuming this is something with Time Zones but I just dont see why this would be happening because I have everything set up correctly. There is no Time Zones selection in Bios. Does OMV adjust Bios time? If it doesnt I might just set the bios to boot at 3pm. Thanks.
    • ZanosG wrote:

      Does OMV adjust Bios time?
      Debian updates the RTC at shutdown.

      I assume the problem comes from the DST (Daylight Saving Time).
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • If DST was the problem, that could account for a one hour discrepancy. The OP does not say what time zone he is in, but if Debian updates the RTC at shutdown, and it is updating it to UTC time, then that could account for much more than a one hour discrepancy.
      --
      Google is your friend and Bob's your uncle!

      OMV 4.x - ASRock Rack C2550D4I - 16GB ECC - Silverstone DS380
    • Since the change in the clocks in the UK my system has remained on GMT and has not adjusted to British Summer Time (BST = GMT+1).


      In Settings/Date & Time I have time set to UTC which shows the Current Time as 1 hour behind UK time. The correct time is shown in the Manual section (and is greyed out).


      Running TZselect shows:

      - Local time is now:Sat Apr 27 10:40:48 BST 2019.

      - Universal Time is now:Sat Apr 27 09:40:48 UTC 2019.


      Can someone tell me how to have the system operate under BST?At the moment my Cron back-up runs an hour late and my music server displays GMT not BST.
      OMV 4.1.8.2-1
      Rock64, 1Gb
      Logitech Media Server 7.9.2
    • ZanosG wrote:

      openletter wrote:

      My experience with various *nix OSs is they always reset BIOS to UTC.
      One of many reasons why I hate Linux. It seems to suffer from all these stupid small things that should be common sense. I have selected right time zone and the right time. That should be the end of that.
      You do realize that the time protokoll is much more enhanced than in windows? There is a very good reason, that GNU/Linux sets utc inside the bios. Your system than looks at his timezone settings and calculates the time. If this isnot working your system got brokem severly before. It is also a necessarity in professional environments to differentiste between thy sxstem and the bios clock. So if you dont write changes to hwclock, you loose changes with reboot. Or you set the timezone but missed to update the clock, I highly advice ntpd, which takes care of most things.
    • Backslash Backslash wrote:

      In Settings/Date & Time I have time set to UTC which shows the Current Time as 1 hour behind UK time.
      How about selecting the correct time zone like Europe/London?

      I have Europe/Berlin and this is the output of date:
      Sat Apr 27 14:49:49 CEST 2019

      So the system show me Central Europe Summer Time.
      Odroid HC2 - armbian - Seagate ST4000DM004 - OMV4.x
      Asrock Q1900DC-ITX - 16GB - 2x Seagate ST3000VN000 - Intenso SSD 120GB - OMV4.x
      :!: Backup - Solutions to common problems - OMV setup videos - OMV4 Documentation - user guide :!:
    • Thanks for the replies. I have fixed the issue but I don't know how I did it.

      I had previously tried setting the Europe/London option but:

      1. it made no difference to the Current Time, it remained incorrect and lagged the Manual Time by 1 hour
      2. if I clicked "Update Now" the system automatically switched the time to UTC and the Current Time remained 1 hour behind the greyed-out Manual Time

      After macom's comment I tried setting the system to Europe/Berlin but the time stayed as before, Manual Time was correct for the UK (i.e. CEST -1h) and Current Time was 1 hour behind (i.e. CEST -2h). Clicking on "Update Now" forced the system back to UTC and the Current Time 1 hour behind the true UK time.

      I then changed the manual time to something ridiculous, say two hours and ten minutes ahead of now. I clicked "Upgrade Now" and was kicked out of the system. When I logged back in the Current Time was correct and the Manual Time was greyed-out and 1 hour in advance (i.e. CEST).

      So, I don't know how it happened but it is now correct.

      Thanks for your help.
      OMV 4.1.8.2-1
      Rock64, 1Gb
      Logitech Media Server 7.9.2