Wifi (wlan0) not working outside of my LAN!

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Wifi (wlan0) not working outside of my LAN!

      Hi, i have a strang problem with a new OpenMediaVault system


      The WiFi Card works, is up and i can ping my LAN but not outside (WAN).

      IP's are correct, DNS is correct, iptables is empty (disabled), submask is correct etc...

      Can someone tell me wtf is wrong?


      Cheers PyCoder

      Source Code

      1. root@omv:~# ping -I wlan0 192.168.0.1
      2. PING 192.168.0.1 (192.168.0.1) from 192.168.0.11 wlan0: 56(84) bytes of data.
      3. 64 bytes from 192.168.0.1: icmp_seq=1 ttl=64 time=7.00 ms
      4. 64 bytes from 192.168.0.1: icmp_seq=2 ttl=64 time=0.576 ms
      5. 64 bytes from 192.168.0.1: icmp_seq=3 ttl=64 time=0.592 ms


      But if i try to ping google.com

      Source Code

      1. root@omv:~# ping -I wlan0 google.com
      2. PING google.com (172.217.21.238) from 192.168.0.11 wlan0: 56(84) bytes of data.
      3. From OMV.linux (192.168.0.11) icmp_seq=1 Destination Host Unreachable
      4. From OMV.linux (192.168.0.11) icmp_seq=2 Destination Host Unreachable

      Or with the IP of google.com


      Source Code

      1. root@omv:/etc/# ping -I wlan0 216.58.207.46
      2. PING 216.58.207.46 (216.58.207.46) from 192.168.0.11 wlan0: 56(84) bytes of data.
      3. From 192.168.0.11 icmp_seq=1 Destination Host Unreachable
      4. From 192.168.0.11 icmp_seq=2 Destination Host Unreachable
      5. From 192.168.0.11 icmp_seq=3 Destination Host Unreachable

      iwconfig output looks like

      Source Code

      1. root@omv:~# iwconfig wlan0
      2. wlan0 IEEE 802.11 ESSID:"GNU_Linux_5G"
      3. Mode:Managed Frequency:5.2 GHz Access Point: 5C:A3:9D:B2:58:A0
      4. Bit Rate=81 Mb/s Tx-Power=16 dBm
      5. Retry short limit:7 RTS thr:off Fragment thr:off
      6. Encryption key:off
      7. Power Management:off
      8. Link Quality=53/70 Signal level=-57 dBm
      9. Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
      10. Tx excessive retries:0 Invalid misc:2517 Missed beacon:0
      11. root@omv:~#
      Display All
      /etc/network/interfaces looks like

      Source Code

      1. root@omv:~# cat /etc/network/interfaces
      2. # The loopback network interface
      3. auto lo
      4. iface lo inet loopback
      5. # eth0 network interface
      6. auto eth0
      7. allow-hotplug eth0
      8. iface eth0 inet static
      9. address 192.168.0.10
      10. gateway 192.168.0.1
      11. netmask 255.255.255.0
      12. post-up /sbin/ifconfig $IFACE mtu 1500
      13. dns-nameservers 192.168.0.1
      14. dns-search linux
      15. pre-down ethtool -s $IFACE wol g
      16. iface eth0 inet6 manual
      17. pre-down ip -6 addr flush dev $IFACE
      18. # wlan0 network interface
      19. auto wlan0
      20. allow-hotplug wlan0
      21. iface wlan0 inet static
      22. address 192.168.0.11
      23. gateway 192.168.0.1
      24. netmask 255.255.255.0
      25. post-up /sbin/ifconfig $IFACE mtu 1500
      26. dns-nameservers 192.168.0.1
      27. dns-search linux
      28. wpa-ssid GNU_Linux_5G
      29. wpa-key-mgmt WPA-PSK
      30. wpa-psk mypassword
      31. iface wlan0 inet6 manual
      32. pre-down ip -6 addr flush dev $IFACE
      33. root@omv:~#
      Display All

      route looks like

      Source Code

      1. root@omv:~# route -n
      2. Kernel-IP-Routentabelle
      3. Ziel Router Genmask Flags Metric Ref Use Iface
      4. 0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0 eth0
      5. 192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0
      6. 192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
      7. root@omv:~#

      iptables looks like

      Source Code

      1. root@omv:~# iptables -L
      2. Chain INPUT (policy ACCEPT)
      3. target prot opt source destination
      4. Chain FORWARD (policy ACCEPT)
      5. target prot opt source destination
      6. Chain OUTPUT (policy ACCEPT)
      7. target prot opt source destination
      8. root@omv:~#

      Resolv.conf looks like

      Source Code

      1. root@omv:/etc/# cat resolv.conf
      2. # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
      3. # DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
      4. nameserver 192.168.0.1
      5. search linux
      6. root@omv:/etc/#
    • subzero79 wrote:

      Try to assign one gateway only, either on wlan0 or eth0
      Doesnt work BUT i fixed it, i guess with this:

      Source Code

      1. route add default gw 192.168.0.1 wlan0



      route -n looks like this now

      Source Code

      1. root@omv:~# route -n
      2. Kernel-IP-Routentabelle
      3. Ziel Router Genmask Flags Metric Ref Use Iface
      4. 0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0 wlan0
      5. 0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0 eth0
      6. 192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
      7. 192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0
      And it works!


      Source Code

      1. root@omv:~# ping -I eth0 google.com
      2. PING google.com (216.58.207.78) from 192.168.0.10 eth0: 56(84) bytes of data.
      3. 64 bytes from fra16s25-in-f14.1e100.net (216.58.207.78): icmp_seq=1 ttl=55 time=16.8 ms
      4. 64 bytes from fra16s25-in-f14.1e100.net (216.58.207.78): icmp_seq=2 ttl=55 time=18.2 ms
      5. ^C
      6. --- google.com ping statistics ---
      7. 2 packets transmitted, 2 received, 0% packet loss, time 1001ms
      8. rtt min/avg/max/mdev = 16.842/17.557/18.272/0.715 ms
      9. root@omv:~# ping -I wlan0 google.com
      10. PING google.com (216.58.207.78) from 192.168.0.11 wlan0: 56(84) bytes of data.
      11. 64 bytes from fra16s25-in-f14.1e100.net (216.58.207.78): icmp_seq=1 ttl=55 time=17.8 ms
      12. 64 bytes from fra16s25-in-f14.1e100.net (216.58.207.78): icmp_seq=2 ttl=55 time=19.2 ms
      13. 64 bytes from fra16s25-in-f14.1e100.net (216.58.207.78): icmp_seq=3 ttl=55 time=15.4 ms
      14. ^C
      15. --- google.com ping statistics ---
      16. 3 packets transmitted, 3 received, 0% packet loss, time 2002ms
      17. rtt min/avg/max/mdev = 15.449/17.516/19.204/1.563 ms
      18. root@omv:~#
      Display All
      BUT its not really beautiful, because i have to use rc.local :(


      Source Code

      1. root@omv:~# cat /etc/rc.local
      2. #!/bin/sh -e
      3. #
      4. # rc.local
      5. #
      6. # This script is executed at the end of each multiuser runlevel.
      7. # Make sure that the script will "exit 0" on success or any other
      8. # value on error.
      9. #
      10. # In order to enable or disable this script just change the execution
      11. # bits.
      12. #
      13. # By default this script does nothing.
      14. /etc/init.d/networking restart
      15. route add default gw 192.168.0.1 wlan0
      16. exit 0
      17. root@omv:~#
      Display All
      Or is there a better solution?

      The post was edited 1 time, last by PyCoder ().