OMV4 on ARM boards (kind of a how-to)

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • OMV4 on ARM boards (kind of a how-to)

      Currently no OMV4 images for ARM boards are available for download. While this might change in the future Below is outlined how to get an optimized OMV 4 version on any of the supported ARM boards.

      Variant 1) -- Upgrading

      Choose any of the available OMV 3 images, activate shellinabox plugin or SSH access and then use the CLI to do an 'omv-release-upgrade'. This will update OMV 3 to 4 and the underlying Debian Jessie to Stretch. After this you can enjoy OMV 4 with all performance and other optimizations we implemented for the weak ARM platforms.

      Main disadvantage especially with an old SD card: the upgrade is a lot of storage activity, on slow cards (random IO is important) this can take hours and with really old and almost worn out SD cards the whole process can even fail and the SD is broken afterwards or became read-only (if it's one with faked capacity then all sorts of strange things can happen). So always clone/backup the SD card first before doing the omv-release-upgrade. The best idea is to get a new A1 rated SD card (the higher capacity the better since lasting longer), clone your old SD card onto it and then do the upgrade on the A1 rated SD card. A SanDisk Ultra A1 with 16 GB for example is both pretty fast and rather inexpensive and will speed up the upgrade process by magnitudes (it's all about random IO!).

      Variant 2) -- armbian-config

      All current OMV images for ARM boards are based on an Armbian Debian variant. The many optimizations we did last year are partially integrated into Armbian, partially a special OMV installation routine (see here for details). I added all the important stuff to Armbian's armbian-config tool so all that's needed is an Armbian variant with recent but stable kernel (next Branch) and the proper Debian flavour (that's Stretch). And then it's simply calling armbian-config --> Software --> Softy --> Install OMV.

      [Blocked Image:]

      So the steps are as follows:
      • Read/understand Armbian's installation procedure (checking download integrity, checking the SD card, burning correctly, logging in the first time)
      • Visit and choose your board. For a Banana Pi you end up here for example:
      • Search for a variant that's called Debian_Stretch_next that does not have "Nightly" in its name. You want a Debian Stretch image based on 'next' branch (recent kernel) that is stable (no nightly).
      • Download the image, decompress it, burn it, boot the board, access it via SSH, login as root, assign a new root password and create a normal user account (it's all guided)
      • Then call armbian-config and install OMV as follows: Software --> Softy --> Install OMV
      • Once installed you can access the web UI with a browser (admin:openmediavault -- immediately change this password please) where everything else will be configured the usual way

      Variant 3) New image

      For the more popular ARM boards here…ngle%20Board%20Computers/ are OMV4 images. For Raspberry Pi 2B, 3B and 3B+ you'll find it here instead:…/Raspberry%20Pi%20images/

      Additional Notes:

      • Variant 2) is not available for the Raspberry Pi. I thought about preparing a new OMV4 image for RPi but since this is such a lousy hardware (way too slow and unrealiable) I still think I should do better things in my spare time.
      • The above screenshot has been made on a Raspbian installation a while ago. We tried to let the armbian-config code run on any Debian based OS (e.g. Raspbian) but YMMV.
      • With our optimized installation routine we will enable the flashmemory plugin by default and we disable monitoring. This happens to reduce wear on SD card, for details see here.
      • The included optimizations are important. See here for performance numbers with another SBC distro based on Debian Stretch that neither cares about performance nor security:

      The post was edited 6 times, last by tkaiser ().

    • Thanks for the how to.
      Unfortunately i have two issues with OMV4.
      First there is no Subsonic plugin and docker seems not working.
      Secondly after the latest kernel and omv update over the omv GUI the system does not boot anymore.
      Glady this is not a production system. Next time i will make an image before updating.
    • the images came a bit too late for me ...

      I upgraded a XU4 and a HC1 via omv-release-upgrade.

      On the XU4 the configuration of llvm2 hang on vgcfgbackup in the postinst script.
      I could not kill the process...
      Thanks to HDMI-output and a keyboard I could boot the 70% configured upgrade (no secure shell after reboot) and do a manual upgrade after a reboot.

      Both machines were lacking a busybox to update the initramfs.
      apt install busybox

      Both machines gave me trouble with
      manually editied the file:…5d1c1f8c2989578a8fc2c1de6

      The post was edited 1 time, last by tkaiser: Moved here and added reference the thread ().

    • tkaiser, I just want to say thank you for taking your time and writing that out. I run a Raspberry Pi 3 did the 'omv-release-upgrade' in CLI ssh didn't take as long as expected once everything was done rebooted I was running OMV4 and knock on wood everything seems to be working great no hiccups other than I had a plug-in that that I wasn't using so I uninstalled it Deluge and it still showed up in the left sidebar just the entry and also a quick note it is not available for omv4 perhaps that's why it still showed up, but installed a new plug-in and the old plug-in entry disappeared I guess it needed to just refresh the list or something but thank you very much for taking your time writing it out all of us arm single board Folk. I'm very impressed with the upgrade process The openmediavault developers did a great job.

      The post was edited 1 time, last by neurotone ().

    • fjld61 wrote:

      Can someone tell me which image I should download from…ngle%20Board%20Computers/ for a WD MyCloud Home apparently based on a Realtek RTD1296PBCG (4x1.4GHz) ARM processor.
      None of those images will work. They only work on the exact board in the name. You need to find a Debian Stretch image for your system, install it, and then install OMV.
      omv 4.1.19 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15 plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Thanks for the info.

      Apparently this Realtek RTD1296PBCG is a Sytem-on-Chip (SoC) which integrates a ARM cortex A53 and a T820 GPU.
      Data sheet :

      I guess it is too simple to think that an image suited for these components is possible (I really don't know)

      It's just that this WD MyCloud Home behaves as a trojan horse in my home network (opening UDP connections to servers all over the world, really check your firewall logs) and I wanted to replace the OS to something more trust-able and more under my control. I guess I should buy a raspberry pi and recover the 4TB disk from the enclosure.
    • fjld61 wrote:

      I guess it is too simple to think that an image suited for these components is possible (I really don't know)

      The problem is (lack of) driver support in the ARM world. Some vendors cooperate, some simply don't care (RealTek being in the latter group -- their RTD chips are pretty interesting hardware but due to them not releasing the relevant sources -- thereby violating the GPL so someone could even sue them -- it would require huge reverse engineering efforts to get their hardware running an upstream Linux kernel which is basic requirement for Debian which is basic requirement for OMV.

      Please don't be stupid and buy a Raspberry Pi for NAS use cases. These toys are great for absolute beginners wanting a KODI box or blink an led but the worst choice possible for anything storage and network related (especially the new RPi 3 B+ with its crappy Gigabit Ethernet implementation).

      There are tons of better options, see @'macom''s link and the download location:…ngle%20Board%20Computers/

      With a 3.5" disk I wouldn't think a second and order an ODROID-HC2.
    • Hi, can I somehow get the great samba file transfer performance these tweaked omv builds have?
      I run latest armbian stretch stable on Odroid HC2, installed OMV via armbian-config.

      Then messed up my php install: PHP Fatal Error: Uncaught Error
      Then removed OMV.
      Then tried to reinstall it via armbian-config which failed:…omv-how-to-reinstall-omv/
      ..Apparently a reinstall of OMV via armbian-config is neighter intended nor possible..

      So now I just installed samba manually, using the old omv generated smb conf but I just get 60 mb/s tranfer speed.
      I used to get 100 mb/s.
    • Thanks so much for this great tutorial! I am working to get a home server up and running and this has been a great help.

      One thing I am stuck on is using the "Software --> Softy --> Install OMV" step. When I choose install OMV, it starts the installation, then goes back to the list without seeming to do anything. Any tips on this?
    • trohn_javolta wrote:

      I used to get 100 mb/s.
      The information you provided here suggest you're using NTFS (very high %sys activity which smells like a FUSE filesystem which is usually the way NTFS on OMV/Linux is handled). In case it's NTFS switch to a native filesystem.

      bl3nd3r wrote:

      When I choose install OMV, it starts the installation, then goes back to the list without seeming to do anything. Any tips on this?
      Unfortunately not. The installation procedure is part of armbian-config which is a single guy's project I gave up on fixing stuff...
    • When loading up Softy I get "/etc/resolvconf/update.d/libc: Warning: /etc/resolv.conf is not a symbolic link to /etc/resolvconf/run/resolv.conf".

      I have an Udoo Quad board and it is not listed as a supported board on that link, which is why I went the Armbian route.

    • tkaiser wrote:

      bl3nd3r wrote:

      Warning: /etc/resolv.conf is not a symbolic link to /etc/resolvconf/run/resolv.conf"
      I've seen this once IIRC. Simple search in the forum points to /etc/resolvconf/update.d/libc: Warning: /etc/resolv.conf is not a symbolic link to /etc/resolvconf/run/resolv.conf for example. Does the command at the bottom resolves the issue?

      Source Code

      1. sudo dpkg-reconfigure resolvconf
      Apologies, I know better than to not first search!

      That fixed the error, but the behaviour (OMV not installing) hasn't changed. I will check the previous version now.