Union Filesystem creation error incorrect validation on min-free-space

    • OMV 4.x
    • Union Filesystem creation error incorrect validation on min-free-space

      BackStory: I have a fresh install of OMV 4 that i am trying to get up and running originally running OMV 2.x and decided fresh install was the way to go as greyhole wasn't supported., planning to do unionfs and SnapRAID.

      When attempting to merge a few disks in the creation dialog i am getting a validation error on the min size property and not entirely sure why (pretty sure its a bug).

      min-free-space: The value '50G' doesn't match the pattern '/^[0-9]+[KMG]$/'.

      Also I have been running into a few of these is 4.x stable or should i go back to 3.x? Chrome didn't work 70% of the time ended up having to use firefox to get anywhere!

    • Having the same issue- even with the default 4G.

      Fresh install of OMV4 over Debian9, have a SnapRAID pool created.

      Pics attached. Error message attached.

      Source Code

      1. OMV\Json\SchemaValidationException: min-free-space: The value '4G' doesn't match the pattern '/^[0-9]+[KMG]$/'. in /usr/share/php/openmediavault/json/schema.inc:481
      2. Stack trace:
      3. #0 /usr/share/php/openmediavault/json/schema.inc(370): OMV\Json\Schema->checkPattern('4G', Array, 'min-free-space')
      4. #1 /usr/share/php/openmediavault/json/schema.inc(297): OMV\Json\Schema->validateString('4G', Array, 'min-free-space')
      5. #2 /usr/share/php/openmediavault/json/schema.inc(627): OMV\Json\Schema->validateType('4G', Array, 'min-free-space')
      6. #3 /usr/share/php/openmediavault/json/schema.inc(395): OMV\Json\Schema->checkProperties(Object(stdClass), Array, '')
      7. #4 /usr/share/php/openmediavault/json/schema.inc(285): OMV\Json\Schema->validateObject(Object(stdClass), Array, '')
      8. #5 /usr/share/php/openmediavault/json/schema.inc(257): OMV\Json\Schema->validateType(Object(stdClass), Array, '')
      9. #6 /usr/share/php/openmediavault/rpc/paramsvalidator.inc(59): OMV\Json\Schema->validate(Object(stdClass))
      10. #7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(178): OMV\Rpc\ParamsValidator->validate('{"name":"mediap...')
      11. #8 /usr/share/openmediavault/engined/rpc/unionfilesystems.inc(182): OMV\Rpc\ServiceAbstract->validateMethodParams(Array, 'rpc.unionfilesy...')
      12. #9 [internal function]: OMV\Engined\Rpc\UnionFilesystems->set(Array, Array)
      13. #10 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      14. #11 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('set', Array, Array)
      15. #12 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('UnionFilesystem...', 'set', Array, Array, 1)
      16. #13 {main}
      Display All
      • union1.JPG

        74.25 kB, 598×876, viewed 175 times
      • union2.JPG

        65.12 kB, 612×844, viewed 177 times
    • No, guess it doesn't work. Ctrl+F5 ... no change in behaviour.

      OS: Windows 10, current patch
      Browser: Chrome 68.0

      Here's the stacktrace:

      Source Code

      1. Error #0:
      2. OMV\Json\SchemaValidationException: min-free-space: The value '4G' doesn't match the pattern '/^[0-9]+[KMG]$/'. in /usr/share/php/openmediavault/json/schema.inc:481
      3. Stack trace:
      4. #0 /usr/share/php/openmediavault/json/schema.inc(370): OMV\Json\Schema->checkPattern('4G', Array, 'min-free-space')
      5. #1 /usr/share/php/openmediavault/json/schema.inc(297): OMV\Json\Schema->validateString('4G', Array, 'min-free-space')
      6. #2 /usr/share/php/openmediavault/json/schema.inc(627): OMV\Json\Schema->validateType('4G', Array, 'min-free-space')
      7. #3 /usr/share/php/openmediavault/json/schema.inc(395): OMV\Json\Schema->checkProperties(Object(stdClass), Array, '')
      8. #4 /usr/share/php/openmediavault/json/schema.inc(285): OMV\Json\Schema->validateObject(Object(stdClass), Array, '')
      9. #5 /usr/share/php/openmediavault/json/schema.inc(257): OMV\Json\Schema->validateType(Object(stdClass), Array, '')
      10. #6 /usr/share/php/openmediavault/rpc/paramsvalidator.inc(59): OMV\Json\Schema->validate(Object(stdClass))
      11. #7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(178): OMV\Rpc\ParamsValidator->validate('{"name":"omvuni...')
      12. #8 /usr/share/openmediavault/engined/rpc/unionfilesystems.inc(182): OMV\Rpc\ServiceAbstract->validateMethodParams(Array, 'rpc.unionfilesy...')
      13. #9 [internal function]: OMV\Engined\Rpc\UnionFilesystems->set(Array, Array)
      14. #10 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      15. #11 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('set', Array, Array)
      16. #12 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('UnionFilesystem...', 'set', Array, Array, 1)
      17. #13 {main}
      Display All
    • geaves wrote:

      kefawirt wrote:

      Sorry for multiple posting ... had some error message ... now I can't delete these messages ...
      That's Ok, but what @ryecoaaron is telling you is to clear your browser cache that is why you are seeing the error

      So I tried CTRL+F5 ... thought this should be ok. Now I followed these steps:

      google wrote:

      On your computer, open Chrome.
      At the top right, click More [Blocked Image: https://storage.googleapis.com/support-kms-prod/ArAlBcUAe8h1l5m69uxnwElxkqwW0QdtIc3F]
      Click More tools [Blocked Image: https://lh3.googleusercontent.com/nHFGZ_9xjCh-mP83zMzXQVJF5VYf2n6kwoBIxB2zv3V4VPT4gNTtBye8lYznogLqLPY=w13-h18] Clear browsing data.
      At the top, choose a time range. To delete everything, select All time.
      Next to "Cookies and other site data" and "Cached images and files," check the boxes.
      Click Clear data.

      But the message is still the same.

      //more info: Just updated from 3.xx to 4.1.11.

      //again more info: Tried it with another browser (IE 11) ... some message.

      The post was edited 1 time, last by kefawirt ().

    • Tried to uninstall union filesystem which works.

      Reinstallation was another topic - got following message on startup:

      RPC service 'UnionFilesystems' not found.
      Error #0:OMV\Rpc\Exception: RPC service 'UnionFilesystems' not found. in /usr/share/php/openmediavault/rpc/rpc.inc:99Stack trace:#0 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('UnionFilesystem...', 'getList', Array, Array, 1)#1 {main}

      And another one - see attached - during installation-process.

      At this point, I'll stop fixing union filesystem and will reinstall OMV; guess this will work or at least hope so.
    • It looks like your repos are incorrect. If you are on OMV 4, it should not be looking for php5. I think you probably had an old version of the plugin but with so many errors, I would start over.
      omv 5.2.3 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.2.1
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Puuh ... this was a tough piece of work.

      When I reinstalled OMV 4.x, I disconnected (put cable off) all data-disks, only my system-M2 was already active ... installation was just fine, no problem. Then I reconnected all drives and then there was a bad surprise - grub was not loading my new installation; every time, I connected a data disk, a error similar like this (No init found. Try passing init=bootarg.) appeared: askubuntu.com/questions/25695/initramfs-error-during-boot

      I found out, that my installation-USB-Stick was ! sda ! [wrong mount order] during installation, so grub put no boot-partition/-information on sda (my M2) after I removed the USB-Stick.

      I found the solution (fix grub2) in this blog: dcandy.wordpress.com/2015/01/0…ls-to-install-bootloader/

      Finally, I looks quite fine to me ... OMV is reachable, data is already there ... hope this will last for a long time ^^

      Thank you for your support!