Upgrading OMV 3->4 incl. OMV-extras

    • OMV 3.x
    • Upgrade 3.x -> 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Upgrading OMV 3->4 incl. OMV-extras

      Hello,

      This weekend I would like to upgrade my HP microserver (RAID 5) running OMV 3 latest version to 4 newest version.

      First, I backupped my system to an USB stick using the backup-plugin.

      I am planning to login via SSH and executing the following commands:

      apt-get update
      apt-get upgrade
      omv-release-upgrade
      omv-initsystem

      Hope, this is the best way to go.

      But, I am not sure how to handle my installed OMV-extras. To be honest, I do not really know what plugins I have installed via OMV-extras.
      How do I integrate the needed OMV-extras upgrade in my update-solution?
    • Blebbens wrote:

      First, I backupped my system to an USB stick using the backup-plugin.
      With the OMV 3.x version of the backup plugin, the restore is difficult. I would use clonezilla.

      Blebbens wrote:

      omv-release-upgrade
      This is all you need if your system is up to date. If not, do an omv-update before omv-release-upgrade

      Blebbens wrote:

      I do not really know what plugins I have installed via OMV-extras
      dpkg -l | grep openm will show you all of the plugins.

      Blebbens wrote:

      How do I integrate the needed OMV-extras upgrade in my update-solution?
      It will update with OMV. There is nothing to integrate. The only problem comes from having 3.x plugins that don't have a 4.x equivalent.
      omv 5.1.2 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.1.7
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Blebbens wrote:

      OMV is running on a SATA 500GB hd. Is clonezilla able to clone the drive to an 64 USB stick?
      Depends on how well it compresses and how much is in use. Try it.

      Blebbens wrote:

      Is there a way to find out the installed version 3 only non-updateable OMV plugins?
      Compare your list with the list on the omv-extras page - omv-extras.org
      omv 5.1.2 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.1.7
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • stefan1983 wrote:

      So on the OMV4-extras page all extras listed with a 3.x version won't work with OMV4?For example:


      ?( ?(
      No, that is not correct. Many OMV 4.x plugins are still at a 3.x version number.

      What you need to do it make a list of your OMV 3.x plugins and see if there are corresponding OMV 4.x plugins. If there are you can leave the existing plugins installed. If there isn't they must be removed prior to upgrading.
      --
      Google is your friend and Bob's your uncle!

      RAID - Its ability to disappoint is inversely proportional to the user's understanding of it.

      ASRock Rack C2550D4I - 16GB CC - Silverstone DS380
    • If it is on the 4.x page, it works on 4.x. If a plugin on the 4.x page has a 3.x version, that means the plugin works on OMV 3.x and 4.x without modification.
      omv 5.1.2 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.1.7
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Users Online 1

      1 Guest