[SOLVED] wrong owners, how to fix it?

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Attributes on big files

      Thanks for the amazing software. I have a weird problem and I narrowed it to the way files' attributes are written into my SMB shares.

      I am using OMV 4, ext4 file system with Filesystem Union as a big drive, SMB shares with Windows 10, NFS shares that all my Kodi devices read. The db is on mysql in OMV plugin.

      I can read and write to my SMB shares from windows and they actually are seen into the NFS shares, but something is missing with the attributes and Kodi devices don't update the libraries for that folder.

      I fond the problem. I add an image to show it better. Two different files, the one on the left is OK, kodi updates it. The one on the right has different security and kodi doesn't update it into the library. How to solve it?
      • 2018-07-11 (1).png

        39.99 kB, 727×510, viewed 52 times

      The post was edited 3 times, last by smandurlo ().

    • I solved the problem. So, for reference: I went to the shared folder, opened the ACL tab and removed the user "Felice". Root is write/read/execute, same for users and nothing for others. Replaced all the ACL, subdir included.

      This didn't fix the problem with Kodi, but at least made the ACL correct.

      To fix the kodi scraping, I added a "no_acl" into the NFS options near the insecure. So now it looks like subtree_check,insecure,no_acl

      Maybe it is not the best for security, but it is my lan only and it is to access movies and music, it doesn't need to be secure.