How can I permanently remove entry from resolv.conf?

    • OMV 4.x
    • How can I permanently remove entry from resolv.conf?

      Hi, I'm running a couple of OMV 4 boxes (on Pi 2's) on a local network and they are unable to resolve each others names.
      I manually added entries to the hosts file and that was fine for a few minutes, but then the hosts file is being automatically regenerated.
      I've then realised that the issue is actually because in resolv.conf the system is automatically adding 1.1.1.1 as the top dns server.
      I removed the top entry and both OMV were able to resolve each other, but again after a reboot the resolv.conf is being automatically regenerated and reasserting 1.1.1.1 as the top dns server - i've never specified 1.1.1.1 as a dns server and my OMV's are not connected to the Internet so it doesn't even make sense to have it in the list at all.

      Please could you help?

      Many thanks.
    • Your dhcp server must be telling them to use that for the dns server. If you want to use something else, set your DNS server in System -> Network -> Interfaces to your local dns server or router.
      omv 5.0.10 usul | 64 bit | 5.0 proxmox kernel | omvextrasorg 5.1.1
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Hi ryecoaaron,

      Thanks for your response, but no. 1.1.1.1 is not specified anywhere in my network and is not listed as a DNS server on any of my other 50 "ish" clients on the network.
      I have already tried specifying my router ip as the only dns server via the omv gui network interfaces and yet still 1.1.1.1 returns to resolv.conf

      here is the resolv.conf from one of my omv pi's:
      cat /etc/resolv.conf
      nameserver 1.1.1.1
      nameserver 10.112.2.1
      nameserver 192.168.4.1

      where 10.112.2.1 is the router address on the private lan and 192.168.4.1 is the router address via the wifi adapter connected to the guest network - neither of which was manually assigned on the omv, just retrieved via dhcp from the router.

      here is the contents of all the dhcp leases output from one of the omvs:

      root@home-vault:/var/lib/dhcp# cat *
      lease {
      interface "en0";
      fixed-address 10.112.2.70;
      server-name "ecosystem.home.cisco.com";
      option subnet-mask 255.255.255.0;
      option routers 10.112.2.1;
      option dhcp-lease-time 86400;
      option dhcp-message-type 5;
      option domain-name-servers 10.112.2.1;
      option dhcp-server-identifier 10.112.2.1;
      option dhcp-renewal-time 43200;
      option broadcast-address 10.112.2.255;
      option dhcp-rebinding-time 75600;
      option host-name "Home-Vault";
      option domain-name "home";
      renew 2 2018/08/14 16:44:03;
      rebind 2 2018/08/14 16:44:03;
      expire 2 2018/08/14 16:44:03;
      }
      lease {
      interface "wlan0";
      fixed-address 192.168.4.116;
      server-name "ecosystem.home.cisco.com";
      option subnet-mask 255.255.255.0;
      option routers 192.168.4.1;
      option dhcp-lease-time 3600;
      option dhcp-message-type 5;
      option domain-name-servers 192.168.4.1;
      option dhcp-server-identifier 192.168.4.1;
      option dhcp-renewal-time 1800;
      option broadcast-address 192.168.4.255;
      option dhcp-rebinding-time 3150;
      option host-name "home-vault";
      option domain-name "home";
      renew 2 2018/08/14 16:44:02;
      rebind 2 2018/08/14 16:44:02;
      expire 2 2018/08/14 16:44:02;
      }
      root@home-vault:/var/lib/dhcp#


      here is the ipconfig from one of my windows clients:
      Ethernet adapter LAN:

      Connection-specific DNS Suffix . : home
      Description . . . . . . . . . . . : blanked
      Physical Address. . . . . . . . . : blanked
      DHCP Enabled. . . . . . . . . . . : Yes
      Autoconfiguration Enabled . . . . : Yes
      IPv6 Address. . . . . . . . . . . : blanked(Preferred)
      Temporary IPv6 Address. . . . . . : blanked (Preferred)
      Link-local IPv6 Address . . . . . : blanked(Preferred)
      IPv4 Address. . . . . . . . . . . : 10.112.2.192(Preferred)
      Subnet Mask . . . . . . . . . . . : 255.255.255.0
      Lease Obtained. . . . . . . . . . : 14 August 2018 15:23:25
      Lease Expires . . . . . . . . . . : 15 August 2018 15:23:25
      Default Gateway . . . . . . . . . : 10.112.2.1
      DHCP Server . . . . . . . . . . . : 10.112.2.1
      DHCPv6 IAID . . . . . . . . . . . : 512799004
      DHCPv6 Client DUID. . . . . . . . : blanked
      DNS Servers . . . . . . . . . . . : 10.112.2.1
      NetBIOS over Tcpip. . . . . . . . : Enabled
      Connection-specific DNS Suffix Search List :
      home



      and there are no static dns servers specified on my router.
      Can you think of anything in the omv v4 armbian build that would be imposing this new cloudflare dns server?

      Many thanks in advance.

      The post was edited 3 times, last by OviumNewbie: additional info ().

    • OviumNewbie wrote:

      Can you think of anything in the omv v4 armbian build that would be imposing this new cloudflare dns server?
      Yep, I guess I never looked on the armbian image. They use resolvconf and the following file forces the system to use 1.1.1.1. So, just remove the line in this file: /etc/resolvconf/resolv.conf.d/head
      omv 5.0.10 usul | 64 bit | 5.0 proxmox kernel | omvextrasorg 5.1.1
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!