[SOLVED] Imposible change web directory with Openmediavault-nginx

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • [SOLVED] Imposible change web directory with Openmediavault-nginx

      Hi.

      I need change directory were I put my web files. I use nginx plugin, but not change it. I configure a server, and always show index.html in /usr/share/nginx/html. You can see my server configuration.

      Please, any idea? I don't know what happend.

      Thanks.
      Images
      • Captura de pantalla 2018-08-26 a las 12.10.21.png

        57.87 kB, 682×599, viewed 49 times
    • If you are using an index.php page, do you have the Use Index and index.php checkboxes checked?
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • spascual wrote:

      I use index.html, but I try with index.php with checkboxes checked, and not work
      Do you have an index.html or index.php page in the shared folder? Have you tried going directly to one of the pages in the shared folder?
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • spascual wrote:

      Both, in /usr/share/nginx/html, but I want put it in /sharedfolders/web. I config a server with /sharedfolders/web, but show index.html or index.php from /usr/share/nginx/html.
      To start, stop doing anything with /usr/share/nginx/html. That has nothing to do with the new server config that the plugin creates. What is the output of:

      cat /etc/nginx/sites-available/zzz-omv-nginx
      grep srv /etc/nginx/sites-available/zzz-omv-nginx | cut -d '"' -f2 | xargs ls -al
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Hi.

      To cat /etc/nginx/sites-available/zzz-omv-nginx

      server {
      listen 80 default_server;
      listen [::]:80 default_server;
      set $root_path "/srv/dev-disk-by-id-ata-WDC_WD40EFRX-68WT0N0_WD-WCC4E4DC5LA0-part1/web";
      index index.html;
      access_log /var/log/nginx/8c747147-04c4-419c-92f0-840e01ab1e64-access.log;
      error_log /var/log/nginx/8c747147-04c4-419c-92f0-840e01ab1e64-error.log;
      large_client_header_buffers 4 8k;
      }

      And to grep srv /etc/nginx/sites-available/zzz-omv-nginx | cut -d '"' -f2 | xargs ls -al

      total 20
      drwxrwsr-x+ 2 root users 4096 ago 26 11:09 .
      drwxrwsrw-+ 18 spascual users 4096 ago 26 11:08 ..
      -rw-rwxr--+ 1 spascual users 4096 ago 26 11:09 ._index.html
      -rw-rwxr--+ 1 spascual users 68 ago 26 10:50 index.html
    • Since I don't see a server name line, I assume you have the OMV web interface running on a port other than port 80?

      While I hate ACLs and don't know how you have them set on your shared folder, I don't see any reason your setup should not be working.
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • spascual wrote:

      Any idea what to look?
      The log files. There is a button to view the logs in the nginx plugin.
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Nothing, Error log is empty an Access log with show access.

      I´m crazy.

      I try in other computer with other OMV installation with the same result. Something fail in configuration, but I follow different tutorials and nothing change. ;(

      UPDATE: In the other installation, I delete shared folder, nginx plugin servers, and I create it again and works. I do it in my real server and not work. ¿?

      The post was edited 3 times, last by spascual ().

    • It must be something you are doing. All I can think is your ACLs are too restrictive.
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!