OpenVPN - can't log in

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • OpenVPN - can't log in


      I reinstall OMV from scratch to upgrade from PMV V3 to OMV 4 in the end of august.

      I add the plugin OpenVPN and I can't connect to the VPN neither with a mobile phone nor with my computer.
      With OMV V3, I have no problem, I install, configure user and all works fine.

      With OMV 4, I always have a timeout error.
      I don't modify my router configurationa nd the port 1194 is opened.
      I have no error during OpenVPN installation and/or configuration.

      How can I have an access to the OpenVPN error log from the OMV webinterface so I can't debug

      Is anyone have such a problem ?
    • Mr.Grape wrote:

      is openvpn the official part of omv? If not...
      no idea what you mean. are there "unofficial" plugins?

      thats what I did:
      OMV3: install openvpn plugin (openmediavault-openvpn 3.0.6) via web plugin installer -> works perfectly
      OMV4: install openvpn plugin (openmediavault-openvpn 4.0.1) via web plugin installer -> does not work (see links in my above post)


      I havent tried the solution that solved the issue for gromgsxr.
      odroid hc1 | omv 4.1.17-1 (Arrakis) | 4.19.14-odroidxu4
    • After poking a while to make this work and yes THIS thread helped a lot to figure out my problem. Could not find a tutorial for this at all but here it is my attempt of creating one:

      - First install the plugin (openmediavault-openvpn 4.0.1)

      General settings:
      - Configure the plugin:
      - enable: true
      - port: 1194
      - use compression: true
      - PAM: true

      VPN network:
      - Address:
      - MASK:
      - Gateway interface: your internet interface (mine is ens5, but the interface is in the dropdown list just select the one connected to the internet)
      - Default gateway: true

      DHCP options
      everything is empty

      - Public address: your IP or if NO-IP use your

      - ssh into your server
      - cd /etc/openvpn/
      - nano server.conf
      - find in this file something like ;push "route" (the IP address can be different 192.xx.xx.xx)
      - in the above two things need to be changed first remove the ; if you have one in your config file, and than change the IP to the same VPN address
      - From this: ;push "route" to this: push "route"
      - restart the openvpn service: service openvpn status check if already started service openvpn stop, service openvpn status be sure it stopped, service openvpn start, service openvpn status be sure it started

      - first create a user from left menu ACCESS RIGHTS MANAGEMENT -> User
      - navigate back to your openVPN -> certificates click on ADD and select the user and give it a common name and finally save.
      - select the user and click on DOWNLOAD CERTIFICATE
      - Extract the archive
      - in your VPN GUI import *.ovpn file

      - if you have a router between your server and internet do not forget to open port 1194 UDP
      Check out my OMV THEME CHANGER
      I do't do support on private, except for theme changer related issues.

      The post was edited 2 times, last by Virgil.A ().

    • Thx,
      i tried the changes on my server.
      The Port 1194 is opened for TCP and UDP.

      In my openvpn-software i got the error:
      Sat Oct 20 21:44:24 2018 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
      Sat Oct 20 21:44:24 2018 TLS Error: TLS handshake failed