smb.conf missing share definitions

    • OMV 4.x
    • Resolved
    • smb.conf missing share definitions


      I'm trying to get OMV to replace an old Ubuntu Server NAS setup (more or less like for like).

      I can successfully setup and add a shared folder definition in the web GUI, and it appears to apply the permissions to the folder path just fine.

      I get the following error with smbclient:

      sudo smbclient //host.domain/sharename --user=myuser

      tree connect failed: NT_STATUS_BAD_NETWORK_NAME

      Initial search suggested it was a permissions issue with the folder permissions, but unless there's a special samba user that needs to be granted permissions, they look fine to me.

      I have noticed however that the smb.conf file is missing anything under the share definitions section. I know some Linux systems use referenced files where the settings are maintained separately, but shouldn't the share definitions turn up in here on OMV?

      Have I missed something?

    • Same result with the IP. The DNS resolves just fine, the "network name" in the error is a Samba error received from the server so it's not a networking issue.

      I've also tried running omv-mkconf samba and performing a reboot of the system, but the share definitions section is still empty.