Transcoding failure Plex - Docker

    • Transcoding failure Plex - Docker

      Hey guys

      I'm in a bit of a pickle , i'm having some issues getting transcoding to work for Plex running in Docker.
      I installed OMV + Docker + Plex following the guide of Technodad.
      I also read through following post and comments ( Plex not transcoding. Docker. )

      I didn't want my Transcoding folder to be under /sharedfolders so I created a directory /transcode directly in the root of my SSD.
      I gave the user 'Ymir', this is the user running all the docker containers, the necesarry rights (as suggested by user 'gderf' in above mentioned forum post) on this folder:

      Source Code

      1. drwxr-sr-x 3 Ymir users 4096 Oct 13 16:48 transcode

      Now, when I play a video file (MPEG2VIDEO in this example) I can see a file being adding to the directory '
      /transcode/Transcode/Sessions' for transcoding:

      Source Code

      1. root@kattegat:/transcode/Transcode/Sessions# ls -al
      2. total 12
      3. drwxr-sr-x 3 Ymir 911 4096 Oct 13 17:29 .
      4. drwxr-sr-x 3 Ymir 911 4096 Oct 13 15:48 ..
      5. drwxr-sr-x 2 Ymir 911 4096 Oct 13 17:29 plex-transcode-zgdt9fnrugpsxh5qyc05qomj-4ded9c49-b2d0-45e8-ac9e-f0bf3ebc6ede

      But after +/- 30 seconds the file disappears and I get follow error in Plex:

      Conversion failed. The transcoder exited due to an error.

      (The directories /transcode/Transcode and /transcode/Transcode/Session have the same rights as /transcode.)

      I also tried with giving 777 permissions on the directories, but the issue is still the same.

      Can you guys help me out? Are there logs somewhere that could give me the answer? (I already went through the plex logs which I downloaded through the GUI but found nothing)

      Thanks in advance!
    • NoobNoob wrote:

      I moved the /config docker directories to my SSD and now it works.
      They were on my Raid5 file system which had the 'noexec' option in /etc/fstab.

      Thank you, you're the best!
      Just be aware that the PMS database can become quite large, depending on the size of your libraries and how you have set things up within Plex. This can easily fill up your rootfs, breaking OMV.
      OMV 4.x - ASRock Rack C2550D4I - 16GB ECC - Silverstone DS380
    • Users Online 1

      1 Guest