OMV 3 to 4 upgrade issues

    • OMV 3.x
    • Upgrade 3.x -> 4.x
    • There is something more i remarked when doing 'apt-get update' from CLI:

      Source Code

      1. Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0x7f6ab817f730>
      2. Traceback (most recent call last):
      3. File "/usr/lib/python3.5/weakref.py", line 117, in remove
      4. TypeError: 'NoneType' object is not callable
      5. Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0x7f6ab817f730>
      6. Traceback (most recent call last):
      7. File "/usr/lib/python3.5/weakref.py", line 117, in remove
      8. TypeError: 'NoneType' object is not callable
      9. Paketlisten werden gelesen... Fertig
    • You can ignore this. There are many posts about this in the forum.

      To fix it
      wget -O /usr/lib/python3.5/weakref.py https://raw.githubusercontent.com/python/cpython/9cd7e17640a49635d1c1f8c2989578a8fc2c1de6/Lib/weakref.py
      Odroid HC2 - armbian - OMV4.x | Asrock Q1900DC-ITX - Intenso SSD 120GB - OMV4.x
      :!: Backup - Solutions to common problems - OMV setup videos - OMV4 Documentation - user guide :!:
    • Ok so everything is up and running fine regarding the upgrade.
      The certificate issue had nothing to do with the upgrade.
      Same for the virtualbox issue. I have copied my OMV3 backup to check and found out that the virtualbox VMs where also not present in the OMV3 installation.
      No idea where they went. Got lost somewhere on the way. I do remember that I had a Windows10 VM that was running from an own partition. The partition is still there, but I have no idea how to get the VM to run with it not having any .vmdk or .vbox config file that I can find....

      The only remaining upgrade issue is the red light on MySQL in the Web GUI. It seems not to harm except it is bugging me mentally (and harms my eye) :)
    • monsen wrote:

      The only remaining upgrade issue is the red light on MySQL in the Web GUI. It seems not to harm except it is bugging me mentally (and harms my eye)
      Maybe now would be the time to use docker for mysql since I posted the plugin is going away in OMV 5.
      omv 5.1.0 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.1.5
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!